Cannot get Abbey Road Studio to work in MuLab

Official support for: mutools.com
KVRAF
2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Wed Sep 30, 2020 10:44 am

Hi,

I can't get Waves Abbey Road Studio to work. When I try to load it on a track, a popup appears (see attached pic). If I just drag it to the rack from File Explorer, I get a popup saying Skip/Rescan. Rescan yields the result in the pic (also if I choose Browse... in the regular MUX/VST window), and Skip gives a tiny, tiny window, with the letter "g" in it (the rest is cutoff and a black little square.

Help needed (just noted the Waves sale runs out tonight). :wink:

As seen in the screenshot, I'm on Windows 10, 64 bit. I can open the file in other hosts (Cakewalk, Traction, as I don't see the need for purchasing another DAW than MuLab :tu: ).

Thanks!
Abbey.png
You do not have the required permissions to view the files attached to this post.
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

User avatar
Banned
88 posts since 20 Sep, 2020

Post Wed Sep 30, 2020 11:07 am

mulabs dont load waveshell, try to a vst /au host like kushview element

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Wed Sep 30, 2020 2:00 pm

vskunk wrote:
Wed Sep 30, 2020 11:07 am
mulabs dont load waveshell, try to a vst /au host like kushview element
Ah thanks! So I assume you mean I need a wrapper to run plugins by Waves in MuLab? I'm looking at Element now, and hope it will do the trick. :tu:
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Wed Sep 30, 2020 2:10 pm

Ah okay, now that I knew what to look for, I see that others have had issues with "waveshell". I start sensing why people on KVR are a bit... well, whatever they fell, they're not only happy anyway with Waves.

Here's a thread re MuLab and Waveshell. viewtopic.php?f=79&t=473348&hilit=waveshell&start=30
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Wed Sep 30, 2020 4:54 pm

OKAY.... So now I have managed it! Using Element, just as suggested. Got Abbey Road Studio 3 - what a revelation for fifty dollars (intro pricing ending tonight I think)! Loaded up Element in MuLab, added ARS3, dragged the left and right cables à la MUX style, and it worked! :tu:
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

KVRist
319 posts since 28 Oct, 2002

Post Thu Jan 14, 2021 6:47 am

Just had to update my waves plugins and normally shell to waves works fine to run them in Mulab, but not this time. I'll sort something out , but its made me wonder if, when Mulab has support for vst3 the waves plugins would run ok then, without having to have work arounds? Would that be a possibility Jo?

KVRist
319 posts since 28 Oct, 2002

Post Thu Jan 14, 2021 8:30 am

By chance I found some waves dll's today in, C > Program Files > VSTPlugins > Waves, I dont recall using this folder before as my vst plugins are all on another drive, maybe I've been doing it wrong for years??. Most of the plugins seem to work in Mulab without a "shell", one that doesnt is AR TG Mastering and a couple of really old plugins, but Abbey Road Studio does,,, well here it does. I've now copied and pasted the plugins (that work) to my normal vst folder for use in Mulab. Can someone check to see if they have to same folder and if so can they use the waves plugins without an extra wrapper of shell?

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Sat Jan 16, 2021 4:00 pm

heks wrote:
Thu Jan 14, 2021 8:30 am
By chance I found some waves dll's today in, C > Program Files > VSTPlugins > Waves, I dont recall using this folder before as my vst plugins are all on another drive, maybe I've been doing it wrong for years??. Most of the plugins seem to work in Mulab without a "shell", one that doesnt is AR TG Mastering and a couple of really old plugins, but Abbey Road Studio does,,, well here it does. I've now copied and pasted the plugins (that work) to my normal vst folder for use in Mulab. Can someone check to see if they have to same folder and if so can they use the waves plugins without an extra wrapper of shell?
Hi, you mean that you wonder whether you can use Waves stuff since you found their dll files?

I wouldn't think so - dll files are not exclusive to VST, but made for all sorts of applications.

Still, did you get it to work by any chance?
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

KVRist
319 posts since 28 Oct, 2002

Post Sun Jan 17, 2021 4:12 am

I had not found these "dll" versions before, I stumbled upon them. I have always used shelltowave to use waves plugins in Mulab. I was wondering if every one else has these or if shell to waves has done some thing, , , it works in mysterious way's at times. Also wondered has Waves themselves changed something? I've had Waves plugins for years and years and Orion and Mulab are the only DAW's that did not "see" Waves plugins , so needed a work around for them. To answer your question, yes Abbey Road Studio is working, using the dll I found, but I don't have a head tracker yet so can't say if that works.

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Thu Jan 21, 2021 4:44 pm

heks wrote:
Sun Jan 17, 2021 4:12 am
yes Abbey Road Studio is working, using the dll I found
Wow! That is amazing! WiIll try it our this weekend. :tu:
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

KVRist
319 posts since 28 Oct, 2002

Post Fri Jan 22, 2021 2:30 am

SparkySpark wrote:
Thu Jan 21, 2021 4:44 pm
heks wrote:
Sun Jan 17, 2021 4:12 am
yes Abbey Road Studio is working, using the dll I found
Wow! That is amazing! WiIll try it our this weekend. :tu:
Just to recap, I found the Abbey Road dll's in C> Program Files VSTPlugins > Waves. There is also a whole load of WaveShell's in the C drive VSTPlugin folder. I normally used shell2vst64 to make "normal" vst's out of the shell's and then put them in my "J Drive" that's full of vst's to use in Mulab. So, I don't know if waves central has done something or I messed something up and put some de-shell'd waves plugins in the Program files.
If you don't have the dll's on your system SparkySpark try using shell2vst found here http://www.xlutop.com/buzz/zip/shell2vst.zip.
It can be temperamental at times but some of the Waves plugins are well worth persevering with to be able to use them in MuLab. Good luck hope it works :)

KVRist
319 posts since 28 Oct, 2002

Post Fri Jan 22, 2021 3:08 am

I've just checked the above link to see if it still worked and downloaded shell2vst again, I noticed a howto file and read it, apparently C Program file vstplugins is where the converter defaults to. So the dll's I found have been converted previously by shell2vst to Program File as well as the folder I wanted them in. I must have forgotten that :dog: :oops: But, do try shell2vst Sparkyspark, all my Abbey Road plugins work fine in Mulab once converted.

KVRAF

Topic Starter

2079 posts since 30 Aug, 2004 from Lancaster, UK

Post Tue Jan 26, 2021 10:29 am

heks wrote:
Fri Jan 22, 2021 3:08 am
I've just checked the above link to see if it still worked and downloaded shell2vst again, I noticed a howto file and read it, apparently C Program file vstplugins is where the converter defaults to. So the dll's I found have been converted previously by shell2vst to Program File as well as the folder I wanted them in. I must have forgotten that :dog: :oops: But, do try shell2vst Sparkyspark, all my Abbey Road plugins work fine in Mulab once converted.
Hey, thanks a bunch! Really worked well with shell2VST.

Note to self and others: I dropped this file "WaveShell1-VST 11.0_x64.dll" on this file "shell2vst64.exe". All Waves stuff ended up in a folder named Waves in the same folder as WaveShell1-VST 11.0_x64.dll.

Opens up new possibilities really, having Waves as "true" VSTs. :party:
Thu Oct 01, 2020 1:15 pm Passing Bye wrote:
"look at SparkySpark's post 4 posts up, let that sink in for a moment"
Go MuLab!

Return to “MUTOOLS”