Windows WASAPI Driver

Official support for: mutools.com
KVRist
123 posts since 10 Jan, 2010 from York, UK

Post Fri Apr 16, 2021 11:54 pm

I use a Focusrite USB interface (Scarlett 4i4).

In Audacity audio editor (version 3.0.0), I can set the 'host' to be "WIndows WASAPI" - then if I hit Audacity's record button it will record any sound that is currently playing on the PC (eg MP4 files, YouTube videos, etc). However, It is not able to record the sound of a MuLab project being played.

I believe this is because the WASAPI driver would need to be enabled in MuLab to allow it communicate with Audacity ? I'm guessing that MuLab doesn't currently support WASAPI, and am wondering if there are any future plans to do that, although maybe not as a high priority.

I read somewhere that, for example, in Reaper, the WASAPI driver can be selected and the Reaper playback can be recorded in Audacity.

Les Johnson
York, UK
Image

User avatar
KVRAF
10972 posts since 24 Jun, 2008 from Europe

Post Sat Apr 17, 2021 12:08 am

Indeed no Wasapi in MuLab. But note you can record all (live) audio of MuLab in MuLab itself.

KVRist

Topic Starter

123 posts since 10 Jan, 2010 from York, UK

Post Sat Apr 17, 2021 1:27 am

Thanks Jo. It's not a big issue for me, especially if Mulab output can be recorded into MuLab itself. But I'm not sure how to achieve that.
eg
4 x midi tracks (Piano, Guitar, Bass, Drums), targeted to Racks 1 (Piano), 2 (Guitar), 3 (Bass), and 4 (Drums).
Add a new audio track (eg with target = Rack 5), and draw an Audio Sequence part.

Arm the audio track, and bring up the 'Rack 5' audio recorder settings window, to select the source to record from.
The listed sources are 'Direct Audio Input' / Piano / Guitar / Bass / Drums / Input 1 / Master Recorder / 'None'.

Selecting one of the instrument tracks, eg 'Piano', records that track only. That works fine.
But selecting 'Direct Audio Input' (or 'Input 1', or Master Recorder, or 'None') doesn't record any of the playback.

How to record all four un-muted midi tracks at once ?

Thanks.
Image

User avatar
KVRAF
10972 posts since 24 Jun, 2008 from Europe

Post Sat Apr 17, 2021 1:38 am

It's about recording the output of your master rack.
So add a new audio track, but route the output of the newly added rack directly to the main outs, not to the master rack.
Then you will see that the list of inputs for the audio record will include the master rack.
Does this help?

KVRist

Topic Starter

123 posts since 10 Jan, 2010 from York, UK

Post Sat Apr 17, 2021 2:02 am

Yes, of course. Sorry Jo, I wasn't thinking clearly !
When I re-route the output of the new audio track (to 'Output 1+2', instead of 'Master'), it all works fine.

As always, thanks for sorting me out quickly !
Image

Return to “MUTOOLS”