Recording Audio on a Mac Trouble! SOLVED!!!

Official support for: mutools.com
User avatar
KVRian
529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 4:05 pm

I can't seem to get the microphone input working. The left and right direct input say NONE, and I do not have an option for anything else.
Screen Shot 2021-11-15 at 5.02.21 PM.png
You do not have the required permissions to view the files attached to this post.
Last edited by tommyzai on Tue Nov 16, 2021 10:36 am, edited 2 times in total.

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 6:07 pm

When you click the arrows next to None, do you see Input 1, 2, ... ?
If not, that is because the audio engine is off.
To fix it, make sure the MuLab Audio Setup is correct (e.g. it shows your audio interface)
If you change to a wrong Core Audio Device MuLab will popup, Cant start Audio Engine.
Audio Setup automatically gets info from the MacOS Utilities/Audio Midi Setup.app
If everything looks ok in MacOS, your interface may be off, or disabled if you are running in safe mode, etc.
https://www.mutools.com/info/M8/docs/mu ... rding.html
buying happiness

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 6:28 pm

Michael L wrote:
Mon Nov 15, 2021 6:07 pm
When you click the arrows next to None, do you see Input 1, 2, ... ?
If not, that is because the audio engine is off.
To fix it, make sure the MuLab Audio Setup is correct (e.g. it shows your audio interface)
If you change to a wrong Core Audio Device MuLab will popup, Cant start Audio Engine.
Audio Setup automatically gets info from the MacOS Utilities/Audio Midi Setup.app
If everything looks ok in MacOS, your interface may be off, or disabled if you are running in safe mode, etc.
https://www.mutools.com/info/M8/docs/mu ... rding.html
Thanks, Michael and HELLO! No inputs next to NONE. Everything seems fine, except . . . in System Preferences/Security & Privacy/Microphone MuLab is not listed. Note: I am trying to use my internal microphone as a test. I will try connecting the interface and go from there, but I should be able to record with the built-in mic, too, right? I don't have any + sign or way to select and add an app in this field. I might reinstall and restart to see if it shows up then.

Image
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 6:47 pm

Hi!!
You can add (+) MuLab to that Privacy list. To record from the internal microphone, you will need to setup an Aggregate Device (or Multi-Output, I forget which). Beware of feedback! You and I had a chat about that very thing in this Forum years ago! IIRC you succeeded, but it was a PITA.

I recommend recording through your audio interface!
buying happiness

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 7:03 pm

Thanks again, Michael L.

The latest version of MuLab claims to have fixed the privacy/microphone issue:

"MuLab for Mac: On Mojave and up, MuLab couldn't access the microphone due to the new MacOS privacy rules. This update now includes support for this microphone privacy setting."

Although I plan to use my audio interface, I'd like the option to noodle around using the internal microphone. I just can't seem to add MuLab to the privacy list. Do I have to set up an Aggregate Device to do this? All my other audio apps show up. I'd like MuLab to appear as well. ;-)

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 7:05 pm

Michael L wrote:
Mon Nov 15, 2021 6:47 pm
You and I had a chat about that very thing in this Forum years ago! IIRC you succeeded, but it was a PITA.
Yikes!! Each time I try to use MuLab as my one and only I get stuck in the same place. ;-0

I'm trapped in Virtual Audio Groundhog day.

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 7:08 pm

tommyzai wrote:
Mon Nov 15, 2021 7:05 pm
I get stuck in the same place.
To add MuLab to Privacy, click the lock, click the +, navigate to MuLab, click MuLab to add it to the list, then check the box next to MuLab.
Last edited by Michael L on Mon Nov 15, 2021 7:15 pm, edited 1 time in total.
buying happiness

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 7:14 pm

Michael L wrote:
Mon Nov 15, 2021 6:47 pm
. . . To add MuLab to Privacy, click the lock, click the +, navigate to MuLab, click MuLab to add it to the list, then check the box next to MuLab.
I can't find + to click.

Image
You do not have the required permissions to view the files attached to this post.

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 7:26 pm

Hmm.
MuLab should be on that long list.
If you don't allow the microphone, it will just uncheck it.
MuLab should give you a new microphone access prompt when you open each new version.
Are you using the latest version?
( But If I "don't allow" the microphone, I still see Inputs in the Recording dialogue )
Last edited by Michael L on Mon Nov 15, 2021 7:50 pm, edited 1 time in total.
buying happiness

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 7:46 pm

Michael L wrote:
Mon Nov 15, 2021 7:26 pm
Hmm. MuLab should be on that long list.
MuLab should give you a microphone access prompt when you open each new version.
Are you using the latest version?
Yes, I'm on the latest, which has added this feature. There is no prompt. Do you think if I get this squared-away my audio recording problem will also be solved?

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 7:50 pm

Which OS are you?
Did you scroll through the entire Privacy>Microphone list?
Do you have a microphone and audio interface?
buying happiness

User avatar
KVRian

Topic Starter

529 posts since 12 Jan, 2011

Post Mon Nov 15, 2021 8:36 pm

Michael L wrote:
Mon Nov 15, 2021 7:50 pm
Which OS are you? Did you scroll through the entire Privacy>Microphone list?
Do you have a microphone and audio interface?
I'm on 11.6 Big Sur.
Yep, no MuLab in the list.
I have both. I will try again with Interface tomorrow. Much appreciation for helping me work through this.

User avatar
KVRAF
3794 posts since 25 Jan, 2014 from The End of The World as We Knowit

Post Mon Nov 15, 2021 9:00 pm

One last idea:
If you updated MacOS after you installed MuLab, the OS might not have retained the previous permission.
So, try trashing just the app, then download the app update installer from MuTools, and reinstall. You should get a new microphone permission request.
buying happiness

User avatar
KVRAF
11198 posts since 24 Jun, 2008 from Europe

Post Mon Nov 15, 2021 10:56 pm

tommyzai wrote:
Mon Nov 15, 2021 7:03 pm
Although I plan to use my audio interface, I'd like the option to noodle around using the internal microphone. Do I have to set up an Aggregate Device to do this?
Yes. Cfr https://www.mutools.com/info/M8/docs/mu ... rding.html

User avatar
KVRAF
11198 posts since 24 Jun, 2008 from Europe

Post Mon Nov 15, 2021 10:58 pm

Michael L wrote:
Mon Nov 15, 2021 7:26 pm
( But If I "don't allow" the microphone, I still see Inputs in the Recording dialogue )
Iirc in that case the Mac will only send silence to the app, MuLab in this case. That's how it implements the privacy.

Return to “MUTOOLS”