MuLab for Mac M1?

Official support for: mutools.com
User avatar
KVRian

Topic Starter

1136 posts since 25 Sep, 2014 from Specific Northwest

Post Fri Nov 19, 2021 7:46 am

It's the first comment, but you have to open it up to see the full comment. "Expert Opinion" indeed!

User avatar
KVRAF
11210 posts since 24 Jun, 2008 from Europe

Post Fri Nov 19, 2021 9:48 am

Ok i was first searching in the q&a section, which is different from the comments section. Found it now. Thx for the link. Well, maybe the reviewer did not know about the Quarantine Remover, cfr https://www.mutools.com/info/M8/docs/mu ... ation.html

User Rpagala reported that MuLab runs fine on Mac M1, so it seems to be possible. Via Rosetta i assume.

KVRist
72 posts since 20 Feb, 2013

Post Sun Nov 21, 2021 3:26 am

Is there any experience with Mulab and the M1 processor, which can be shared? How is the performance? Are there any issues with plugins etc.? Perhaps the user Rpagala can answer these questions.

KVRist
134 posts since 31 Mar, 2017 from New Caledonia

Post Sun Nov 21, 2021 4:19 am

May I suggest that M1 relative questions could be put in a separate topic, in order to keep this one focused on M9?

KVRist
72 posts since 20 Feb, 2013

Post Sun Nov 21, 2021 4:41 am

Yes, thank you. I have alread started a thread about Mulab and the M1, but got rarely reponse. After the discussion in this thread was quite intensive, I took the chance to get informations here. But I agree that a special thread would be appropriate.

User avatar
KVRAF
11210 posts since 24 Jun, 2008 from Europe

Post Sun Nov 21, 2021 9:03 am

I've split the Mac M1 related posts to this separate topic.

KVRian
1314 posts since 11 Nov, 2013

Post Sun Nov 21, 2021 11:40 am

i see the message on top. it is from nov 2020. maybe newer mac os work better.
2,0 von 5 Sternen Not recommended for audio-applications
Rezension aus Deutschland vom 28. November 2020
Größe: 256GBVerifizierter Kauf
Price was €778 (8 GB RAM, 256 GB SSD)

There are no cables included except for a power-cable.

There is no handbook included.

I had no major problems with making the OS run (I did not migrate from another machine).
Only the German USB keyboard (non Apple) was not detected correctly. The @ key, which is necessary to enter the email, did not work.

Booting time is 25 seconds till the login-screen. Another 7 seconds to desktop.
Shutdown time is 5 seconds

GUI performance is good

The overall look & feel is nice

Safari works fine. Web performance is good

The Logitec G502 Mouse works fine

My LG 4K screen which is connected through USB(Thunderbolt?) works, but I have some issues. The system did not wake up, after the Energy Saver became active. I had to do a cold reset of the Mac. I disabled the energy saver as a workaround.
The screen is also not always detected.

WLAN works fine

When I click on my HD it says it only has a capacity of 245 GB, the OS also seems to need 11-30 GB (sorry I missed to do an exact measurement here, please update me with more detailed info). A little more than 210 GB free disc-space should remain in practise.

The CPU is faster than my Intel I3, but slower than my Ryzen 3800. For audio processing I'd say it is comparable to a strong Intel I7, which has 4 cores (+4 virtual ones for hyperthreading).

The Mac mini is really quiet.

Reaper does not work. The app does not launch. Apple cannot check it for malicious software. “This software needs to be updated. Contact the developer for more information.”
One day later I and many reboots later was able to make Reaper work.

Flstudio can’t be installed. Apple cannot check it for malicious software. “This software needs to be updated. Contact the developer for more information.”
After many tries and a freeze the installer it is running.
Now audio-output does not work (I didn’t change anything so far) “The required sample rate (44100 Hz) is not supported by the CoreAudio output. “Could not enable the CoreAudio device”.
Note: I got no soundcard connected to the Mac Mini. So the audio-output ‘internal speaker’ or ‘HDMI’ are available.

Bitwig does not launch. I tried again half an hour later. Now suddenly 3 Rosetta installers pop up at the same time. I tried again and now Bitwig is now running in Intel mode. The interface feels a slightly ‘sluggish’ because of Rosetta. I’d say it feels similar to my Mac mini from 2018. I will need to run some more tests for a more detailed info about CPU performance.

GarageBand works, but does not list AudioUnits (which are Intel?). There does not seem to be support for Intel-AudioUnits.

Logic Pro 10.6 (fullversion) download from “the Apple cloud” is very slow. It is only 1.1 GB and needed 30 minutes on a DSL 50000 line.
After a reboot Tone2 Saurus 2.6, Tone2 Electra 2.8 and Tone2 Icarus2 seem to work in Logic.

Ableton Live works in Rosetta. The Tone2 VST plugins successfully load

MuLab (a not so well-known host) doesn’t work at all. “MuLab cannot be opened because the developer cannot be verified. macOS cannot verify that this app is free from malware.” A righ-click and Open did also not help.

Since Catalina is not longer possible to create own directories into root. Fixing it is really tricky. You need to create a symbolic link in root directory via synthetic.conf or need to switch of security completely (which will be not explained here for given reasons).

Audiounit validation is broken, which is a well-known problem since many years. But now it seems to be completely broken? The post-flight script for .pkg installers to fix it and force a restart of the scan does not longer work always. As a result “auval” does not detect recently installed AudioUnits.
Rebooting does solve the problem and AudioUnit plugins are detected.
Logging out and in may also solve the issue. I still haven’t tested it

Iceberg Packages (an App) does not launch. Apple cannot check it for malicious software. “This software needs to be updated. Contact the developer for more information.” Right-click and Open did work as a workaround.

CMake (an App) seems to work.

The XCode 12 installer (an Apple product for programming software) hangs. I get a duplicate Icon with an X in Applications which does not disappear for 20 minutes, although the software installation had already been completed successfully.
I was able to compile a VST 3.7 plugin for the M1 chipset, but had trouble. On macOS 10.14 I had placed my build directory and other stuff into root. Since Catalina is not longer possible to create own directories into root. Fixing it was tricky.
XCode 12 builds against the 11.0 SDK. There are many files missing which had been included in older SDKs. This means trouble if you want to port older projects to the M1 chipset.

XCode 11 and 10 can not be run within Big Sur. Apple did deactivate the installers. You are forced to use XCode 12. All programmers need to migrate their projects to XCode 12, which can be problematic if you used for example gcc as a compiler.

Not all IPad Apps are available. I have been looking forward to be finally able to play “The Elder Scrolls: Blades”. However it is not available in the App Store. It seems that quite a few devs do not want to see their IPad Apps on the mac.

Summary:

Apps that run in Rosetta feel slightly laggy to mouse-clicks. It is not a big issue. Most users won’t even notice it.
The GUI performance of Apps running in Rosetta is fine. Everything looks smooth.

For audio-applications the performance seems to be similar to a strong Intel I7 with 4 cores.

Some software works. Some does does not work at all. Some software works, but still has issues.

Audiounits are not detected after an installation. Rebooting Big Sur after a plugin-installation does solve the issue.

Not all IPad Apps are available.

There are still issues with hardware-compatibility.

It is not possible to add RAM to the Mac Mini M1 or to replace the SSD.

Apple did not fix bugs which are known since many years (Audio Unit validation, German keyboards).

If you used macOS 10.14 or lower you will notice that it is not longer possible to create own directories into root easily.

Apples words that ‘developers can port their software with a few mouseclicks’ are not true. Porting software to the M1 chipset can be easy, but can also be difficult or even nearly impossible. Ports to the M1 chipset might never happen for many older products, because companies will have to make an economic decision.

You can currently run much Intel software with Rosetta2. However history has shown that Apple did remove Rossetta1 (used for the Intel transition from PowerPC) only after two years. As soon as Rosteta2 will be removed you will not longer be able to use older Intel Apps.

With Big Sur there seem to be problems with Certificates and Notarisation. It affects installers as well as apps. It could be related to a server problem on Apple’s side. Currently only a part of the software-installers work without problems. If it fails it sometimes helps to try again later
win 10 64 Build 18363 intel i5 8600K (6*3.6 GHZ) 16 GB Ram

Return to “MUTOOLS”