Granulab

Talk about all things "KVR Developer Challenge" related.
ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Post Wed Sep 05, 2018 11:22 am

|¨|_|¨|_| wrote:Which version of Bitwig?

I downloaded the demo, v 2.2.2 and installed.
Current Bitwig demo is 2.3.5. That's what I tested on Mac.
Confused it with the version on my Win machine.
Both work for me, need to investigate more...

Well, nvm.
/re

RCJacH
KVRer
14 posts since 23 Jun, 2015 from Beijing

Re: Granulab

Post Thu Sep 06, 2018 5:12 am

Apparently note off message is recognized globally - the sound stops upon releasing any note when multiple notes are being pressed.

ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Re: Granulab

Post Thu Sep 06, 2018 9:42 pm

Good call!
I had old logic for a proper note stack but it was not connected.
(last-priority, so you can hold a note and hit others both up and down)
Please try new build (09-06).

User avatar
Russell Grand
KVRAF
1544 posts since 22 May, 2017

Re: Granulab

Post Fri Sep 07, 2018 5:32 pm

I still haven't tested out Granulab yet but I'm gonna try to do so tonight. :D

User avatar
DJErmac
KVRian
651 posts since 25 Apr, 2009 from France

Re: Granulab

Post Sun Sep 09, 2018 3:06 pm

Cubase 9.5 (64, on Win 8.1 64) simply doesn't see the plugin...

ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Re: Granulab

Post Sun Sep 09, 2018 7:01 pm

40 mins no email with the download info for CB Elements from Steinberg...
Gotta hold off until tomorrow.
:-/

ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Re: Granulab

Post Tue Sep 11, 2018 1:38 am

Installed trial version of Cubase Elements.
You need to go into plugin settings (menu Studio | VST Plugin manager),
add the right folder (or drop Granny_x64.dll into one of your usual),
and hit rescan button (really small circular arrows in bottom box).
It seems Cubase doesn't auto-rescan on startup.

Showed up for me and sounded as usual.
Either that's the thing, or there is some Windows 8 issue.

User avatar
DJErmac
KVRian
651 posts since 25 Apr, 2009 from France

Re: Granulab

Post Tue Sep 11, 2018 4:04 am

Oh, thank you for your help, I see the problem now. I've downloaded Granulab v1.5 and not Granny. I was trying with the file GranuLab_151.exe. Since the plugin is supposed to be named Granulab I hadn't downloaded the files named Granny. I'm going to try again.

ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Re: Granulab

Post Tue Sep 11, 2018 12:21 pm

Ah, cool ;)

But actually it's a good reminder to reorganize the webpage.

(i'm also still ironing out the most glaring & bizarre misfeatures.
Basic stability seems ok, and the sound engine is more or less done. But the GUI/frontend needs more work.
Don't be shy to point out.)

Anyway, enjoy!

User avatar
DJErmac
KVRian
651 posts since 25 Apr, 2009 from France

Re: Granulab

Post Tue Sep 11, 2018 12:36 pm

I confirm it's correctly detected by Cubase 9.5, thank you again, all is working now !

But something is very surprising : when I unload then reload the plugin, it never reloads to default settings. It always reloads what I had just made before, it seems to remember for ever what has been made. Is it what was supposed to happen ? If so, how to reload the default settings please ?

secretkillerofnames
KVRian
565 posts since 9 Jul, 2012

Re: Granulab

Post Tue Sep 11, 2018 1:42 pm

Tj Shredder wrote:GrannyVST.vst is not accepted by Bitwig, can't test it...

Bitwigs comment:

com.bitwig.flt.library.metadata.reader.exception.CouldNotReadMetadataException: could not read metadata: Could not read VST plug-in metadata
64 bit plugin host reported errors: Pluginhost returned non zero exit code 255
Error messages:

2018-09-04 13:12:48.381 BitwigPluginHost[1188:79351] Error loading /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: dlopen(/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST, 262): Library not loaded: /System/Library/Frameworks/ColorSync.framework/Versions/A/ColorSync
Referenced from: /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST
Reason: image not found
2018-09-04 13:12:48.381 BitwigPluginHost[1188:79351] Error loading /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: dlopen(/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST, 262): Library not loaded: /System/Library/Frameworks/ColorSync.framework/Versions/A/ColorSync
Referenced from: /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST
Reason: image not found

32 bit plugin host reported errors: Pluginhost returned non zero exit code 255
Error messages:

2018-09-04 13:12:48.449 BitwigPluginHost[1189:79390] Error loading /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: dlopen(/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: mach-o, but wrong architecture
/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: mach-o, but wrong architecture
2018-09-04 13:12:48.449 BitwigPluginHost[1189:79390] Error loading /Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: dlopen(/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: mach-o, but wrong architecture
/Library/Audio/Plug-Ins/VST/GrannyVST.vst/Contents/MacOS/GrannyVST: mach-o, but wrong architecture
I'm getting this as well in Bitwig 2.4 beta 5 on OSX 10.12.6 :(

User avatar
Tj Shredder
KVRAF
1598 posts since 6 Jan, 2017 from Outer Space

Re: Granulab

Post Tue Sep 11, 2018 10:47 pm

None of my hosts load Granny... Its broken in general on OS X...

User avatar
RunBeerRun
KVRAF
7894 posts since 2 Aug, 2005 from Guitar Land, USA

Re: Granulab

Post Wed Sep 12, 2018 6:39 am

I'm listening to the standalone, sounds like Mars Landings.
Presets are all blank.
The only site for experimental amp sim freeware & MIDI FX: http://runbeerrun.blogspot.com
https://m.youtube.com/channel/UCprNcvVH6aPTehLv8J5xokA -Youtube jams

Halonmusic
KVRAF
1740 posts since 13 Nov, 2015 from Norway

Re: Granulab

Post Wed Sep 12, 2018 9:51 am

Russell Grand wrote:
|¨|_|¨|_| wrote:Thanks for holding the fort mcbpete.

Yes, there was some issue with the link that made KVR hide the Windows entry.
(and I was at work, trying to not freak out visibly ;)

What was the issue with Win10 VariKusBrainZ?
I can build 32-bit version too, just need to diddle some complier flags.
(though when I searched for the topic it looked like most don't need it)

I've updated to same version 5-10 times over the weekend (3 crash bugs fixed), but maybe it's time to start a new version number...
A 32-bit version would be beautiful for those of us like myself who refuse to progress along with technology. :hihi: :D
:tu:

ostinato-plugins
KVRer
22 posts since 30 Oct, 2016

Re: Granulab

Post Wed Sep 12, 2018 12:09 pm

DJErmac wrote:I confirm it's correctly detected by Cubase 9.5, thank you again, all is working now !

But something is very surprising : when I unload then reload the plugin, it never reloads to default settings. It always reloads what I had just made before, it seems to remember for ever what has been made. Is it what was supposed to happen ? If so, how to reload the default settings please ?
Good!

Yes, it gets back to previous view.
Default settings are in blue button top left. Shift-click to reset everything (also ADSR).

Thanks for question, I want to iron out the surprises. (and somehow label things so you know what's what...)

Return to “KVR Developer Challenge 2018”