NB01

Talk about all things "KVR Developer Challenge" related.
KVRer
3 posts since 10 Jan, 2018

Post Sat Jul 03, 2021 3:22 pm

Apologies in advance if this is the wrong forum for this. Move/warn/delete as needed.

I'm experiencing some bugs with this one. Foremost, many of the dials do not respond to mouse input. When moved they jump around and reset themselves to their defaults. This seems to have been partially addressed in the 0.1.1 update, but EQ and Master dials still have a mind of their own.

Also, when opening the plugin the interface is minimized well below the actual GUI size and it doesn't seem to remember changes after resizing it.

This is on Win 10 x64 in Reaper 6.29.

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Sun Jul 04, 2021 2:45 am

I think its perfectly alright to start a thread in this forum. I was even think of starting it myself to ask for feedback and bug reports.
So many thanks for reporting, I'll have a look at it tonight.

KVRer
1 posts since 5 Jul, 2021

Post Mon Jul 05, 2021 8:36 am

I've got a problem with the display my end. It's not showing it all in one window in Reaper, it's just showing scroll bars and one small tiny portion of the plugin.
You do not have the required permissions to view the files attached to this post.

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Tue Jul 06, 2021 12:43 am

Thanks for reporting, I have been able to reproduce the issues mentioned above, not showing the entire editor and controls not working in bypass mode, and I think I have figured out how to solve them. Expect a new release later today.

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Tue Jul 06, 2021 7:45 am

I have just uploaded an update to 0.1.2 which (at least for me, hopefully for you too) solves the display problems in Reaper, and the issue with unresponsive controls in bypass.

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Tue Jul 06, 2021 11:35 am

Sounds like a nice plugin, but still, adding the plugin causes all media to go offline in REAPER, unless playback is already running (my version is currently 6.31 x64, on Win10 21H1 x64). Also when clicking anywhere on the GUI, the space bar (play/stop) isn't passed through to REAPER (and media goes offline if playback is stopped). If I click on the plugin window's title bar (or the white strip below the actual GUI), space is passed through again and all media comes online.
This is with NB01 0.1.2
Last edited by Paul Eye on Tue Jul 06, 2021 6:44 pm, edited 1 time in total.

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Tue Jul 06, 2021 11:44 am

This white strip I mean (marked in red)
Image

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Tue Jul 06, 2021 12:35 pm

Also in REAPER, the standard preset/param/etc bar is missing. Using a DD plugin to illustrate how it should look like. Marked in red:
Image

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Thu Jul 22, 2021 7:22 am

First, apologies for the time it has taken. I have finally had some time to dig into the editor issues reported by Paul Eye and have hopefully solved them for good this time.

I have updated NB01 to version 0.1.3 with fixes for the editor being positioned over the preset bar in Reaper, and now it doesn't steal keyboard focus when you click on it, so keypresses are sent to the host instead.

Happy tweaking and please report back if something is not working. It's only a Windows release for now as that were the issues were most prominent.

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Thu Jul 22, 2021 7:09 pm

Thanks for the fixes, the focus stealing and GUI bugs are now fixed. Media still goes offline (sometimes briefly and then comes back) when loading or opening the plugin so something funky is still going on. Still, it's far more usable now than it was in 0.1.2 :)
I like this. It seems simple but it's capable of some nice sound mangling when tuned just right. Fits well with my recent interest in strange distortion plugins :D

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Fri Jul 23, 2021 9:08 am

Thanks Paul, nice to hear! Though could you elaborate a bit on the "all media goes offline" as I'm not sure I fully understand what you mean. I though It mainly had to do with window keyboard focus, but maybe there's more to it that I didn't see or failed to reproduce myself.

I have also added a bunch of audio samples to the plugin page that shows a bit of what the plugin is capable of. Listen to the 909 clip for some over the top pumping compression :wink: .

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Fri Jul 23, 2021 11:23 am

noizebox wrote:
Fri Jul 23, 2021 9:08 am
Though could you elaborate a bit on the "all media goes offline" as I'm not sure I fully understand what you mean.
Ah, now I see how this might be confusing. I have "Set media offline when application is not active" turned on in REAPER Preferences -> Media. I also run REAPER fullscreen so it's not immediately apparent if/when it loses focus. So basically what happens when I load NB01 on a track, REAPER loses focus which causes media to go offline (only if playback is stopped though). This of course also causes REAPER not to receive any keyboard input so these 2 cases are possible:

- stopped -> load NB01 -> press space -> playback doesn't start
- playing -> load NB01 -> press space -> playback doesn't stop

I have also set all new FX to open in a floating window ("Auto-float newly created FX windows" and "Auto-open FX windows after quick add" in Preferences -> Plugins). Quick add - right click on the track FX button - is how I add plugins in most cases.

Hope this helps :)

KVRist
116 posts since 10 Mar, 2004 from Helsinki, Finland

Post Wed Jul 28, 2021 7:26 am

I managed to get REAPER to hang when opening the NB01 GUI in a slightly larger project. The title bar of the plugin itself had the text "not responding" which seems a bit unusual to me (audio was still playing though). Then the standard Windows "this program is not responding" dialog came up. Thankfully I did save just before this :)
So yeah, I like the plugin but there's something about opening the GUI that trips up at least REAPER. I don't have any other DAW/host to test with.

User avatar
KVRist
56 posts since 19 Nov, 2012 from Stockholm, Sweden

Post Fri Jul 30, 2021 9:50 am

Thanks for the report Paul. I got another bug report from another forum with very similar symptoms, audio still running but gui window hangs. There's definitely something fishy going on there and probably some race condition when opening the gui window in reaper. The downside of not using JUCE to build the plugin :(.

I'm on vacation now and away from my main development machine so unfortunately it's unlikely that I will be able to fix this before the DC voting ends. Though I will definitely keep updating this plugin after that. I have some features I want to add and improve. Scalable graphics would be one of them.

Return to “KVR Developer Challenge 2021”