Roli Lightpad M minimum requirements

Anything about hardware musical instruments.
Q-Bass
KVRer
7 posts since 20 Dec, 2018

Post Sun Jan 20, 2019 9:18 pm

Hello,

I'm considering this Lightpad, but I am bit confused (or dissapointed) by it's minimum requirements on CPU. I know that the data transmission/processing has to be bigger than with standard MIDI, but 2,5 GHz? Is it the hardware itself or it just counts that working with MPE capable synth would take so much CPU? But than Strobe2 for example needs only 2,0 GHz..
My "not-so-up-to-date" Macbook has only i5 2,3 (with turbo boost to 2,8 GHz). Anybody has experience with Lightpad M or Seaboard block running on slightly weaker computer like this?

Thanks for any comment.

(I'm still kind of green with this tech stuff. Recording for few years but still don't get how a comp can run DAW plus several plugins - each of them have its processor and RAM requirements that in sum exceeds computer's power but it somehow works.. :-) )

User avatar
DJ Warmonger
KVRAF
2942 posts since 7 Jun, 2012 from Warsaw

Re: Roli Lightpad M minimum requirements

Post Mon Jan 21, 2019 2:48 am

Ignore this. In such cases devs simply list the lowest configuration they were able to test it with. Actual CPU usage of such device should be insignificant,
http://djwarmonger.wordpress.com/
Tricky-Loops wrote: (...)someone like Armin van Buuren who claims to make a track in half an hour and all his songs sound somewhat boring(...)

Q-Bass
KVRer
7 posts since 20 Dec, 2018

Re: Roli Lightpad M minimum requirements

Post Mon Jan 21, 2019 11:00 pm

Thanks, that is what I thought. Do you have personal experience? Can anybody else confirm this?

And what about the OSX version compatibility? I am on 10.10 but the bundled Cypher2 player for example has 10.11 in requirements. Is it the same case of "lowest configuration they were able to test it with"? Or is it something specific in that Os that is needed to run it? It is more general and more software question, I know.. I was upgrading OSX only once ore twice and that process somehow scares me. Only doing it because of music stuff (i.e. requirements) - I don't need anything else that newer versions offer..

User avatar
Tj Shredder
KVRAF
1873 posts since 6 Jan, 2017 from Outer Space

Re: Roli Lightpad M minimum requirements

Post Fri Feb 01, 2019 10:08 pm

Mac software is built with X-code. If it is compiled for 10.11 it won‘t run in 10.10!
To get 10.11 now you either have downloaded it already (then you will find it under purchased apps), or need a machine running 10.6 or 10.7. Apple wants to force everybody to the newest OS X...
10.11 is the bug free version of 10.10 - first time ever an Apple OS needed less resources than its predecessor...

Return to “Hardware (Instruments and Effects)”