Is it at all reasonable to think I can have all my NI software running?

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
ew
KVRAF
9159 posts since 23 Jul, 2002 from Pequot Lakes, MN

Post Sun Feb 17, 2019 11:57 am

Ah_Dziz wrote:
Sat Feb 16, 2019 6:33 pm
So none of the “versions” of any of ,my NI stuff match when I’m looking at properties or hovering over the .exe or .dll files. This is consistent up to the newest stuff. The “about screen” when you click on the logo or “about” under options or whatever does not match either number. I can’t launch the problematic programs as plugins to even look at the “about” screen. If anybody with a working copy of Kontakt 2, Pro 53, or vokator that is fully functional under Windows 7 64-bit, please tell me the “properties” version number, the vst .dll file “properties” version number and then the numbers displayed under “about” from inside the program. That would help immensely. “If it works for you then I can make it work for me” is what I’m thinking. I’d like to see what I can confirm as being “wrong” with what I have so I can try and move forward.
Will W10 x64 do?

Pro-53: 3.0.5.001
Spektral Delay: 1.6.0.011
Vokator: 1.2.0.012

All wrapped via jBridge and working in Live, Kore, Reason and Sonar.

ew
A spectral heretic...

User avatar
ew
KVRAF
9159 posts since 23 Jul, 2002 from Pequot Lakes, MN

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 12:07 pm

EvilDragon wrote:
Sun Feb 17, 2019 10:33 am
That sounds horrible, whoa. Something really messed up there during all the installs and/or updates. Kontakt 2 stopped at version 2.2.4. Pro-53 is at 3.0.5.001. This to me sounds like the VST plugin folder was somehow incorrectly set in certain installs, so things went awry from there onwards.

Version number has to be the same for both standalone EXE and plugin DLL.
Yep- that's how I see it.

@ Ah_Daiz- open up Service Center and click on details for each plugin - it'll tell you where Service Center installed the latest updates.

When you start up Service Center, it will say it failed on self-updating. It will start up again; when you get the "do you want to try updating again" prompt, click no and it will open as normal.

ew
Last edited by ew on Sun Feb 17, 2019 7:43 pm, edited 1 time in total.
A spectral heretic...

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:11 pm

I fully re arranged how I did all my plugins (put them in big fat 32/64 bit folders with sub folders) with my last build which is when I installed all of this. So if I hover my mouse over the exe and the dll file it should give me the same version for everything? It definitely does not now although service center and native access know exactly where everything is installed and lists the latest version as installed. I have everything working stand-alone now, but Kontakt 2, Pro 53, vokator, B4, akoustik piano, and elektrik piano will not run as plugins. Al of them give an error box that says they need to be registered, but don’t give me the option to register with service center. This is usually followed with a crash. I have screen shots of this stuff, but it sounds like something is very wrong. I updated, restarted, then ran the standalone, then restarted again with all of these and it fixed guitar rig 3&4, absynth 4 and spektral delay, but the rest will still not start up in a host at all. Just an error and then (most of the time a crash). Still waiting to hear back from NI, or even have them approve my post. I am more curious than anything else at this point. It’s very strange.
Don't F**K with Mr. Zero.

User avatar
ew
KVRAF
9159 posts since 23 Jul, 2002 from Pequot Lakes, MN

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:44 pm

What are you using as a bridge?

ew
A spectral heretic...

User avatar
Orbit-50
KVRAF
2240 posts since 29 Jun, 2005 from La La Land

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:45 pm

Ah_Dziz wrote:
Sun Feb 17, 2019 7:11 pm
I fully re arranged how I did all my plugins (put them in big fat 32/64 bit folders with sub folders) with my last build which is when I installed all of this. So if I hover my mouse over the exe and the dll file it should give me the same version for everything? It definitely does not now although service center and native access know exactly where everything is installed and lists the latest version as installed. I have everything working stand-alone now, but Kontakt 2, Pro 53, vokator, B4, akoustik piano, and elektrik piano will not run as plugins. Al of them give an error box that says they need to be registered, but don’t give me the option to register with service center. This is usually followed with a crash. I have screen shots of this stuff, but it sounds like something is very wrong. I updated, restarted, then ran the standalone, then restarted again with all of these and it fixed guitar rig 3&4, absynth 4 and spektral delay, but the rest will still not start up in a host at all. Just an error and then (most of the time a crash). Still waiting to hear back from NI, or even have them approve my post. I am more curious than anything else at this point. It’s very strange.
If I were as brave as I used to be, which I am not, :hihi: I would try all of this out myself because I'm really interested to see if I could ever fire up Intakt or even Kontakt 1 again just for old times sake. Let's see what NI says in your case. I feel very negative about it, and again it's because of the newer authorization systems in place. Service Center still works for me surprisingly, and I can still run older stuff but I haven't tried to go very far back. I might join you in this. I'll have to take my moth eaten cape out of the old suitcase, and bring to the dry cleaners for repair and spring back into action. :hihi:
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
Alienware i7 R3 loaded with billions of DAWS and plugins.

User avatar
Orbit-50
KVRAF
2240 posts since 29 Jun, 2005 from La La Land

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:48 pm

ew wrote:
Sun Feb 17, 2019 7:44 pm
What are you using as a bridge?

ew
OMG!!! It's the ghost of ew. This is starting to get really serious now.
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
Alienware i7 R3 loaded with billions of DAWS and plugins.

User avatar
ew
KVRAF
9159 posts since 23 Jul, 2002 from Pequot Lakes, MN

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:51 pm

Ah_Dziz wrote:
Sun Feb 17, 2019 7:11 pm
I fully re arranged how I did all my plugins (put them in big fat 32/64 bit folders with sub folders) with my last build which is when I installed all of this. So if I hover my mouse over the exe and the dll file it should give me the same version for everything? It definitely does not now although service center and native access know exactly where everything is installed and lists the latest version as installed. I have everything working stand-alone now, but Kontakt 2, Pro 53, vokator, B4, akoustik piano, and elektrik piano will not run as plugins. Al of them give an error box that says they need to be registered, but don’t give me the option to register with service center. This is usually followed with a crash. I have screen shots of this stuff, but it sounds like something is very wrong. I updated, restarted, then ran the standalone, then restarted again with all of these and it fixed guitar rig 3&4, absynth 4 and spektral delay, but the rest will still not start up in a host at all. Just an error and then (most of the time a crash). Still waiting to hear back from NI, or even have them approve my post. I am more curious than anything else at this point. It’s very strange.
What I would try in your case is installing those troublesome plugins from scratch. Uninstall those, reboot, and then reinstall *and* update before runinng Service Center. After you've activated them, reboot. Now, run them as standalones and make sure they're working correctly and that they can find their libraries. Reboot again and scan your plugins.

ew
A spectral heretic...

User avatar
ew
KVRAF
9159 posts since 23 Jul, 2002 from Pequot Lakes, MN

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 7:52 pm

Orbit-50 wrote:
Sun Feb 17, 2019 7:48 pm
ew wrote:
Sun Feb 17, 2019 7:44 pm
What are you using as a bridge?

ew
OMG!!! It's the ghost of ew. This is starting to get really serious now.
I pop in every once in a while these days. *waves*

ew
A spectral heretic...

User avatar
Orbit-50
KVRAF
2240 posts since 29 Jun, 2005 from La La Land

Re: Is it at all reasonable to think I can have all my NI software running?

Post Sun Feb 17, 2019 8:03 pm

ew wrote:
Sun Feb 17, 2019 7:52 pm
Orbit-50 wrote:
Sun Feb 17, 2019 7:48 pm
ew wrote:
Sun Feb 17, 2019 7:44 pm
What are you using as a bridge?

ew
OMG!!! It's the ghost of ew. This is starting to get really serious now.
I pop in every once in a while these days. *waves*

ew
It's great to see you man. You've given a lot, and I, as well as a lot of others, won't ever forget that.
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
Alienware i7 R3 loaded with billions of DAWS and plugins.

User avatar
jancivil
KVRAF
17536 posts since 20 Oct, 2007 from No Location

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 4:22 am

I would try to open them in VE Pro 32-bit standalone and/or server.

I actually tried Kontakt 2 Player, which NA sees oddly enough, in it. It opens but the GUI strobes, it isn't workable.
I added licenses to NA of plugins from this older era, which it took but it doesn't show anything of the plugins. Kontakt 2 proper; nope.

I had quite a time the last time I tried to make Kore 2 work here, one day I cleaned system cache and all that went down the drain. The success of it becoming authorized a bit of a mystery. IIRC Service Center from VE Pro was a different result from SC from standalone. It required a hack to even install.

But windows and OSX are not going to produce the same problems much anyway.

sacer
KVRist
499 posts since 8 Jan, 2012 from frankfurt, Germany

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 7:45 am

all my NI stuff since komplete 5 is still activated, but i have other problems like yesterday, when i open an old daw project with reaktor 5, it doesn't find the new reaktor spark from reaktor 6, so it's a whole mess with their updates. Also in kore you need all previous version of kontakt, absynth and guitar rig to edit sounds. Why can't they keep the name of the plugin, that a major update would be loaded instead of the old version, the sound quality is the same, there is no significant difference, if they release a newer verion of kontakt, reaktor.
Maybe in battery and maschine 2 the newer version are different, but they should work on backward compatibility on newer versions, like tone2, omnispehere

User avatar
EvilDragon
KVRAF
17700 posts since 7 Jan, 2009 from Croatia

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 8:01 am

sacer wrote:
Mon Feb 18, 2019 7:45 am
Why can't they keep the name of the plugin, that a major update would be loaded instead of the old version, the sound quality is the same, there is no significant difference, if they release a newer verion of kontakt, reaktor.
Because sometimes newer versions remove certain features. Plus it's much safer from a working composer's perspective - you can check out the newest major version while your current projects all still use previous version.

original flipper
KVRAF
2423 posts since 14 Sep, 2003 from Essex

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 8:11 am

Hi

When you think about it in a perfect world you should be able to run programs (vst's) that you bought however many years ago if (for example) a 32 bit app bridges OK.
But it does not help when NI have both discontinued some of those app's as well as changing there copy protection scheme.
To make things even more difficult was things such as having to update before registering, having to run standalone so the library loads up and so on.
You cant always think ahead with technology, but wouldn't it be nice if NI made available discontinued app's to purchasers as special downloads without any CP whatsoever - it's not like anyone wants to crack 15 year old software ... is it?
I look forward to trying to install some of my older NI stuff sometime soon and will bookmark this thread as a kind of self/group help guide.

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 8:19 am

ew wrote:
Sun Feb 17, 2019 7:44 pm
What are you using as a bridge?

ew
Jbridge
Don't F**K with Mr. Zero.

Ah_Dziz
KVRAF
2482 posts since 2 Jul, 2005

Re: Is it at all reasonable to think I can have all my NI software running?

Post Mon Feb 18, 2019 8:20 am

original flipper wrote:
Mon Feb 18, 2019 8:11 am
Hi

When you think about it in a perfect world you should be able to run programs (vst's) that you bought however many years ago if (for example) a 32 bit app bridges OK.
But it does not help when NI have both discontinued some of those app's as well as changing there copy protection scheme.
To make things even more difficult was things such as having to update before registering, having to run standalone so the library loads up and so on.
You cant always think ahead with technology, but wouldn't it be nice if NI made available discontinued app's to purchasers as special downloads without any CP whatsoever - it's not like anyone wants to crack 15 year old software ... is it?
I look forward to trying to install some of my older NI stuff sometime soon and will bookmark this thread as a kind of self/group help guide.
I do remember quite clearly that they said they would provide unlocked software when and if the authorization servers were going to stop supporting things. oh well.
Don't F**K with Mr. Zero.

Return to “Instruments”