Very strange Retina Behavior!

Official support for: bitwig.com
reflekshun
KVRist
418 posts since 6 Sep, 2003 from Baltimore, MD

Post Sun Apr 14, 2019 7:32 pm

I'm running Mojave, and experience this same issue on both Bitwig 2.4.3 and 2.5

When running both of my displays at 1600x900 Retina (or any resolution retina for both - it has the same results), I experience this very strange behavior! CPU spikes when UI is on primary display, and absolutely no CPU spikes on the secondary screen.

Here, have a look:
https://www.dropbox.com/s/nrn0k7nm8jya1 ... s.MOV?dl=0

I would be less confused if it was spiking on both displays (okay maybe Bitwig or the OS or plugin creators didn't get scaling worked out right yet). BUT, if its working without a hitch on the secondary display, this gives me hope that there is SOME way to make this work on the primary display, without that really bad case of CPU Spikes.

Has anyone got any ideas, or have experienced this on a Mac?
http://www.soundcloud.com/reflekshun
Audio Engineer / Music Producer

http://www.reflekshunblog.blogspot.com
Explore the Love of Sound... and the Sound of Love

jonljacobi
KVRian
878 posts since 16 Jan, 2013 from USA

Re: Very strange Retina Behavior!

Post Mon Apr 15, 2019 9:02 am

Not something I've tried, but you seem to be dragging around third-party plug-ins. I don't believe the DAW is responsible for drawing those. I couldn't really make out the CPU meters, but if the audio doesn't glitch (you don't say it does), then perhaps not worry about it. You could try reducing the color depth to 8-bits.

reflekshun
KVRist
418 posts since 6 Sep, 2003 from Baltimore, MD

Re: Very strange Retina Behavior!

Post Mon Apr 15, 2019 10:25 am

jonljacobi wrote:
Mon Apr 15, 2019 9:02 am
Not something I've tried, but you seem to be dragging around third-party plug-ins. I don't believe the DAW is responsible for drawing those. I couldn't really make out the CPU meters, but if the audio doesn't glitch (you don't say it does), then perhaps not worry about it. You could try reducing the color depth to 8-bits.
Yeah I think you're right, it might be an OS level problem. I'm experiencing the same thing in reaper. God knows if apple is going to help me at all with this though! I think i'm just screwed lol

Oh and the audio does glitch pretty badly, you should be able to hear that in the video I posted. Sorry if it didn't come through!

The only workaround I've found is turning off retina mode (2x OS Scaling) for the primary display. Although it is SUPER strange that plugins display perfectly on the secondary screen which is retina and 2x scaled, without any CPU spikes or audio glitching! That's the part of this which is a complete mystery and gives me hope that the primary display is capable of working in retina mode without any glitching.
http://www.soundcloud.com/reflekshun
Audio Engineer / Music Producer

http://www.reflekshunblog.blogspot.com
Explore the Love of Sound... and the Sound of Love

spritex
KVRian
855 posts since 4 Apr, 2001 from Finland

Re: Very strange Retina Behavior!

Post Mon Apr 15, 2019 3:59 pm

Have you tried how it behaves with only one display?
Bitwig - Logic - U-He - NI Komplete - Geist - Korg Legacy

reflekshun
KVRist
418 posts since 6 Sep, 2003 from Baltimore, MD

Re: Very strange Retina Behavior!

Post Mon Apr 15, 2019 10:24 pm

spritex wrote:
Mon Apr 15, 2019 3:59 pm
Have you tried how it behaves with only one display?
Yep! - On the primary display it always works this way, doesn't matter whether the 2nd display is connected or not.

If anyone has an mac and uses retina display with slate plugins and/or roland plugins, please let me know, I'd love to confirm that it can work on someone's system!
http://www.soundcloud.com/reflekshun
Audio Engineer / Music Producer

http://www.reflekshunblog.blogspot.com
Explore the Love of Sound... and the Sound of Love

joeballs
KVRist
64 posts since 17 Jan, 2012

Re: Very strange Retina Behavior!

Post Thu Apr 18, 2019 9:01 am

I'm suspecting that since Bitwig is software rendered UI (vs hardware gpu), the amount of rendering on that one screen is putting a lot of load on the cpu (during playback). When moving windows around like that, you're causing many redraws of that window.

jonljacobi
KVRian
878 posts since 16 Jan, 2013 from USA

Re: Very strange Retina Behavior!

Post Fri Apr 19, 2019 6:38 am

Redraws. Good point. But as it only happens on the second display, and is replicable with Reaper, it would seem it’s something very basic in the way that display is being handled, and not necessarily Bitwig. Interesting. Perhaps simply not enough VRAM.

reflekshun
KVRist
418 posts since 6 Sep, 2003 from Baltimore, MD

Re: Very strange Retina Behavior!

Post Mon Apr 22, 2019 12:34 pm

joeballs wrote:
Thu Apr 18, 2019 9:01 am
I'm suspecting that since Bitwig is software rendered UI (vs hardware gpu), the amount of rendering on that one screen is putting a lot of load on the cpu (during playback). When moving windows around like that, you're causing many redraws of that window.
yeah good observations. I think you are right about redraws, still however pretty insane that it would max out my iMac Pro 8 core cpu LOL.

I did find a partial solution:

System preferences -> Display -> Color, then choose an sRGB profile near the bottom.

This improves plugin display performance a lot, still slower than my 6.5 year old imac on high sierra, which is sad, but at least there's an improvement!
http://www.soundcloud.com/reflekshun
Audio Engineer / Music Producer

http://www.reflekshunblog.blogspot.com
Explore the Love of Sound... and the Sound of Love

joeballs
KVRist
64 posts since 17 Jan, 2012

Re: Very strange Retina Behavior!

Post Tue Apr 23, 2019 9:51 pm

reflekshun wrote:
Mon Apr 22, 2019 12:34 pm
joeballs wrote:
Thu Apr 18, 2019 9:01 am
I'm suspecting that since Bitwig is software rendered UI (vs hardware gpu), the amount of rendering on that one screen is putting a lot of load on the cpu (during playback). When moving windows around like that, you're causing many redraws of that window.
yeah good observations. I think you are right about redraws, still however pretty insane that it would max out my iMac Pro 8 core cpu LOL.

I did find a partial solution:

System preferences -> Display -> Color, then choose an sRGB profile near the bottom.

This improves plugin display performance a lot, still slower than my 6.5 year old imac on high sierra, which is sad, but at least there's an improvement!

What it really comes down to is that it would be great if the devs added hardware (gpu) support for the GUI. :wink:

reflekshun
KVRist
418 posts since 6 Sep, 2003 from Baltimore, MD

Re: Very strange Retina Behavior!

Post Thu Apr 25, 2019 1:15 pm

joeballs wrote:
Tue Apr 23, 2019 9:51 pm

What it really comes down to is that it would be great if the devs added hardware (gpu) support for the GUI. :wink:
Haha I would love that, not sure if that would affect plugin video performance, but I think it would def help with Bitwig itself :)
http://www.soundcloud.com/reflekshun
Audio Engineer / Music Producer

http://www.reflekshunblog.blogspot.com
Explore the Love of Sound... and the Sound of Love

Return to “Bitwig”