My First Rant: NI MX [RESOLVED, sorta]

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
fisherKing
KVRAF
2135 posts since 6 Aug, 2009

Post Tue Feb 18, 2020 4:16 pm

i have never ranted here, but today is special.

when massive X came out, i bought it. thought it was great, with an intriguing architecture, and an impressive sound. i even defended it vigorously on this very forum.

then, today... am doing a remix for a client, and went to finish the work. the mix is simple, and based almost entirely around a massive X sound.

2 hours ago, i opened the project (in logic X), and all was fine. but now, when i open it, the massive X sound is all wrong. it sounds like it has been eaten by godzilla (really, that's an accurate description).

i rebooted my mac, and same problem. this is a preset i altered, a lot. i have, with every plugin, for over a decade, recalled projects, and plugins played as i set them up to play. not today.

so i have to reconstruct (or replace) the sound. it's not ok... and will remove MX from my arsenal; if i can't rely on it, i don't care how good it can sound. :evil:
Last edited by fisherKing on Wed Feb 19, 2020 4:43 am, edited 1 time in total.
https://upstatebrooklyn.com
always one plugin short of perfection...

User avatar
digitalboytn
KVRAF
1675 posts since 8 Dec, 2008 from Global Cowboy

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 4:46 pm

Don't worry FK...

The new team of bean counters over at NI will have any software problems fixed in a heartbeat :wink:

That's why the're earning the big $$$...
Sorry - I don't use auto-tune....

User avatar
fisherKing
KVRAF
2135 posts since 6 Aug, 2009

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 4:53 pm

am thinking i didn't need to post this; i panicked. i've just reworked the original preset, and it's close enough (perhaps better). still... this shouldn't happen, and doesn't with any other of my synth plugins (and i own many, and have owned many more).

don't know why this happened; and your own mileage may vary. but am not using MX anymore. even tho i can save what i do as a new preset... i shouldn't have to.

so it goes.
https://upstatebrooklyn.com
always one plugin short of perfection...

experimental.crow
KVRAF
6224 posts since 9 Mar, 2003 from the bridge of sighs

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 5:00 pm

fisherKing wrote:
Tue Feb 18, 2020 4:53 pm
am thinking i didn't need to post this; i panicked. i've just reworked the original preset, and it's close enough (perhaps better). still... this shouldn't happen, and doesn't with any other of my synth plugins (and i own many, and have owned many more).

don't know why this happened; and your own mileage may vary. but am not using MX anymore. even tho i can save what i do as a new preset... i shouldn't have to.

so it goes.
belt and suspenders ...
Image

User avatar
fisherKing
KVRAF
2135 posts since 6 Aug, 2009

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 5:03 pm

experimental.crow wrote:
Tue Feb 18, 2020 5:00 pm
fisherKing wrote:
Tue Feb 18, 2020 4:53 pm
am thinking i didn't need to post this; i panicked. i've just reworked the original preset, and it's close enough (perhaps better). still... this shouldn't happen, and doesn't with any other of my synth plugins (and i own many, and have owned many more).

don't know why this happened; and your own mileage may vary. but am not using MX anymore. even tho i can save what i do as a new preset... i shouldn't have to.

so it goes.
belt and suspenders ...
i hear you, and it's easy enough to do. am just always tweaking things, until the last minute. and never had this happen before. but yes, worth doing from now on...
https://upstatebrooklyn.com
always one plugin short of perfection...

V0RT3X
KVRAF
8183 posts since 4 Jul, 2012 from Alesia

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 5:27 pm

You on mac or pc?

User avatar
zvenx
KVRAF
7467 posts since 16 Feb, 2005 from Kingston, Jamaica

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 5:29 pm

I assume you didn't update MX between the time you first created the preset to the time it got all screwed up?
rsp
sound sculptist

User avatar
fisherKing
KVRAF
2135 posts since 6 Aug, 2009

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 7:32 pm

V0RT3X wrote:
Tue Feb 18, 2020 5:27 pm
You on mac or pc?
zvenx wrote:
Tue Feb 18, 2020 5:29 pm
I assume you didn't update MX between the time you first created the preset to the time it got all screwed up?
rsp
logic X = mac. and no updates, just two hours between the time it was fine... and the time it no longer was.

i got the sound i wanted, converted it to audio, and all is well (enough). :tu:
https://upstatebrooklyn.com
always one plugin short of perfection...

V0RT3X
KVRAF
8183 posts since 4 Jul, 2012 from Alesia

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 7:35 pm

Right i should have noticed that

:dog:

Too bad it did that. Glad you got it sorted

User avatar
fisherKing
KVRAF
2135 posts since 6 Aug, 2009

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 8:13 pm

V0RT3X wrote:
Tue Feb 18, 2020 7:35 pm
Right i should have noticed that

:dog:

Too bad it did that. Glad you got it sorted
it IS a lesson learned. i have SO many projects with edited presets, created sounds... none of them saved. but will start doing that (after all, nothing to lose).

still... massive X should not have done that, and won't trust it again.
https://upstatebrooklyn.com
always one plugin short of perfection...

User avatar
Tj Shredder
KVRAF
3948 posts since 6 Jan, 2017 from Outer Space

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 11:10 pm

Its important to understand technically why it happened! It could as well be a quirk of Logic... It might need the support of NI/Apple to figure it out. These are scary experiences, I would not be able to sleep well without figuring out the why...

chk071
KVRAF
23134 posts since 11 Apr, 2010 from Germany

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 11:13 pm

fisherKing wrote:
Tue Feb 18, 2020 4:53 pm
am thinking i didn't need to post this; i panicked. i've just reworked the original preset, and it's close enough (perhaps better). still... this shouldn't happen, and doesn't with any other of my synth plugins (and i own many, and have owned many more).

don't know why this happened; and your own mileage may vary. but am not using MX anymore. even tho i can save what i do as a new preset... i shouldn't have to.

so it goes.
Consider to report this if you think it is a bug. The only way that NI will take note of it, and potentially fix it.

MRT
KVRian
1118 posts since 3 Dec, 2002

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 11:16 pm

I recently had a similar problem with OP-X in Reaper project. I've been using OP-X for years and to my memory it was the first time that has happened. I assumed it was a Reaper fault in the last project save?

User avatar
DJ Warmonger
KVRAF
3671 posts since 7 Jun, 2012 from Warsaw

Re: My First Rant: NI MX

Post Tue Feb 18, 2020 11:57 pm

Sad story, bro :(

It didn't happen to me yet, but now I'm afraid.Hopefully it's limited to Mac / Logic, or some other specifics. Didn't hear about this issue yet.

I've had some issues with D16 plugins losing their settings on project (re) load, tho. Since then started just to export presets or bounce to audio if possible.
http://djwarmonger.wordpress.com/
Tricky-Loops wrote: (...)someone like Armin van Buuren who claims to make a track in half an hour and all his songs sound somewhat boring(...)

recursive one
KVRAF
4597 posts since 7 Feb, 2013

Re: My First Rant: NI MX

Post Wed Feb 19, 2020 12:29 am

Do you have the most latest MX update? It was aimed just at fixing preset saving/reloading issues.

What exactly has happened? DId MX switched to some other preset, or init preset, or did some parameters randomly change?

I had similar issues with Sylenth in Studio One few times, it randomly changed some parameters or switched to some random preset. It doesn't really bother me though, as I usually freeze things once I'm happy with the sound.
You may think you can fly ... but you better not try

Return to “Instruments”