How to use Hardware Reverb with DAW?

Anything about hardware musical instruments.
User avatar
KVRian
623 posts since 15 Jun, 2015

Post Sun Aug 07, 2016 8:39 am

theEmbark wrote:Thanks for the post,

How do I go about a installing the VST?
Instructions start on page 41 of the manual. Works great on my setup. :tu:

KVRian

Topic Starter

512 posts since 4 Dec, 2015

Post Sun Aug 07, 2016 9:00 am

Thank you :D.

So I already have the drivers installed. Now I am trying to figure out the proper config inside Cubase.

I can see the MX300 in my device setup.
Image

Next I jumped into my VST connections and external effects. And add a new external effect.
Image

What I don't understand is how you are able to do this with just a USB cable. Because it needs the I/O right?
Image

Thanks,
Kevin
Win 7 | Dual Xeon x5680 | 48 GB RAM | Saffire Pro 40 | Yamaha HS50 monitors |Cubase 8.5 Pro|
Image
Kevin DiGennaro

User avatar
KVRian
623 posts since 15 Jun, 2015

Post Sun Aug 07, 2016 3:39 pm

Yep, you need audio out to the MX300 and back in to the audio interface. Any two assignable outputs will do, they don't have to be sends. And then you set up an audio track to record the reverb audio back from the MX300.

With the vst extension, you don't need to set up an External FX. There should be a vst/au version of the MX300 in your plugins folder. The vst/au looks just like the front panel of the MX300. And you can control the MX300 from the plugin: change presets, tweak parameters, control automation, etc. It works exactly like any other plugin at that point.
Last edited by RichieWitch on Sun Aug 07, 2016 3:42 pm, edited 1 time in total.

KVRian

Topic Starter

512 posts since 4 Dec, 2015

Post Sun Aug 07, 2016 3:41 pm

RichieWitch wrote:Yep, you need audio out to the MX300 and back in to the audio interface. Any two assignable outputs will do, they don't have to be sends. And then you set up an audio track to record the reverb audio back from the MX300.
Thanks for the clarification,

That's what I thought and then got confused :p.

I'm going to go ahead and utilize the digital I/O. I think it's a good way to use them up.

Thanks,
Kevin
Win 7 | Dual Xeon x5680 | 48 GB RAM | Saffire Pro 40 | Yamaha HS50 monitors |Cubase 8.5 Pro|
Image
Kevin DiGennaro

User avatar
KVRian
623 posts since 15 Jun, 2015

Post Sun Aug 07, 2016 3:43 pm

Check my edit above about External FX vs plugin. Looks like you're still missing the plugin for the MX300.

KVRian

Topic Starter

512 posts since 4 Dec, 2015

Post Sun Aug 07, 2016 3:53 pm

RichieWitch wrote:Check my edit above about External FX vs plugin. Looks like you're still missing the plugin for the MX300.
Thanks for the update, we most have posted at the same time :-).

Yeah I can't seem to find the vst. I installed the mixedit software so it should be on here. I might just need to find it on my computer. Might be on another hard drive now that I am thinking.

Thanks again,
Kevin
Win 7 | Dual Xeon x5680 | 48 GB RAM | Saffire Pro 40 | Yamaha HS50 monitors |Cubase 8.5 Pro|
Image
Kevin DiGennaro

KVRer
1 posts since 23 Feb, 2021

Post Tue Feb 23, 2021 3:08 pm

Hi resurrecting an old thread here, I recently bought an MX200 hardware reverb I too am having trouble finding the plug in to load up in Logic Pro X? I downloaded the MX edit software when I try to load this app it crashes. I downloaded Jbridge which allows 32bit apps to run on 64bit architecture. Would love to know a simple way to get this routed into Logic via Spdif?

User avatar
KVRAF
5249 posts since 6 Jan, 2017 from Outer Space

Post Fri Feb 26, 2021 9:18 am

Jbridge won’t let you run 32-bit in Catalina and above.
The routing via Spdif is straight just send spdif out to spdif in and the reverb in-between... The plugin is just a remote btw. It should work without as well. Just edit on the machine...
But isn’t a cable already more expensive than let say Dragonfly reverb or Orilriver? They both sound better than an old MX 200 too...

Return to “Hardware (Instruments and Effects)”