Monophonic per row?

Official support for:
Topic Starter
460 posts since 25 Jan, 2016

Post Mon Sep 20, 2021 8:42 pm

I'd like to set things up so that I can create chord shapes across the columns and add notes along the rows which will replace the held notes of the chords while retriggering the held chord notes once the additional notes are released.

Please forgive me, I'm a relatively new Linnstrument owner/ bass player with little technical knowhow.

59 posts since 26 Mar, 2020

Post Tue Sep 21, 2021 1:17 am

Hi Werzel,

You can set the Linnstrument to "ChPerRow" ( ... l-settings)
This way, each row will have a dedicated MIDI channel.
Now you can send each of these MIDI channels (these will be channels 1 to 8 ) to a separate mono-synth. Assuming you are using a DAW, this means you have to set up 8 separate tracks, and on each track wil be a mono-synth on a different MIDI channel (1 to 8 ).

Now, on each mono-synth, you should check if you can set up the "note priority" ( ... s-triggers). You want a synth that has "last-note priority". This means each new note played will play immediately, and when you release the note, it go back to the note you're still holding.

Good luck!


1411 posts since 2 Apr, 2015

Post Tue Sep 21, 2021 12:26 pm

The only synth/plugin that will work with one instance that I know works in this way is Uhe Diva.
Bitwig, against the constitution.

9 posts since 27 Sep, 2017

Post Tue Oct 05, 2021 4:37 pm

Hi Jef,

I have attempted a ChPerRow setup as you describe. On the Linnstrument in Per-Split setting I have: Midi Mode, ChPerRow is lit; View, PerRowCha is lit; Midi Channels 1-8 are lit; Low Row, Normal is lit; Same settings for Left and Right Split. In Global Settings I have No Overlap selected in Row Offset.

In Bitwig Studio I have 8 tracks loaded. Each track has an instrument loaded. In the first track I have the Performance Control setup as Midi; Midi ch is 1; I also turned Mono Mode On and Mono Retrig On. The second track Midi Ch 2 is selected: etc. for all 8 tracks.

When I Solo track 1, notes sound chromatically for every pad in the bottom row, but continues going up in row 2, 3, and 4, and stops towards the end of row 4 (I assume when it runs out of MIDI notes). The rest of the pads and rows 5-8 are silent and the keys don't light up.

If I mute track 1 and solo track 2, no notes are sounded at all, although the pads light up for the bottom 4 rows. In fact, none of the other tracks play notes; the pads light up and the bottom 4 rows of pads lightup and trigger Bitwig but no notes are played. Only track 1 will play notes.

What looks like is happening is that with the above Linnstrument settings only MIDI ch 1 is activated, and since I have not specified an overlap, the bottom 4 rows play what looks like 98 midi notes on channel 1...and that's it. It looks like the rows are not really linked to separate MIDI channels. I must be overlooking something and I'm hoping someone can see my mistake.

Thanks! Bruce

User avatar
Tj Shredder
8596 posts since 6 Jan, 2017 from Outer Space

Post Sat Oct 09, 2021 10:04 pm

You have to check the track setting in Bitwig. Per default it will be all -> 1… Make sure it listens only to a single channel on each track. But better is to use an instrument layer in a single track. Set this to all -> same and let each layer with your solo synth listen to one of the channels…
Btw. midi allows exactly 128 different Midi notes, the big LinnStrument has more than that. If you get only 98, you didn‘t start with the lowest note… A Midi monitor helps to analyze such issues…

59 posts since 26 Mar, 2020

Post Mon Oct 11, 2021 2:36 am

Hey Bruce,

Coming from guitar and getting into hardware synths, MIDI and now MPE, I feel your pain. There is a lot to learn. And a lot to troubleshoot, once you start hooking up a bunch of hardware that needs to talk to each other. Especially when a Linnstrument (or other MPE controller) is involved, routing stuff can get complicated.

As TJ said, a MIDI monitor is very useful for troubleshooting. It is an application that shows you all MIDI data coming in and out of your computer.

The one I use is this one: It is a free one for Mac and it works perfectly.
You can select which source you want to monitor. By default it wil show you ALL incoming MIDI data, so deselect every source that is not your Linnstrument. Now you can play a few notes on a few rows and the application will show you which note is sent on which channel. It will also show you all Timbre/Y and Loudness/Z data, so you might want to temporarily switch these off on your Linnstrument ( ... l-settings).

This way, you can be sure the settings on your Linnstrument are correct.

I can't help you much on the Bitwig side of things unfortunately.
Last edited by JefVerbeeck on Mon Oct 11, 2021 6:01 am, edited 1 time in total.

Dirk Diggler
594 posts since 12 Sep, 2007

Post Mon Oct 11, 2021 5:04 am

A midi monitor is required for making sure things are working as expected.
Grab the free midiOx if you're on a PC.
Still works great in win10.

59 posts since 26 Mar, 2020

Post Mon Oct 11, 2021 5:58 am

Oops, I accidentally quoted myself and do not know how to delete a post...

112 posts since 15 Feb, 2012

Post Mon Oct 11, 2021 6:11 am

Dirk Diggler wrote: Mon Oct 11, 2021 5:04 am Grab the free midiOx if you're on a PC.
Or the free MIDI Monitor if you're on Mac.

Return to “Roger Linn Design”