MASSIVE X Gui latency

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
KVRAF
11387 posts since 26 Jun, 2006 from San Francisco Bay Area

Post Mon Oct 18, 2021 7:19 am

My only complaint about Massive X’s interface is that it sucks.
Zerocrossing Media

4th Law of Robotics: When turning evil, display a red indicator light. ~[ ●_● ]~

User avatar
KVRAF
16436 posts since 16 Sep, 2001 from Las Vegas,USA

Post Mon Oct 18, 2021 7:31 am

Urs wrote:
Mon Oct 18, 2021 6:55 am
In VST3 this could be a "feature" of the plug-in format where the host is supposed to add the plug-in latency onto communication between plug-in and GUI, allegedly so things happen visually "as you hear" them rather than "as you expect" them.
So to compensate for audio latency the plugin adds visual latency?

I don't have the VST3 version installed so can't test but it seems like someone else would have reported the issue before if it was intentional behavior. But I don't know how long the MX VST3 has been out or if anybody else uses it in Cubase. :shrug:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
Urs
u-he
26020 posts since 8 Aug, 2002 from Berlin

Post Mon Oct 18, 2021 7:54 am

Teksonik wrote:
Mon Oct 18, 2021 7:31 am
Urs wrote:
Mon Oct 18, 2021 6:55 am
In VST3 this could be a "feature" of the plug-in format where the host is supposed to add the plug-in latency onto communication between plug-in and GUI, allegedly so things happen visually "as you hear" them rather than "as you expect" them.
So to compensate for audio latency the plugin adds visual latency?

I don't have the VST3 version installed so can't test but it seems like someone else would have reported the issue before if it was intentional behavior. But I don't know how long the MX VST3 has been out or if anybody else uses it in Cubase. :shrug:
I don't know if that's the case with Massive here. I just know that VST3 is designed to give visual feedback with latency, e.g. for VU meters, visual plots and what not. The latency depends on the plug-ins in the chain and the buffer size. Both hosts and plug-ins need to support this, I'm sure Cubase does, but I have no idea if NI do (we don't).

KVRist
128 posts since 19 Jun, 2021

Post Mon Oct 18, 2021 10:11 am

I'm doubtful but it would be worth trying the VST2. But I think when I tried the VST3 version for a minute it had no lag issues, I would notice very quickly.

I kinda don't think it's fair to assume otherwise (intended lag) from NI though. Massive X has one of the most smooth moving interfaces, rivaling U-he's.

My bet was on a gaming mouse overwhelming the UI with 1000 inputs per second, and the OP indeed uses such a mouse but we don't know anything more about this.

User avatar
KVRian
655 posts since 21 Aug, 2017 from Brasil

Post Mon Oct 18, 2021 10:31 am

kenny saunders wrote:
Fri Oct 15, 2021 11:46 am
When sweeping the dials there is visual lag for the dail animation and the digital value.
Check this
viewtopic.php?p=7624448#p7624448
Make sure to apply the POWER and the registry fix.

KVRAF
30020 posts since 11 Apr, 2010 from Germany

Post Mon Oct 18, 2021 10:35 am

attention ♥ wrote:
Mon Oct 18, 2021 10:11 am
My bet was on a gaming mouse overwhelming the UI with 1000 inputs per second, and the OP indeed uses such a mouse but we don't know anything more about this.
As I mentioned, my mouse does 1000 Hz as well (yes, it's insane, and, noone needs that really :D), and, I don't have such issues.

The OP should contact NI.
Plugins and a DAW. On an operating system. Which runs on a computer.

User avatar
KVRAF
16436 posts since 16 Sep, 2001 from Las Vegas,USA

Post Mon Oct 18, 2021 12:24 pm

As a reminder the OP wrote.....
kenny saunders wrote:
Sun Oct 17, 2021 1:27 pm
I don't have this issue with any other vsti or fx.
That would point away from it being a system wide issue. He did say he would contact N.I. support so I'm interested in what they say just out of pure curiosity.

My G400S is supposed to have a Polling Rate of 1000Hz and like I said everything is smooth here.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

KVRist

Topic Starter

157 posts since 16 May, 2019

Post Wed Oct 20, 2021 6:01 am

Well I ran the NI info tool and was about to send it to NI but I thought I'd just try it again and it works ok. tbh shortly before I made this post was the very 1st time I ran MassiveX since upgrading my machine. SO no idea what that was about, thanks.
Pictus wrote:
Mon Oct 18, 2021 10:31 am
kenny saunders wrote:
Fri Oct 15, 2021 11:46 am
When sweeping the dials there is visual lag for the dail animation and the digital value.
Check this
viewtopic.php?p=7624448#p7624448
Make sure to apply the POWER and the registry fix.
thanks some good info
______


I've barely touched this synth, what's it good for soundswise?
If you don't eat yer meat, you can't have any pudding. HOW CAN YOU HAVE ANY PUDDING IF YOU DON'T EAT YER MEAT!?

Return to “Instruments”