Equalize 2 bug? My fault?

Official support for: acondigital.com
rafa1981
KVRian
673 posts since 4 Jan, 2007

Post Thu Nov 25, 2021 11:11 am

Hello.

Using Win10, VST3, Reaper 6.34.

1.) I select a highpass and set it to the highest frequency. Blocks all signal, as expected I get no sound.
2.) I set the channel mode to L or R.
3.) Now I hear both channels.

I would expect to only hear one channel.

Now I hard pan a sound with no high frequency to the left and apply the same highpass. If i select the mid channel the sound gets completely muted. If I select the side channel there is no gain change.

A hardpaned sound when converted to M/S should have the same energy on both channels (M and S) I think.

What am I doing wrong?

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Tue Nov 30, 2021 10:21 am

Can anyone confirm?

[PTMAO]Dusk
KVRist
32 posts since 6 Dec, 2004

Post Tue Nov 30, 2021 1:18 pm

This is the normal behavior since when you select L or R the filter is applied only to one channel not both has in the stereo position! Right ? ;)

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 6:42 am

From the manual
Channel Mode Buttons
You can choose any of the following channel modes for each equalizer band
individually:
L : Apply to left channel only
M : Apply to mid channel only. The mid channel is the sum of the input channels
multiplied by a scaling factor.
: Apply to both channels
S : Apply to side channel only. The side channel is the difference of the input
channels multiplied by a scaling factor.
R : Apply to right channel only
If I select R or L I expect the hipass that blocks all the signal to just block all the signal in one channel. I'm reporting this as a bug...

User avatar
stian
KVRian
1266 posts since 1 Jan, 2005 from Norway

Post Thu Dec 02, 2021 6:45 am

Hi Rafa,
rafa1981 wrote:
Thu Nov 25, 2021 11:11 am
Hello.

Using Win10, VST3, Reaper 6.34.

1.) I select a highpass and set it to the highest frequency. Blocks all signal, as expected I get no sound.
2.) I set the channel mode to L or R.
3.) Now I hear both channels.

I would expect to only hear one channel.
Do you have anything else in your chain? I cannot reproduce this in REAPER. Selecting either L or R mutes one channel here (running REAPER 6.29 under Windows).

Best,
Stian

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 6:54 am

Will try again when back at home. Let's hope I'm misreporting (apologies in that case)...

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 02, 2021 12:30 pm

stian wrote:
Thu Dec 02, 2021 6:45 am
Hi Rafa,
It seems actually a bug, but it requires more than two channels. To reproduce:

-Set some audio or synth.
-Set equalize afterwards.
-Set the hipass to the highest frequency.
-Set the right or left channel (L or R) button on Equalize.

At this point only one channel sounds. Everything working OK.

-Press the "2in 2out" button on the top right of Reaper's area.
-Set the track channels dropdown to 4.

Now the EQ settings are completely ignored (same for L,R,M and S). But there is more. Now this requires another audio source on channels 3/4.

If I set the EQ to normal (linked L and R) the expected behavior would be to apply the EQ to channel 1 and 2 and let 3 and 4 pass through, but the EQ is applied to all 4 channels.

I say expected behavior because, for an EQ it seldomly makes sense to apply the same EQ settings to two channels with different audio content. In this case it can be workarounded by just not connecting pings 3 and 4 on both in an out.

Notice that with pins 3 and 4 disconnected, 1 and 2 still behave weirdly with regards to L, R, M and S.

[PTMAO]Dusk
KVRist
32 posts since 6 Dec, 2004

Post Thu Dec 09, 2021 3:26 am

Are you instantiating the vst3 or vst 2 version ?
Could you please update your Reaper to the latest stable version (6.42) and report back?

[PTMAO]Dusk
KVRist
32 posts since 6 Dec, 2004

Post Thu Dec 09, 2021 3:42 am

I could replicate this, indeed there is something i dont quite understand.
If you use the VST2 version seems like the HPF on L or R is applied to what is supposed to be the Ls or Rs of a surround system, not applied to the L or R of the stereo signal.
I´ll try this in another daw and report back too so if there is something wrong it can be fixed.

User avatar
stian
KVRian
1266 posts since 1 Jan, 2005 from Norway

Post Thu Dec 09, 2021 5:17 am

Hi Rafa,
rafa1981 wrote:
Thu Dec 02, 2021 12:30 pm
It seems actually a bug, but it requires more than two channels. To reproduce:

-Set some audio or synth.
-Set equalize afterwards.
-Set the hipass to the highest frequency.
-Set the right or left channel (L or R) button on Equalize.

At this point only one channel sounds. Everything working OK.

-Press the "2in 2out" button on the top right of Reaper's area.
-Set the track channels dropdown to 4.
Thanks, I understand now. For M/S processing to work, you will need to process stereo audio. Equalize does work with higher channel counts, but it mid and side channels don't make any sense for surround audio, so it processes all channels equally. Ambisonics would be the logical extension to that, but I'm that Equalize doesn't support it.

Best,
Stian

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 09, 2021 1:12 pm

stian wrote:
Thu Dec 09, 2021 5:17 am
Hi Rafa,
...
I understand. Let me give you some background; on Reaper it isn't unusual to have multiple channels on the same track without that meaning that the track is surround, some examples:

-A drum machine or any instrument with N outs, e.g. a drum machine with separate audio outputs for each drum.
-Deliberately creating parallel fx chains. E.g. setting a delay with a chorus in series on some track pair of channelsvto be used only by the instrument of that track, to avoid FX send channel bloat on the mixer.
-Etc.

So the total channel count of a track can be any without meaning that you are dealing with a surround track.

The expectation is for the plugin to look how many inputs of all that are available are really connected, so e.g. if the track has 8 channels but only two pins are connected it should act as a stereo FX.

The problem is that equalize is using the total number of track channels to decide its operation mode, whether the channels are connected or not. It should be using the total number of connected channels only, ignoring the unconnected ones.

This is how all FX from other vendors behaves at least.
Last edited by rafa1981 on Thu Dec 09, 2021 1:39 pm, edited 2 times in total.

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 09, 2021 1:15 pm

What happens now is that if e.g. I have a synth with 4 outs, I can't do MS eqing on the second output pair.

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Thu Dec 09, 2021 1:23 pm

So you probably have to assume stereo if the plugin has only channels 1 and 2 connected.

https://docs.juce.com/master/tutorial_a ... youts.html

rafa1981
KVRian

Topic Starter

673 posts since 4 Jan, 2007

Post Mon Dec 20, 2021 3:01 pm

Is the behavior described above unreasonable?

User avatar
stian
KVRian
1266 posts since 1 Jan, 2005 from Norway

Post Thu Dec 23, 2021 4:30 am

I apologize for my late reply. I would have to run the debugger with REAPER to see what channel layout is reported when only two channels are connected. If the two channels are L and R, M/S processing should work, so I don't know exactly what's going on.

Return to “Acon Digital”