Volume reset / strange behaviour

Official support for: zynaddsubfx.sourceforge.net
User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sat Apr 02, 2022 12:32 am

Hello, jackoo (I guess it is you who will be reading this).

One or two years ago we had a discussion about strange volume behavior when I used Zyn together with Reaper. The solutions was the checkboxes and digits in the screenshot.

Well, now I have bought a better laptop (Intel i7, SSD and HDD), but I still have W10 Home and the same version of Zyn. But now the problem is the opposite. If I listen to a piece of music with my own Zyn-strings, every time I press stop, the volume of the strings turns to maximum (for about 0,3 seconds). I get a shock every time, so I cannot use Zyn (strings) if this is going to continue.

Have you got any idea why the same settings as before do no longer work?
You do not have the required permissions to view the files attached to this post.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
932 posts since 3 Jul, 2006

Post Sat Apr 02, 2022 5:32 am

Hi.
First of all, sorry for any loud bursts of sound, I can understand this could be very disturbing and even dangerous for the ears.

I'll try to replicate.
There was a change in Zyn trying to smooth out CC changes within a certain time. If this is causing issues (by adding some 50 ns of delay to CC modifications), I've recompiled a version to revert to old functionality. To disable CC smoothing, edit the zynaddsub.cfg file and modify this line as below:

<par name="cc_latency" value="0"/>

So this line will revert back to old ways of handling CCs with zero delay, no smoothing, and no internal MIDI events queue.

The newly compiled binary is temporary stored here (use this together with the cfg line above):
522beta to test out

If this is not solving the issues, I need more details:
- What's the Reaper version?
- Do you mean that the same Reaper version and same Zyn version version work fine on your old computer but do not work correctly on your new computer? This would be really strange.
- What are you automating on your Reaper track where you use your strings patch?
- Are you using host automation ("*" in channel of Midi Learn) or are you just sending midi CCs to automate volume?
- If you automate CCs in your midi track, what are the exact CCs that you send? CC7 (volume?) CC11 (expression?) - other CC values?
- To debug, I would need to know exactly what MIDI data Reaper sends to Zyn...
- I find it difficult to believe that a new CPU and windows 10 have anything to do with this...
- If all fails, it would be really helpful if you send to me a reaper project with just the track that is causing problems (or only part of it so I can replicate the behavior - not your complete composition), and the Zyn patch causing the issue.

EDIT:
- Maybe you could add: CC11:-1 to that line?
Last edited by jackoo on Sat Apr 02, 2022 6:02 am, edited 2 times in total.

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sat Apr 02, 2022 5:48 am

jackoo wrote: Sat Apr 02, 2022 5:32 am - Do you mean that the same Reaper version and same Zyn version version work fine on your old computer but do not work correctly on your new computer? This would be really strange.
I'm in a cafe right now, it's very noisy. So I have to leave soon. I'll give you a better answer when I get home, but I just wanted to tell you that I've been using v2.4.1.521beta for something like two years, and the new computer is only two months. So that smoothing you mention could hardly (?) be the problem. But when it comes to REAPER, they offer new updates once or twice a week. I think almost no one has got time to read all those change logs (or whatever they are called). And W10 has also been updated during those two months.

That's all I can say at the moment.
Last edited by per99 on Sat Apr 02, 2022 12:05 pm, edited 1 time in total.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sat Apr 02, 2022 12:03 pm

I haven't tried your edit-suggestion (cc 11) yet, but I noticed that this phenomenon does not occur if I use no automation. But if I want to control the main volume (that part's/instrument's volume) from the midi-track, using the Zyn's midi-window, where it feels natural for me to choose cc 7 - then the volume knob is turned up to maximum, at STOP, even if the cc 7-graph at the bottom of the midi-track is a straight line at level 64. (But when I press PLAY again, it returns to 64.)

EDIT: I haven't tried <par name="cc_latency" value="0"/> either - I got back home just half an hour ago. But it seems a little bit unlikely that smoothing has got anything to do with this.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sat Apr 02, 2022 12:39 pm

@jackoo I'll send you a complete (but small) REAPER-project tomorrow. Have to go to bed.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sun Apr 03, 2022 12:43 am

To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
jackoo
KVRian
932 posts since 3 Jul, 2006

Post Sun Apr 03, 2022 6:47 am

Hi Per,

Many thanks for sharing that project. I was able to replicate the issue, and I think I know how to fix it.

It seems that Reaper changed a little bit in interpreting that line in the Preferences window:
Instead of capital letters CC7=-1, you have to use small (lower case letters) like cc7=-1.

In the example you sent, with capital letters, Reaper still sends CC7=127 to Zyn, when you stop the playback. This makes the loud volume. I tried to change from "CC" to "cc" and then it worked.

So starting from your initial image, just replace the line in Reaper's preferences / Playback with:
cc52=-1;cc53=-1;cc54=-1;cc1=-1;cc7=-1

This worked for me.

Please let me know if this helps!

PS: Your string patch is reaaaaaly beautiful! Really good sound design!!! :hyper: :tu: :phones: :clap:

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Sun Apr 03, 2022 12:20 pm

I must say you're a remarkable detective, jackoo! Reaper uses capital letters (CC) in the dialog playback box (where you make those settings) as well as in their manual (I think it's page 405). It's beyond my imagination how they can do that, if it's so important with lower case letters. I'm not sure if I used lower case letters or not in my old computer, and I can't check it either. But if I did it, it must have been some kind of mistake.

I haven't tested to change to lower case letters yet (I'm too tired), but I think we can assume it will work.

Thanks for your help, cheers
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

User avatar
per99
KVRist
Topic Starter
229 posts since 5 Oct, 2017 from Närförort söder

Post Fri Apr 08, 2022 4:08 am

Fun fact: I used the system restore point-feature yesterday. I had not expected the system restore to change the lower case cc:s back to capital ones. But it did. I took me a few minutes to realize what had happened, and I felt rather disillusioned during those minutes, to say the least.

BTW I'm going to inform Cockos about the insanity in not mentioning the need for lower case letters. No one (expect those with a sixth sense) is going to guess this. CC is the common abbreviation everywhere.

I noticed that marking several notes in the midi editor and moving them (dragging) still makes a lot of nois (VU-meters gets red). But that's not a big problem, it's often possible to copy and paste, instead.
To be is to do — Socrates.
To do is to be — Jean-Paul Sartre.
Do be do be do — Frank Sinatra.

Return to “ZynAddSubFX”