All Mac VST plugins updated for Cubase 5 Compatibility

Official support for: bluecataudio.com
User avatar
Blue Cat Audio
KVRAF
4821 posts since 8 Sep, 2004 from Paris (France)

Post Tue May 05, 2009 10:50 am

All our free and commercial VST plugins for Mac have been updated to make them compatible with Cubase 5. If you previously encountered any issue with our plugins in Cubase 5 on your Mac, just download the new versions of our plugins!

Return to “Blue Cat Audio”