Bug reports

Official support for: musicdevelopments.com
RELATED
PRODUCTS
Fyler RapidComposer

Post

Hello Bob,

welcome to this forum, and thanks for your first post!
You are correct, I just checked the source code, the MIDI Mutator uses a newer rhythm mapping algorithm than the older Apply Rhythm variation.
What I can do is adding a "Preserve original velocity" option to Apply Rhythm in the next 2-3 days. I'll send you an update when this is done.

Rhythm in RapidComposer includes not just note positions but accents/velocities and note lengths too. But it indeed makes sense to offer an option to preserve the original velocities.

When converting an imported MIDI to a phrase generator, the velocities are preserved.

When applying rhythm, I think it is important to use repetitions, e.g. the rhythm pattern should repeat every 2 bars or 4 bars. It is possible to set this up in the MIDI Mutator (Repetition menu) and in the Length menu for the rhythm generators.

The latest beta version includes a Markov model, which you can use to create variations of the dropped MIDI file. I used Chopin pieces for fine tuning it.

Thanks,
Attila

Post

hello! i just updated to the latest version of Rapid Composer and it seems to have removed the ability to resize the window so now I am unable to use it as everything is very zoomed in. I'm using Bitwig 5. The older version was working for me before.

Post

Hello DramaticFanatic!

I made this screenshot with Bitwig 4 which let me resize the window by dragging the right bottom corner.

Image

If the host does not offer a resizable window, you can still resize the window in RapidComposer where the horizontal and vertical scrollbars meet (it is visible even when the browsers are hidden, that is why it is there).

You wrote "everything is very zoomed in". I hope you don't use Windows UI scaling. You can scale the RapidComposer UI by changing the font size under Settings / Miscellaneous. Does the standalone version appear normally? Can you send me a screenshot to the info@... address?

Thanks,
Attila

Post

So that option to expand the window is what is missing (or sometimes missing, just now it popped back up and I was able to resize it, but when I close the Rapid Composer plugin and start again it will default to this.Image

It appears like it defaults to a size that is too small for the "expand" button to appear in the bottom right side. I figured out if I hold down left-click right next to the little keyboard at the bottom left, it will turn into a resizer and I can get it big enough to make the resizer button to re-appear. I'm not sure why this is the case. In the standalone app it will open up at the correct size.

Post

This is very strange. The program should use the same font size for the standalone and plug-in, so I do not understand why the plug-in appears with a big font. Does it work if you click on the "Settings" tab at the top, then "User Interface", and set a smaller font?

When RC is run for the very first time, the monitor resolution is checked and a suitable font size is chosen (big font for bigger resolution), but this is done only once.

Post

bobby mac wrote: Sun May 14, 2023 2:10 am Hello,

Recently, I have been using the demo version of RC, and I have come across some really great features. However, I have noticed that when I apply rhythm to any MIDI file or convert it to a generator, I instantly lose the velocity. This is very disappointing, especially since I'm importing piano pieces from classical music that have unique and expressive velocities.
Hello Bob,

I am not able to send you a PM. I wanted to send you the latest beta version with "preserve original accents" implemented for "apply rhythm".
Please let me know where I can send you the beta version download links.

Thanks!
Attila

Post

I'm having trouble loading Rapid Composer after installing the 4.7.0 Update."Fatal Error when loading Rapid composer: Libraries cannot be located.Abort.
I tried uninstalling then re-installing the previous version, but I get the same message for each time. Any thoughts?
 
error.png
You do not have the required permissions to view the files attached to this post.

Post

Chords.rcCHRD and other files should be there.

Can you check if you have a C:\Users\Public\RapidComposerV4 folder?
If so, please move all files to your Documents\RapidComposerV4 folder.
If not, run the v4.7 installer, and without running RapidComposer, move the files manually to your Documents\RapidComposerV4 folder.

The installer places data files there. RapidComposer, when first run, should move those files to your Documents folder.

The explanation for this is that the installer is run with administrator privileges, to be able to write files in your Program Files folder. However the user Documents folder is not available to the installer (it does not know the user name when it is the administrator).

Thanks,
Attila

Post

That worked! Thanks!

Post

Hi Attila,

Thank you for your response. I will send you an email shortly.

Thanks!
Bob

Post

magmagwa wrote: Tue May 16, 2023 3:42 am
BluGenes wrote: Sat May 13, 2023 3:49 pm Just so you know, if RC crashes you should at some point do a reboot. When it does, it won't unload properly and kind of stick around in memory. It is always best to start fresh.. If it continues to crash, of course please report it..
I know on windows people do like to reboot. However, memory for an exiting process will be cleaned up. When the process is restarted, new memory is allocated. Unless the process is allocating it's own persistent shared memory and then reattaching to it on startup. This seems quite unlikely for RC but would be a bug if it's not cleaning it up properly. If RC is keeping around lock files or state files, that could also cause state issues.

It's really up to RC developers to know if there is state across instantiations.

I definitely hesitate on the "reboot" to fix problems since it changes so many variables.

All this beind said, I do reboot as a last resort/test because "you never know".
yea, had to go deeper into this, sorry, old post and all, but, it is better just to reboot.. probably best explained in this video, by one guys that wrote the OS.

https://youtu.be/9IPP39OF78M

Post

Hello all, I'm not sure if this is an application bug or my own bug :-) but in Reaper when configuring routing from a track with Rapidcomposer VST to other tracks it sends duplicated midi notes (notes on and off, oddly also note off value is always velocity 1 in this case) ONLY when the track is armed and I'm playing the keyboard, when playing something already recorded in RC it plays back fine (including note off with the real value).

How sends are set up is 1 per track to different tracks in reaper, audio off, and midi channel remapped always to channel 1 in the routing in the DAW. I'm attaching a screenshot of my routing config as well as the MIDI Log showing the duplicates and wrong note off velocities.

Thanks in advance for any insights
screnshot.jpg
You do not have the required permissions to view the files attached to this post.

Post

Found half of the problem, my midi keyboard was sending 2 midi messages to the channel, so that's why the note duplication issue, though, after addressing that issue the note off value being velocity 1 is still mantained, oddly, when recording within RC plugin the note off value is preserved and replayed correctly.... another snapshot, the selected notes are the ones replayed after recording and the first group are the notes as I was playing and recording them.
screnshot2.jpg
You do not have the required permissions to view the files attached to this post.

Post

I installed a new motherboard which has the same Realtek sound chip as I had before but has a different name for the output port, which is what Rapid Composer is configured for. I have uninstalled and reinstalled Rapid Composer and the sound chip driver, tried rebooting in safe mode. RC always comes up looking for the invalid device and immediately dies.

I can run the VST inside my DAW because it sets the audio device via the DAW. But I would like to be able to run standalone. This is Windows 11 latest updates. Is there a registry edit I can do to remove the invalid audio device name?

Post

Hey all, need someone to confirm this bug please..

Using these steps:

1 ) New composition about 8 bars is fine.
2 ) Select a melody generator, then select the track header and press "F" to fill the track
3 ) Select the track inspector and place a VST instrument for the melody.
4 ) Select all the phrases in the track and right click to open the Phrase Inspector.
5 ) Open the Harmonize Tab and harmonize the track with add the harmony track checked.
6 ) Harmonize.
7 ) Select the Harmony track just created and add a VST to this track.
8 ) Select the phrases in the Harmony track and click the mute button on the phrase, all mute buttons should be yellow.
9 ) Save the composition.

The bug should be that harmony track loses the ability to open the VST and the track reverts to the default sound font information on the track, once the composition is saved. The actual VST is still in memory.

Much appreciated!

Return to “MusicDevelopments”