Login / Register 0 items | $0.00 New @ KVR
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Sat Aug 12, 2017 11:12 am AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

Hey OverTone DSP team,

Thanks for developing the Linux plugins. Unfortunately the Equalizer plugin AF-210 doesn't work on Linux because of incompatible OpenGL versions. The GUI of the plugin leaves black... Enclosed you find the output:

** INFO: AF210 - System GL Version is: 3.0 Mesa 17.1.5
** INFO: AF210 - System GLSL Version is: 1.30 : #version 100

AF210::GFX_renderer::GFX-VXSHDR-03 failed to compile
0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES


AF210::GFX_renderer::GFX-PXSHDR-03 failed to compile
0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES


AF210::GFX_renderer::GFX-UNSHDR-03 failed to link
error: linking with uncompiled shadererror: linking with uncompiled shader

AF210::GFX_renderer::GFX-VXSHDR-02 failed to compile
0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES


AF210::GFX_renderer::GFX-PXSHDR-02 failed to compile
0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES

[...]



It is a little bit curious becaus GLSL 1.50 is a highe version as the supported one??? I have an intel kaby lake chipset and an intel hd630 graphic card...

Thanks in advance,
Max
Last edited by MaxPerl on Sun Aug 13, 2017 3:14 am, edited 1 time in total.
lentferj
KVRist
 
96 posts since 4 Feb, 2016

Postby lentferj; Sat Aug 12, 2017 12:26 pm Re: AF-210 - GUI doesn't work on Linux

Works here on Debian 9 (worked on 8, too) in Ardour and Bitwig.
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Sat Aug 12, 2017 11:14 pm Re: AF-210 - GUI doesn't work on Linux

Thanks for the reply. Which graphic card do you use? Perhaps the reason is that I use Mageia 6 and there is the new Mesa 17.x version installed whereas in Debian 9 the old Mesa 13.x or in Jessie even the 10.x Mesa drivers are preinstalled? I just find it curious that GLSL 1.50 seems to be the newer version. Or do I have here an error in reasoning?
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Sat Aug 12, 2017 11:35 pm Re: AF-210 - GUI doesn't work on Linux

PS.: Could you post your output of "glxinfo | grep OpenGL" ? This would be interessting for me.

Here is my output:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.1.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.1.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 17.1.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
OverTone DSP
KVRist
 
87 posts since 23 Feb, 2012, from Oxford, England

Postby OverTone DSP; Sun Aug 13, 2017 12:39 am Re: AF-210 - GUI doesn't work on Linux

Something odd is happening when determining the glsl version you have in your driver:

** INFO: AF210 - System GLSL Version is: 1.30 : #version 100


When we test it here we get the expected:

** INFO: AF210 - System GLSL Version is: 1.30 : #version 130


In your case our gl renderer thinks that you are running glsl 1.0 which it doesn't support (as almost all versions of glsl are incompatible in some way, it has to determine which version specific shader code to compile at run time. In this case it fails over to glsl 1.50 as this is the more likely to be supported in more recent versions of opengl. This causes an error because the shader code is then asking for glsl 1.5 which your system doesn't support).

We will investigate further - in the meantime you should find it works correctly if you have drivers which support glsl 1.5

The title of the post is a bit misleading to other potential users - to clarify, its not true that the AF210 doesn't work on linux - which other users might infer from the title - it doesn't work on this particular install of linux and with your particular combination of openl graphics driver and chipset.

It would help to know if this is 32 or 64Bit?
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Sun Aug 13, 2017 3:08 am Re: AF-210 - GUI doesn't work on Mageia 6 and Intel HD620

Dear OvertoneDSP team,

Thanks a lot for your reply. I run a 64bit system. It would be great if you could fix my problem.

The title is indeed a little bit misunderstanding. Can I change it in any way or could a moderator of the forum change the title?

Best wishes,
Max
lentferj
KVRist
 
96 posts since 4 Feb, 2016

Postby lentferj; Sun Aug 13, 2017 6:55 am Re: AF-210 - GUI doesn't work on Linux

MaxPerl wrote:PS.: Could you post your output of "glxinfo | grep OpenGL" ? This would be interessting for me.



$ glxinfo | grep -i opengl
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 3800/PCIe/SSE2
OpenGL core profile version string: 3.3.0 NVIDIA 340.102
OpenGL core profile shading language version string: 3.30 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.3.0 NVIDIA 340.102
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 340.102 340.102
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00
OpenGL ES profile extensions:
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Mon Aug 14, 2017 1:48 pm Re: AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

Dear OvertoneDSP team,

I just tested the plugin on another laptop with Intel BayTrail chipset and an Intel HD graphic card and I got exactly the same issue. It seems to be an Intel problem.. I will test another distribution the next days...

Would it be possible to test version 2.4.2 (e.g. the last version without OpenGL) in the meantime?

If I could help you in any way, please let me know.

Thank you very much for working on linux audio plugins!

Best wishes,
Max
OverTone DSP
KVRist
 
87 posts since 23 Feb, 2012, from Oxford, England

Postby OverTone DSP; Mon Aug 14, 2017 10:25 pm Re: AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

Forums are probably not the best place to try to resolve very specific compatibility issues - if you can use the contact support page at: https://www.overtonedsp.co.uk/contact/ we may be better able to establish what is happening with your particular distribution and / or configuration. It is unlikely to be an intel specific problem - we test compatibility here with various intel GPUs and are not seeing the issue. It is more likely a combination of something unusual in your distribution combined with a lack of mesa graphics driver support for more recent glsl.
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Tue Aug 15, 2017 1:34 am Re: AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

Dear OvertoneDSP team,

Thanks for your reply. I still have sent a eMail regarding this problem. But it seems that you are more responding here ;-) Indeed I did not described my problem in the same depth as here in the contact formular. Therefore I will sent another eMail later to your support.

I don't think that it is a compatibility issue. I tested it on two laptops and two distributions. The problem occurrs on Ubuntu 17.04 (the mainstream distro), too.. The Mesa guys suppose a application issue, too. (see https://bugs.freedesktop.org/show_bug.cgi?id=102200 ). I will try Ubuntu 15.04 later...

But - as said - I will try to contact your support again later. On the other side, perhaps other people have the same problem. Therefore an public discussion could be helpful, too...

Thanks for all your work and help,
Max
OverTone DSP
KVRist
 
87 posts since 23 Feb, 2012, from Oxford, England

Postby OverTone DSP; Wed Aug 16, 2017 3:08 am Re: AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

You should have now received a reply to your support request, and most recently some links to download a beta update. If this addresses the issue you are seeing we can incorporate the changes into the next update for linux. Please let us know via the support email if there are any issues.
MaxPerl
KVRer
 
7 posts since 12 Aug, 2017

Postby MaxPerl; Wed Aug 16, 2017 11:50 am Re: AF-210 - GUI doesn't work on Mageia 6 with Intel HD620

The support of OvertoneDSP is simply fantastic. Yesterday the developer of the plugin wrote me, today it is solved. Incredibly!!! I never experienced such a great support. And the products are awesome, too!!!
Thank you so much!!

Moderator: OverTone DSP

Return to OverTone DSP