Help: Repro-1 does not respond to any Midi Messages!

Official support for: u-he.com
luqsuasa
KVRer
21 posts since 19 Jan, 2016

Post Fri Oct 13, 2017 3:51 am

I am a little new in this world of DAWs & VSTs.

I am using a simple DAW/Midi Sequencer (Anvil Studio with Pro-Mix Accessory) to set up some instances/tracks of Repro-1.

On each Anvil Studio track I assigned an independent Repro-1 instance and then on the beginning of the track MIDI data I configured the following MIDI messages:

Midi Bank Select (Selecting Bank 0) (MIDI CC 0)
Midi Program Change (Selecting the Repro-1 patch)
Midi Panpot (Selecting the Repro-1 patch stereo panning or placement) (MIDI CC 10)
Midi Channel Volume (Selecting the Repro-1 patch volume) (MIDI CC 7)

... But none of the Repro-1 instances on each Anvil Studio track is responding to these MIDI messages.

I cannot believe It would be impossible to set up these basic parameters (Patch, Pan, Volume) for each Repro-1 instance/Track, so I must doing something wrong. Also is not an Anvil Studio problem simply because if I use another VST (for instance Synth1 VST by Ichiro Toda) it works fine.

Anybody can help me in this, please? I will appreciate any help :pray:

best regards.

Sanluque

User avatar
#rob
KVRian
562 posts since 20 Aug, 2013

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Fri Oct 13, 2017 3:58 am

Click on the cogwheel icon in the upper right corner, select the parameter you want to control, send a CC message from the MIDI CC you want to control it with.
Cheers,
Rob
u-he | Support | FAQ | Patch Library

User avatar
Urs
u-he
24270 posts since 8 Aug, 2002 from Berlin

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Fri Oct 13, 2017 4:01 am

luqsuasa wrote:Midi Bank Select (Selecting Bank 0) (MIDI CC 0)
Midi Program Change (Selecting the Repro-1 patch)
Check out the user manual for use of the MIDI Programs folder.

luqsuasa
KVRer
21 posts since 19 Jan, 2016

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Sat Oct 14, 2017 11:10 am

Thanks for your advice Urs!

I organized the MIDI Programs folder with sub-folders (the banks) labeled from 000(Bank 0) to 127 (Bank 127) and the patches inside them from 000 Patch Name to 127 Patch Name and now Midi Bank Select (MIDI CC 0) and Midi Program Change commands from DAW are working fine. Thanks again. :clap:

But I was unable to assign the Parameter "Main Output:Output" to Controller (Midi Channel Volume) using the Repro-1 MIDI TABLE. Also I tried to use the Repro-1 MIDI LEARN selecting the Output Knob and moving the DAW track Volume slider but it did not work either. :(

The only thing I could do was to control the Output Knob (MIDI LEARN) from the knobs of my keyboard controller (Nektar Impact) but using the CC number fixed on the keyboard knobs, not with the CC 7.

Regarding the Midi Panpot) (MIDI CC 10) I could not find any Pan control on Repro-1 MIDI TABLE list so all the Repro-1 tracks on the DAW are played hard centered and panpot is not possible. Would I need a more advanced DAW to make and individual VST Panpot for each track? :help:

Thanks in advance for your advice.

Regards.

sanluque

tripleflows
KVRist
114 posts since 21 Feb, 2012

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Sun Jan 12, 2020 10:54 am

UPDATE: Ok, found the solution, thanks.

Another MIDI related question: how to set the global channel for Repro1?
I do know the MIDI Table / Learn, but these are mainly for controlling the synth.. but all I need the synth responds to e.g. Ch4 or Ch 9 while playing on the keyboard.
Currently Repro 1 seem to respond to MIDI Ch 1 only.

After RTFM, still do not find this thing, which is very basic on any synth.

What do I miss.. where is it?

thanks
Blaise

The unshushable Coktor
KVRist
306 posts since 18 May, 2007 from Berlin

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Thu Jan 16, 2020 12:55 am

tripleflows wrote:
Sun Jan 12, 2020 10:54 am
how to set the global channel for Repro1?
Hello Blaise,
your DAW does that, not the plugin. Find a way to change the MIDI channel that your track receives MIDI from. Which DAW do you use?

Viktor
u-he team
u-he team

tripleflows
KVRist
114 posts since 21 Feb, 2012

Re: Help: Repro-1 does not respond to any Midi Messages!

Post Thu Jan 16, 2020 2:08 am

Yes, thanks I found it in Cubase.

Return to “u-he”