DrivenByMoss - Bitwig extension for lots of controller devices (and more)

spritex
KVRian
851 posts since 4 Apr, 2001 from Finland

Post Sat Mar 16, 2019 12:49 am

I am not sure if this is related to the controller script, but I suspect so:

I am very new to Bitwig and got the APC40 mk2 yesterday. I also installed the newest DrivenByMoss extension, which seems very nice so far. However, I have been playing around today and noticed a possible bug:

I changed the top row of knobs to the "user" mode so that I can map them to whatever. I successfully mapped the first four knobs to sends from individual parts from a drum machine and to some controls on a reverb on the send track.

Problem is, when I map the knobs 5-8 they not work reliably. Mapping itself works but the knobs reset thier value to zero by itself just after turning the knob.

Any ideas?
Bitwig - Logic - U-He - NI Komplete - Geist - Korg Legacy

spritex
KVRian
851 posts since 4 Apr, 2001 from Finland

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Sat Mar 16, 2019 1:07 am

spritex wrote:
Sat Mar 16, 2019 12:49 am
Problem is, when I map the knobs 5-8 they not work reliably. Mapping itself works but the knobs reset thier value to zero by itself just after turning the knob.
Ha! Figured this out. I needed to create empty tracks corresponding to the remaining knobs.

Hmm, now on my current project the device control knobs don't follow the selected track anymore. I'll try to figure out why. They work as expected on a new project though.
Bitwig - Logic - U-He - NI Komplete - Geist - Korg Legacy

spritex
KVRian
851 posts since 4 Apr, 2001 from Finland

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Sat Mar 16, 2019 1:45 am

spritex wrote:
Sat Mar 16, 2019 1:07 am
Hmm, now on my current project the device control knobs don't follow the selected track anymore. I'll try to figure out why. They work as expected on a new project though.
A-ha! I had accidentally pressed this:
"Shift + Dev. Lock - Pin the cursor track and the cursor device."

Pressing it again makes it work as I thought again.

Thank you very much for this script. I initially tried the built-in one and the clip buttons didn't always flash properly, depending on the colour. With your script they work fine.

I am starting to like this whole setup quite a lot.
Bitwig - Logic - U-He - NI Komplete - Geist - Korg Legacy

SB-SIX
KVRist
170 posts since 30 Mar, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Sun Mar 17, 2019 3:14 am

I'm having some fun with the moss scripts lately, and ran into something, I'm not sure if its a bug or that I am doing something wrong. I'm trying to replicate the ableton behaviour where the cursor keys can navigate through the clips on the grid. Pressing up/down works fine when invoking it like: this.model.getSelectedTrack().getSlotBank ().selectPreviousItem();
Pressing left/right would need to first select the next/prev track (works fine too), and then the clip at the same row. The problem is with the latter, it seems that this.model.getSelectedTrack().getSlotBank().selectItemAtPosition(position) doesn't do anything?

User avatar
moss
KVRAF
1513 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Mar 18, 2019 1:58 am

SB-SIX wrote:
Sun Mar 17, 2019 3:14 am
Pressing left/right would need to first select the next/prev track (works fine too), and then the clip at the same row. The problem is with the latter, it seems that this.model.getSelectedTrack().getSlotBank().selectItemAtPosition(position) doesn't do anything?
Hmm, could be that the select() in the method needs to be delayed a bit after the scrollTo (like in selectPrevious).

SB-SIX
KVRist
170 posts since 30 Mar, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Mar 18, 2019 2:06 am

Cool thanks will try that!

User avatar
moss
KVRAF
1513 posts since 13 May, 2004

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Mar 18, 2019 2:14 am

SB-SIX wrote:
Mon Mar 18, 2019 2:06 am
Cool thanks will try that!
I checked in a modified version of the method. Could not test it but give it a try.

SB-SIX
KVRist
170 posts since 30 Mar, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Mar 18, 2019 10:49 am

moss wrote:
Mon Mar 18, 2019 2:14 am
SB-SIX wrote:
Mon Mar 18, 2019 2:06 am
Cool thanks will try that!
I checked in a modified version of the method. Could not test it but give it a try.
Cool thank you very much for the quick reply. I've tried and it kind of works :)
I can move up and down the clips using:

Code: Select all

this.model.getSelectedTrack().getSlotBank ().selectPreviousItem();
And move left/right by using:

Code: Select all

final ISlot selectedSlot = this.model.getSelectedSlot();
        if (selectedSlot != null){            
            final int slotposition = selectedSlot.getIndex();
            this.model.getTrackBank().selectNextItem();                    
            this.surface.scheduleTask ( () -> this.model.getSelectedTrack().getSlotBank().selectItemAtPosition(slotposition), 100);
        } else {
            this.model.getTrackBank().selectNextItem();
        }
But on the latter I get very strange behaviour. If I press left/right, at first it works, but when I have pressed down (it goes down), and then right, it goes right AND down. I've tried in several different ways too all with the same result. Can't figure out why, but it looks like the selectedslot is not reporting the right index.

zengel
KVRist
103 posts since 12 Jul, 2015

Re: DrivenByMoss - Bitwig extension for lots of controller devices (and more)

Post Mon Mar 18, 2019 11:06 am

Hello !
I have found a bug i think on the push 2 version.

When i am on send or master track the "automate" button does not work.
that's all ;)
thanks you for your work !
have a good evening

Return to “Controller Scripting”