Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Discussion about: tracktion.com
pdk_
KVRer
23 posts since 24 Oct, 2017

Post Fri Jul 13, 2018 2:14 pm

I am having this issue where the duration of a vst sound gets really short. For example a normal piano sound ends up having no sustain at all. I believe this happens when I use quantize on the midi editor or messing around moving notes in the editor. I have to reset the audio engine for the instrument to play notes correctly again. This happens with a lot of vsti and on two different computers with a different midi keyboard. I am using waveform 8 btw. The latest update for 8.

dRowAudio
KVRian
1264 posts since 30 Dec, 2012

Re: Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Post Tue Jul 17, 2018 3:24 am

Do you have "Loop" turned on but the transport playhead to the right of the "out marker" by any chance?

pdk_
KVRer
23 posts since 24 Oct, 2017

Re: Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Post Tue Jul 17, 2018 6:02 pm

When I press play everything works fine. The problem appears when I play with my midi keyboard or write notes in the midi editor. The only way to fix it is to reset the audio engine. Its really weird cause it appears only in those two cases not when the track is playing.

dRowAudio
KVRian
1264 posts since 30 Dec, 2012

Re: Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Post Wed Jul 18, 2018 1:15 am

Right, but that doesn't answer my specific questions...
Perhaps sending a short screen capture video to support@tracktion.com of the problem would help?

The difficulty with this is that there are hundreds of possible configurations we'd need to try with MIDI notes, transport position, groover/quantise settings etc. Having a video might let us spot where the mistake is much more quickly.

Cheers, Dave

pdk_
KVRer
23 posts since 24 Oct, 2017

Re: Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Post Wed Jul 18, 2018 2:10 am

Ok I will try to make a video demonstrating the problem.

zzz00m
KVRian
1338 posts since 17 Sep, 2016

Re: Tracktion seems to cut the sustain of any vst instrument after using the midi editor.

Post Wed Jul 18, 2018 6:40 am

I can reproduce this easily in Waveform 9, by enabling a loop and then placing the transport head to the right of the "out marker".

Move the transport head back into the loop region, and sustain is on again!

"Reset" also clears it.

If I have notes in the clip extending beyond the "out marker", this issue only seems to occur after playing the loop at least once. Otherwise, it happens as soon as I move the head out past the last note and the marker.
Windows 10; with instruments from AIR, Ample Sound, AAS, Cakewalk, IK Multimedia, iZotope, KV331, NI, Seaweed Audio, SONiVOX, TAL, Tracktion, u-he, Way Out Ware, XLN, others...

Return to “Tracktion”