VST effect that follows Kotelnikov GE stops passing audio in Cubase

Official support for: tokyodawn.net/tokyo-dawn-labs
User avatar
DrReacto
KVRist
115 posts since 21 Apr, 2016 from US

Post Tue Mar 05, 2019 8:05 am

It seems about 30% of the time when using Kotelnikov GE, on a group buss in Cubase 9.5 Windows 64bit, I will find audio will stop processing on that group/buss. It seems to start happening when I try to do an audio export/mixdown and I find the export empty. I go back to Cubase and find no audio is passing the group/buss. So far, it seems if I remove whichever VST effect that comes after Kotelnikov on the the inserts, the group/bus starts passing audio again.
If I put the other effect back, it still passes audio until I do another export and I end up with an empty export file.
What ultimately fixes it is removing Kotelnikov from the chain.
Im no where near maxing out on ASIO buffer. I work at 48khz. Kotelnikov and can be set to eco or precise and I have the problem.
Has anybody seen this issue?
Is there a work around?
I might try doing real time export to see if that makes a difference.
I like Kotelnikov but it is a big waste of time troubleshooting effects instead of mixing.
Yesterday it was PSP E27 that stopped passing audio. It worked fine until I added Kotelnikov. I have had other effects after Kotelnikov act the same way.

User avatar
FabienTDR
KVRian
1016 posts since 24 Feb, 2012

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 8:25 am

Mhhh weird never heard of such an issue before.

I wonder what Cubase support says about it, as this issue can technically only be theirs. Plugins have zero control over other plugins, if they have, it's most likely a bug by the host. It's under their responsibility (they launch, control and run the plugins. They also control the audio bus).

I just tried with latest cubase with two dozen channels, all with Kotelnikov and all sort of plugins afterwards. 64bit, VST, windows 7. No issue at all.

Do you see any crash reports appearing, or something else that is unusual? In doubt, pls send me a project where you see this happening.
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

DarkStar
KVRAF
8826 posts since 2 Sep, 2003 from Surrey, UK

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 8:31 am

Just a diagnostic suggestion:
-- put an analyser before Kotelnikov on the buss,
-- and another one after Kotelnikov,
-- and a third analyzer after the FX that was after Kotelnikov,
-- try the export,
-- go back to the analyzers and see how far along the chain the audio gets.
DarkStar
Interesting, if true ...

User avatar
DrReacto
KVRist
115 posts since 21 Apr, 2016 from US

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 8:43 am

No crash reports, just no audio on the group or render after an export about 1/3 of the time. I had read that Kotelnikov detects when host is doing an export and modifies it's internal quality setting. I am curious if this is what is triggering the issue and is there a setting to manually adjust offline export/render quality? I know Cytomic and Melda have those as oversample settings. Not sure if TDR works the same way.
I will be testing realtime renders from now on whenever I run into this problem, which will likely be today.
Thanks for the super fast reply.

User avatar
FabienTDR
KVRian
1016 posts since 24 Feb, 2012

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 8:43 am

Ok, I'll try that
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

User avatar
FabienTDR
KVRian
1016 posts since 24 Feb, 2012

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 8:59 am

Good idea DrReacto, this new feature could be a cause.

So you have the render at max quality option enabled? maybe try without it, just to exclude the cause when it still reappears.
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

User avatar
FabienTDR
KVRian
1016 posts since 24 Feb, 2012

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 9:10 am

Would be interesting for me to know if this also happens with the standard edition, any info on this?
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

User avatar
DrReacto
KVRist
115 posts since 21 Apr, 2016 from US

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 9:42 am

Note that I'm not stating there is an issue with Kotelnikov, I was hoping there could be a known issue so that I could stop troubleshooting. I likely use the same subset of plugins plus Cubase.
I tried real time export, no difference. Took off the PSPe27 that seemed to be acting buggy, only after I added Kotel (perhaps coincidence). Audio would play through the group/buss but no export until removed kotelnikov. I added PSP e27 back and its working fine.
Kotelnikov already had the offline render for max quality setting at off so I didn't change it.
I had already deleted Kotelnikov when I purchased GE as I love/love the extra features in GE so much, I couldn't imagine using non-GE.

***********************
This is really strange. Same project, I don't have the PSPe27 loaded. I don't have Kotel loaded. I insert Kotel on group. Renders fine. I change preset to Optical Illusion. Doesn't pass audio on render. I switch preset back to default on Kotel. Renders fine.
I change preset back to Optical Illusion ( one of my favorites by the way), and no audio on render.
Some of the settings in that factory preset, yin, or intertia, or FDR having an effect? Asio buffer looks fine, check out attachment.
You do not have the required permissions to view the files attached to this post.

User avatar
DrReacto
KVRist
115 posts since 21 Apr, 2016 from US

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 9:47 am

Just to confirm, I deleted Kotel, then added it back as an insert.
Render fine.
I turned on Yin, Interia, FDR.
Render fine.

I switched to optical illusion preset. Render fails to pass audio.

User avatar
DrReacto
KVRist
115 posts since 21 Apr, 2016 from US

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 10:05 am

Turns out I am using v1.5.1, so I upgraded to v1.5.2 and using the same project I'm not having any issues at this time. Was it the Kotel version or was just restarting Cubase the fix? I had already restarted cubase and the computer thought and was still experiencing the issue before.
I've ran into a very similar problem before when using Kotel, so I'll keep an eye on that and whatever else that might be going on to determine where the issue is coming from.

User avatar
FabienTDR
KVRian
1016 posts since 24 Feb, 2012

Re: VST effect that follows Kotelnikov GE stops passing audio in Cubase

Post Tue Mar 05, 2019 10:34 am

Cool, many thanks for the efforts! Yes, 1.5.2 contained an important (undocummeted) bug fix. Sadly I can't remember what it was.
Fabien from Tokyo Dawn Records

Check out my audio processors over at the Tokyo Dawn Labs!

Return to “Tokyo Dawn Labs”