SM2.9, layer2 has endless sustain, Bug or something I'm missing ?

Official support for: kv331audio.com
RandyEspoda
KVRer
14 posts since 19 Aug, 2017

Post Wed Mar 06, 2019 2:58 pm

Hi,

I'm completely new with this Synth and I'm getting along just fine, everything once understood is fairly intuitive. But I cannot for the life of me get Layer 2 to work properly.

Whatever I do, whenever I activate an oscillator of Layer 2, it doesn't seem to respond to envelopes, LFOs and sustain seems to continuously go on until I turn volume to zero, even after stopping play.

It seems almost like a feedback loop. Is this a bug or am I just missing something.
I've spent the better half of 2 hours trying to find any setting that could pertain to it, also in the matrix,
but nothing I do fixes this.

I was just getting the hang of it, started using Layer 2 and it's just unusable.

I've seen this mentioned like two times already in this forum, but nowhere is a solution mentioned.
I'm kind of stuck with this now...anyone ?

RandyEspoda
KVRer
14 posts since 19 Aug, 2017

Re: SM2.9, layer2 has endless sustain, Bug or something I'm missing ?

Post Wed Mar 06, 2019 4:45 pm

Ok so I found what was causing this :

An ADSR needs to be connected to the voice volume of the layer,
so I knew something related to it was likely causing this.
But no matter how many times I tried, it didn't seem to respond to any envelope or LFO.
I knew it was because when I connected an ADSR to the voice volume, the knob in the matrix
never went to zero, only halfway, and it took me until now to find why that was...
Apparently, in the matrix list, for the knob to go to full zero you need to click the little + sign
on the left and change it to multiply.

I read the manual yesterday and can't remember reading anything about this,
otherwise I would've known this, somehow I completely looked past it...

This seems to be a unique 'thing' with SM because of the way the routing is set up,
and I suspect I'm not the only one starting out with SM hitting this problem and struggling to find the solution...

So if you have the issue of endless sustain on an oscillator, and sound not dropping after stopping playback,
check the matrix for the ADSR/VoiceVolume entry and change the + to x so that the modulation knob goes fully to zero.

kv331
KVRAF
5577 posts since 14 Nov, 2006 from Ankara, Turkey

Re: SM2.9, layer2 has endless sustain, Bug or something I'm missing ?

Post Wed Mar 06, 2019 11:31 pm

Hi Randy, as you found out, it's written in the user manual. NI's Massive is like that too. if there are no envelopes connected to osc outputs, the oscillators never terminate in Massive as well.
Works at KV331 Audio
SynthMaster voted "Best VST/AU Synth of 2016" by MusicRadar readers
SynthMaster One voted "Best New Virtual Instrument of 2017" by MusicRadar readers

RandyEspoda
KVRer
14 posts since 19 Aug, 2017

Re: SM2.9, layer2 has endless sustain, Bug or something I'm missing ?

Post Thu Mar 07, 2019 5:49 am

Took me a while because I could not find it in the manual. All is good now, beginning to love it more and more. Thank you !

Return to “KV331 Audio”