will aptrigga be developed further?

Official support for: www.apulsoft.ch
rockiner
KVRer
9 posts since 3 Feb, 2018

Post Fri Nov 15, 2019 3:45 am

if so will it someday be able to render its contents 1:1? the timing is off and sometimes renders a non symetrical pattern to the one triggering the samples...and that would be ok, i can nudge things, but what it renders doesnt pass a null test and does not sound like what i spent 30mins working on.. it seems like a resampling problem but i cant find any info online or in the manual about what sample rate, bit rate, pan law aptrigga is using so im assuming its using whatever the host is saying. in any case, weather stereo or mono, sounds print flat and 1 dimensional sounding in comparison to what i had. ive been living with this but i think im fed up...i think you are too. it has great potential and there still isnt anything rivaling its options, but not being able to use the sounds, say when mixing down your friend drumming for an hour, isnt even crippling. its lazy death. and i know youd love a fight, but you know, look at this forum...let us/me know if youre done...or do i keep hanging on hoping that the next update address these and other fundemental basics instead of flipping the gui around and adding/removing features. this thing would be great guy, whats wrong with you? no one needs another harmonic generator, we all need a flexible drum replacer/trigger. and did i mention the crashes? listen: ive gotten used to it, a year of reloading projects every 20 mins, am i not faithful? loyal? when i buy smoething it should work. im also an independent developer of product, so i can understand delay and needing to get hype up, rushing things...this is long enough.

Pflugshaupt
KVRist
47 posts since 12 May, 2005 from Zürich

Re: will aptrigga be developed further?

Post Fri Nov 15, 2019 5:08 am

Hmm.. let's cool down a bit. First of all... apTrigga3 will see more updates in the future. But the things you're having trouble with.. they aren't being worked on as frankly you seem to be the only one having these issues. Or let's say the only person contacting me about it. I don't know what is going on with those things. I'd need much better information to even consider working on improving any of these aspects.

What do you mean by "render its contents 1:1".. that makes no sense to me at all. I need examples if you think something is wrong. I also need to know what version you are using in what host on what system and what you are trying to achieve. Ok I see from the other thread.. it's reaper running at 44.1 kHz. on Windows xp? Give me at least a chance to verify your claims. I'm happy to patch the plugin if I can reproduce a problem in a specific situation.

What does this mean: "what it renders doesnt pass a null test".. ?

If you are getting crashes.. do you get any information about them?

Maybe we'd be better of discussing all this by email.

Pflugshaupt
KVRist
47 posts since 12 May, 2005 from Zürich

Re: will aptrigga be developed further?

Post Sun Nov 17, 2019 6:11 am

As your post has impacted me more than I'd like to admit, I did run some tests on reaper myself but cannot get any of the issues you are facing to happen. I have seen no crashes and for me renders of single tracks and whole projects sound the same as the real-time processing. If I phase-invert a render of a track I get zero output in case the apTrigga3 patch isn't using any features involving randomness. These are random sample selection, use of generated noise and random modulation - which make the output be slightly different on every trigger on purpose.

rockiner
KVRer
9 posts since 3 Feb, 2018

Re: will aptrigga be developed further?

Post Thu Nov 21, 2019 5:17 am

1. you stopped replying to my emails. been waiting...
2. im not the only one. you told the other guy to try switching the detector's setting from fast to precise or "the other way around"...was regarding the latency while rendering..remember? you said trigga3 was more of a live sound thing somewhere else...theres so little documentation online, i think thisll be useful to others.
3. in order to completely exclude my own errors from being at fault, i started a new windows installation and ive been double checking on a win7 64bit system also with reaper and steinberg cubase.
id like to know what your specs are and see some of that flawlessness for myself. i can set anything up. i need trigga3 to run on windows xp 32bit reaper 5.9x, 44,1khz 24bit, asio mainly because of an older sound card that sounds better than anything ive heard since. yes i have up to date drivers for it...
4. sure ill cool it, when we get to the bottom of this and im on my merry way. its been years guy! in the end, this is about making music and im willing to go way beyond the dues of a customer to help you get this thing fixed. yeah im a lil bitter...youre a lil aloof and dismissive.

no, no randomness modulation is running. a bar or two is looped and is playing back identically every pass. reaper even has a live bounce option, and its not the same (1:1) there either. realtime rendering, after realigning at sample depth to compensate for the latency also not nulling. offline rendering also the same change of dimension. it sounds like theres a bit depth reduction or something with the panning. i think the quickest way out of this, would be me trying to replicate your setup honestly.

Pflugshaupt
KVRist
47 posts since 12 May, 2005 from Zürich

Re: will aptrigga be developed further?

Post Thu Nov 21, 2019 5:50 am

1) I'm sorry - I am not aware of this. Please give me a hint how to locate your mails. Maybe you get filtered away midway somehow.
2) Yes this will affect latency depending on the input content. However this is unrelated to the problem you are describing. If I understand correctly, you are saying the latency is changing for you when running the exact same input signal through the plugin.. you wrote you don't get the same timing when listening in real time vs. offline. Fast vs. precise is just about how transients are detected, but not about consistency. Unless there is a bug (and I'd really like to fix such a bug), the same input should always produce the same timing.
3) This is not necessary. Just let me know if the issues you are seeing happen on Windows 7 or 10 as well so we can exclude window XP from the list of possible causes. I guess you pretty much already confirmed that. "Flawlessness" ... That's a very subjective term. I just want to make sure the same input leads to the same output every time because you wrote that's not happening for you.
4) I'm sorry I made you bitter, but I think this is all a communication problem. I just don't understand the precise problem you are facing so I still don't even know where to start looking for a solution. I tried to replicate your issues based on what you wrote, but had zero success.

"realtime rendering, after realigning at sample depth to compensate for the latency also not nulling.".. sorry I don't get this? I don't understand what you compare to what - if you change the result manually how could it ever be consistent or sum to null?. Please give me an example that is as simple as possible.

"offline rendering also the same change of dimension.". What does that mean? If I understand right you are saying the sound changes somehow once you do offline rendering. Can you describe the issue in more scientific terms? Change of dimension.. means mostly nothing to me.. I could only imagine a stereo sample rendered as mono by accident.

"it sounds like there is a bit depth reduction or something with the panning.". How are you using the pan in apTrigga3? Normally I'd recommend to use the DAWs panning unless you need pan effects in the sound.
And again you say this is different real-time vs offline? I apologize for all your trouble, but it's just so hard to believe this.. From my view real-time vs offline makes absolutely zero difference. It is running through the same code in both cases.

So overall I just don't get it. can you send me a preset you are using when the problems happen so I can try it on my system (win 10, latest reaper (32bit!))? To get to the bottom of this the only way is to make problems occur on my systems because that would allow me to debug properly once I can reliably experience the problem.

Return to “apulSoft”