SynthMaster One: Midilearn problem

Official support for: kv331audio.com
-Neb-
KVRer
13 posts since 30 Nov, 2019

Post Sun Dec 01, 2019 4:01 pm

I'm trying to use 'midilearn' to map some knobs on my Arturia Minilab II to parameters SynthMaster One.

I can successfully map knob 3 which uses CC71, to the cutoff control in 'One'.

However, knob 1 (CC112) and knob 2 (CC74) will map, but do not move the cutoff control in the synth.

Can anyone explain why CC71 works, but CC112 and CC74 don't?

Thanks.

-Neb-
KVRer
13 posts since 30 Nov, 2019

Re: SynthMaster One: Midilearn problem

Post Sun Dec 08, 2019 10:47 am

I still have this problem if anyone can help.

kv331
KVRAF
5863 posts since 14 Nov, 2006 from Ankara, Turkey

Re: SynthMaster One: Midilearn problem

Post Sun Dec 08, 2019 10:54 am

Hi guys,

Could it be that your controller is sending MSB + LSB combination ? We don't support that yet.
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

kv331
KVRAF
5863 posts since 14 Nov, 2006 from Ankara, Turkey

Re: SynthMaster One: Midilearn problem

Post Sun Dec 08, 2019 10:55 am

Can you please do me a favor, and record the MIDI sent by your controller? If you can send me the MIDI file I'll check if it has to do with MSB+LSB
Works at KV331 Audio
SynthMaster voted #1 in MusicRadar's "Best Synth of 2019" poll
SynthMaster One voted #4 in MusicRadar's "Best Synth of 2019" poll

-Neb-
KVRer
13 posts since 30 Nov, 2019

Re: SynthMaster One: Midilearn problem

Post Sun Dec 08, 2019 4:42 pm

Can you please do me a favor, and record the MIDI sent by your controller?
Sorry, I don't know what you mean by that. This is the data captured in Reaper when I move the knob:

0: B0 4A 01 [CC74 Brightness/Cutoff Freq] chan 1 val 1
1: B0 4A 02 [CC74 Brightness/Cutoff Freq] chan 1 val 2
2: B0 4A 03 [CC74 Brightness/Cutoff Freq] chan 1 val 3
3: B0 4A 04 [CC74 Brightness/Cutoff Freq] chan 1 val 4
4: B0 4A 05 [CC74 Brightness/Cutoff Freq] chan 1 val 5
5: B0 4A 06 [CC74 Brightness/Cutoff Freq] chan 1 val 6
6: B0 4A 07 [CC74 Brightness/Cutoff Freq] chan 1 val 7
7: B0 4A 08 [CC74 Brightness/Cutoff Freq] chan 1 val 8
8: B0 4A 09 [CC74 Brightness/Cutoff Freq] chan 1 val 9
9: B0 4A 0A [CC74 Brightness/Cutoff Freq] chan 1 val 10

Note that if I change the CC number that is assigned to the knob, then the midilearn works. So the problem has something to do with it being assigned to CC74, I think.

Return to “KV331 Audio”