W11 Beta's Up!

Discussion about: tracktion.com
chico.co.uk
KVRAF
2368 posts since 17 Jun, 2003

Post Thu Feb 13, 2020 3:55 am

netsvetaev wrote:
Wed Feb 12, 2020 10:39 pm
Hi!
I can’t call plugins' context menus by two-fingers’ tap on macbook trackpad/right mouse click. Menus are showing only if I press ctrl+left mouse/one-finger tap. I’ve had this bug since W9. Please, help :-D
Video: https://www.dropbox.com/s/skhp4mohi4qup ... 8.mov?dl=0
Both right mouse click and two finger tap on the macbook trackpad are working for me, to do this.

I'd be inclined to close waveform, backup then delete your settings file (under ~/Library/Application Support/Tracktion/Waveform/Waveform.settings), restart waveform, and see if anything changes. If not, close it down, and copy your backed up settings file back
"my gosh it's a friggin hardware"

vitocorleone123
KVRist
410 posts since 30 Jun, 2014 from Pacific NW

Re: W11 Beta's Up!

Post Thu Feb 13, 2020 8:33 am

I still struggle with Waveform at times in not knowing when it will - or will not - trigger MIDI at the start. This has been a problem for several versions now, and I'd really hoped it finally would've been fixed in v11.

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 4:00 am

The first MIDI note is an issue in two place:
1) If you have a plugin with latency on the track, we will be embarking on a plan to fix this in 2020
2) If you have plugins that don't like to receive an all-notes-off message in the same block as a note-on. These are bugs in the plugins and should be fixed by the plugin manufacturers

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 4:03 am

Version 11.0.15 now available via your tracktion.com Downloads page for pre-sale customers:

Code: Select all

11.0.15:
- Racks:            Avoided a situation where plugins could become silent when wrapped in a Rack
- Tempo:            Fixed a crash cutting or copying tempo points
- Time sigs:        Fixed a crash triggering the shortcut to insert a time sig when not on an Edit screen
- Racks:            Ensured Rack presets are sorted alphabetically in the "Rack plugins" popup menu
- Insert plugin:    Fixed an issue with the warning message not updating when viewed using the plugin window
- 4OSC & Arp:       Fixed enabled buttons not reflecting enabled state
- Arp:              Fixed a crash closing the Arp window
- Arranger Track:   Added a new mouse cursor and some icons to make drag-to-arrange actions more obvious
- Project List:     Ensured project list folders stay closed when adding/removing projects

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 4:04 am

spoontechnique wrote:
Wed Feb 12, 2020 10:28 am
Minor complaint: In the projects menu, any attempt to organize projects (moving them around, creating new ones, etc.) still causes all subfolders to pop open. This makes it difficult to organize many projects.
This should be fixed in 11.0.15 now available.

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 4:11 am

netsvetaev wrote:
Wed Feb 12, 2020 10:39 pm
Hi!
I can’t call plugins' context menus by two-fingers’ tap on macbook trackpad/right mouse click. Menus are showing only if I press ctrl+left mouse/one-finger tap. I’ve had this bug since W9. Please, help :-D
Video: https://www.dropbox.com/s/skhp4mohi4qup ... 8.mov?dl=0
Do you have any custom Finder or window layout software installed? We've found problems with these in the past that they interfere with windows and popups...

Watchful
KVRist
252 posts since 9 Jan, 2018

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 4:46 am

dRowAudio wrote:
Fri Feb 14, 2020 4:00 am
The first MIDI note is an issue in two place:
1) If you have a plugin with latency on the track, we will be embarking on a plan to fix this in 2020
2) If you have plugins that don't like to receive an all-notes-off message in the same block as a note-on. These are bugs in the plugins and should be fixed by the plugin manufacturers
...also for connected hardware synths? Today I need to create special clips for coarse, fine, and program change commands, and overlap that onto a regular clip and the start and hope it triggers it all before the first note plays. A flyout menu....where insert bank/program change is...might be an easy way to address this.

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 5:41 am

I think so...
If you add the new MIDI monitor to a track you'll see the MIDI messages that get passed to a plugin or any external synth.

vitocorleone123
KVRist
410 posts since 30 Jun, 2014 from Pacific NW

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 9:36 am

dRowAudio wrote:
Fri Feb 14, 2020 4:00 am
The first MIDI note is an issue in two place:
1) If you have a plugin with latency on the track, we will be embarking on a plan to fix this in 2020
2) If you have plugins that don't like to receive an all-notes-off message in the same block as a note-on. These are bugs in the plugins and should be fixed by the plugin manufacturers
Great! Looking forward to it (#1). Yes, I've long been disappointed in manufacturers neglect of compatibility.

In this case, it's straight MIDI out to my OB-6 - no plugins involved - and still the first note doesn't always play (or one of the first notes). I've definitely experienced it with plugins, as well, but it's not consistent (which probably indicates #2 in your post!).

I do want to add that the sandbox is working quite well overall - W11 has only crashed on me once. The sandbox has crashed several times due to plugins. I'm installing the latest beta, and I'm hoping the strange re-positioning/lost positioning of plugins is maybe better.

dRowAudio
KVRAF
1550 posts since 30 Dec, 2012

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 10:01 am

I do want to add that the sandbox is working quite well overall - W11 has only crashed on me once. The sandbox has crashed several times due to plugins.
That's good to hear. Did restarting the sandbox via the icon get all the plugins reloaded to their original state ok?
I'm installing the latest beta, and I'm hoping the strange re-positioning/lost positioning of plugins is maybe better.
Can you elaborate on this a bit? I think I might have missed this report.

vitocorleone123
KVRist
410 posts since 30 Jun, 2014 from Pacific NW

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 12:11 pm

dRowAudio wrote:
Fri Feb 14, 2020 10:01 am
I do want to add that the sandbox is working quite well overall - W11 has only crashed on me once. The sandbox has crashed several times due to plugins.
That's good to hear. Did restarting the sandbox via the icon get all the plugins reloaded to their original state ok?
I'm installing the latest beta, and I'm hoping the strange re-positioning/lost positioning of plugins is maybe better.
Can you elaborate on this a bit? I think I might have missed this report.
Yes, restarting the sandbox restored everything. A huge improvement over the past versions (though each has been better than the last in this regard... just not the people who code some of the plugins!).

As for the 2nd item, W11 doesn't seem to remember where I'd last positioned each plugin window. I may have a plugin up in the middle of my screen and then dismiss it. Later, I open it again (if it opens - there's been issues with not being able to open plugins once dismissed), and it has actually relocated to be toward the lower-left of the screen, half off the screen and out of view, and I have to drag it back to where I want it. I'm assuming this is a side-effect of the sandbox, but I don't actually know.

robbluda
KVRer
12 posts since 25 Jun, 2014

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 12:45 pm

If a new Arpeggiator is used in the track, the notes continue to repeat endlessly after stopping playback.
Similarly for Note Repeater and Chord Companion with "ARP" or "REPEAT" option enabled.
In 11.0.15 this is still not fixed.

Kott
KVRist
148 posts since 12 Mar, 2013 from Russia, Vladivostok

Re: W11 Beta's Up!

Post Fri Feb 14, 2020 5:19 pm

Sandboxing doesn't allow to show plugin's face on Linux. They are loaded and works (sound, parameters etc) but (double) clicking on plugin shows nothing, WF 11.0.14, 11.0.15.
And Arpeggiator is still not stoppable, yeah.

FigBug
KVRist
415 posts since 3 May, 2005 from Victoria, BC

Re: W11 Beta's Up!

Post Sat Feb 15, 2020 8:15 am

robbluda wrote:
Fri Feb 14, 2020 12:45 pm
If a new Arpeggiator is used in the track, the notes continue to repeat endlessly after stopping playback.
Similarly for Note Repeater and Chord Companion with "ARP" or "REPEAT" option enabled.
In 11.0.15 this is still not fixed.
Just fixed, will be in 11.0.16

vitocorleone123
KVRist
410 posts since 30 Jun, 2014 from Pacific NW

Re: W11 Beta's Up!

Post Sun Feb 16, 2020 4:08 pm

Feature request: simpler MIDI routing.

I have 2 hardware synths on the MIDI of my 6i6v2 using Thru. There's only one output available for a given track - the 6i6v2. There's no way to designate which channel at that point. The only way to do it is in a MIDI clip (what if I don't want to add a clip?), my MIDI controller (but I'm not always generating the MIDI notes - several VSTs do it,too), or in the VST (if it supports it and it's well-behaved). In this case, with Audiomodern Riffer, the only way that seems to work is to add a MIDI patchbay and route it that way.

Ideally, I could just pick the destination of the track output AND the channel, if it's MIDI. Or at least select a track and, if the destination is MIDI, then be able to have a place to enter it, like on a MIDI clip, only without having to rely on a clip.

Return to “Tracktion”