Faderport 8 Details

Discussion about: tracktion.com
dRowAudio
KVRAF
1649 posts since 30 Dec, 2012

Post Mon Feb 10, 2020 8:14 am

There's been a couple of reports of Faderport 8 not working in Waveform.
I don't have one of these to test with so to see if it's something I can fix without a physical device, can someone let me know what doesn't actually work with it?

If you put the device in to MCU mode and use the device in the Mackie Control Universal mode, what doesn't work? (And what does work).

For the things that don't work, do you know what messages they are sending that are non-standard MCU?

That would be a big help.

User avatar
Captngeetch
KVRist
34 posts since 16 Jun, 2016

Re: Faderport 8 Details

Post Mon Feb 10, 2020 9:14 am

Waveform doesn't even see the Fajderport 8. I have tried it in all available modes. It isn't available in the input or output drop down menus. It will show it in midi mode, but it's connected via USB and isn't usable.

chico.co.uk
KVRAF
2384 posts since 17 Jun, 2003

Re: Faderport 8 Details

Post Tue Feb 11, 2020 9:29 am

Just for anyone doing future searches, Faderport 8 works, when in MCU mode, if the input and output are both enabled in Settings/Midi Inputs, then assigned to input and output of the Mackie Control Universal profile under Settings/Control Surfaces ;
Captngeetch wrote:
Tue Feb 11, 2020 4:02 am
chico.co.uk wrote:
Mon Feb 10, 2020 9:27 am
If you go into Settings / Midi Devices, does it show the Faderport input and output there?
Are both set to Enabled?

If it doesn't show there, check you don't have "Only show enabled devices" turned on.
Thanx ! You pointed me in the right direction. It was listed on the output only. Set it on the input, put the FP into MCU mode and it was available at last. Faders popped into action the second I selected it...thanx again.
"my gosh it's a friggin hardware"

GuitarPlayerinNYC
KVRist
71 posts since 23 Dec, 2019

Re: Faderport 8 Details

Post Thu Feb 13, 2020 11:49 am

FWIW, to anyone with a midi keyboard with pads/transport buttons, and sliders, it's the same- at least for the Arturia KeyLab Essential.

KeyLab has separate drivers for the controls, so select that, as the In and Out, in both Midi Devices, and in Control Surfaces in MCU. My sliders don't work in Waveform- but, I didn't attempt to map them- the pads, and the basic transport controls work.

I asked Arturia if they would write a template for Tracktion/Waveform, as they have for Ableton/FL Studios, but they essentially said they're catering to the "big boys" now.

User avatar
Captngeetch
KVRist
34 posts since 16 Jun, 2016

Re: Faderport 8 Details

Post Thu Feb 13, 2020 11:55 am

When I was using my M-Audio Oxygen 49 as a controller all the sliders and knobs worked perfectly after mapping them manually. I only use it as a midi keyboard now though

GuitarPlayerinNYC
KVRist
71 posts since 23 Dec, 2019

Re: Faderport 8 Details

Post Thu Feb 13, 2020 1:16 pm

Hmm...I could swear I read you can't map knobs and sliders. I've tried a few times, but can't get midi learn/mapping to respond to any of my sliders or knobs. Partly why I haven't dedicated a whole lot of time to mapping everything.

dRowAudio
KVRAF
1649 posts since 30 Dec, 2012

Re: Faderport 8 Details

Post Fri Feb 14, 2020 4:08 am

Not having used a Faderport, I'm a bit lost by the status of this thread now. With chico.co.uk's advice, is everything now working correctly in MCU mode?

Return to “Tracktion”