SOLVED: SynthMaster 2.9 won't show up in Studio One

Plug-in hosts and other software applications discussion
garryknight
KVRian
1155 posts since 6 Jan, 2015 from London, England

Post Thu Feb 13, 2020 7:34 am

I had to reinstall Windows 10 recently plus all of my software, including Studio One 4.6.1, and all of my plugins. I installed SynthMaster 2.9 but it doesn't show up in S1's Instruments list. Interestingly, it does show up in Reaper on the PC, and also in Studio One and Logic on my MacBook. I've also got SynthMaster One and that shows up everywhere. Plus the standalone version of SM2.9 runs fine, so I'm thinking it must be a problem with Studio One.

I tried resetting S1's blacklist and restarting, but SM2.9 still didn't appear, so I did a rescan to no effect. S1's log file doesn't show anything relevant. I've emailed KV331 Audio Support and they got back to me pretty quickly but all they've suggested so far is what I've already done: reinstalling with no DAW open, with the license file in the correct folder, and rescanning my plugins.

So now I'm wondering if anyone here has had and solved this problem, or if anyone can suggest anything else I can try.
Last edited by garryknight on Fri Feb 14, 2020 2:40 pm, edited 1 time in total.

anttimaatteri
KVRist
329 posts since 17 Nov, 2015

Re: SynthMaster 2.9 won't show up in Studio One

Post Fri Feb 14, 2020 8:34 am

i got a similar problem with ableton 10. when i got confused due to tryin out too many steps, i just restart.
means uninstalled the plugins, and reinstalled it. synthmaster is very pecular in that very process. keep both versions in its own folder, strictly!

but the most important step was indeed: i went to the daw preferences where the directions for the plugin files was set. disabled them and reenabled them straight away. this means the daw is forced to re-register all plugins inside the folders for your plugins.
thats it. i did that in ableton and in renoise and it always worked out. maybe that works in studio one too. just let it rescan the plugin folder.

garryknight
KVRian
1155 posts since 6 Jan, 2015 from London, England

Re: SynthMaster 2.9 won't show up in Studio One

Post Fri Feb 14, 2020 2:24 pm

Thanks. It was something to do with the folders. I recall that when I first installed it, shortly after reinstalling Windows, I put it into C:\Program Files\Vstplugins. Since then, every time I've tried reinstalling it, the installation dialog suggested that it should go into C:\Program Files\Vstplugins. This time, I uninstalled it and reinstalled into C:\Program Files\Vstplugins\KV331 Audio. And this time, it finally showed up in Studio One!

Of course, this doesn't explain why it didn't show up before, even though it showed up in Reaper. But I'm happy to have it back, so thanks again.

eazypop
KVRist
59 posts since 13 Jul, 2012

Re: SOLVED: SynthMaster 2.9 won't show up in Studio One

Post Sat Feb 22, 2020 11:52 pm

Hi! I have synthmaster player and it works fine BUT when adding a sound to my favourites it won't show up in my Fav list :(
I've been messaging KV331 but they're completely ignoring me (I can see they've read my messages) :S
Any suggestions or is there someone on the forum that represents KV331 that I can speak to directly?

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”