MuLab 9.0.37 App + Plugin beta

Official support for: mutools.com
humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Thu May 05, 2022 12:56 am

I really like the new look of modules with no sharp contours, easier on the eyes :tu:

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Fri May 06, 2022 7:42 am

Here is a preview of a video that explains MuLab App vs MuLab Plugin.
Comments are welcome, video still is editable at this point.
More videos coming soon.

https://youtu.be/jPdpON_7VEc

humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Fri May 06, 2022 11:48 am

The video's looking good! I don't have any advice but I'd like to report some bugs:

-click on mulab or project menu and aim at any option that has a pop up helper, like shortcuts, the drop down list disappears after pop up is shown

-the previewer rack either isn't working properly or I'm doing something wrong, I use the new synth template which gives me the basic synth, then I want to try out different presets from the browser and no matter what I do the output is only from the basic synth

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Fri May 06, 2022 1:22 pm

humanboeing wrote: Fri May 06, 2022 11:48 am The video's looking good!
Thanks.
I'd like to report some bugs:
-click on mulab or project menu and aim at any option that has a pop up helper, like shortcuts, the drop down list disappears after pop up is shown
I can't repeat this.
Which platform are you using MuLab on?
Is it using MuLab App or MuLab Plugin?
-the previewer rack either isn't working properly or I'm doing something wrong, I use the new synth template which gives me the basic synth, then I want to try out different presets from the browser and no matter what I do the output is only from the basic synth
Is it using MuLab App or MuLab Plugin?
Are you playing the preview via the on screen keyboard at the top or via MIDI?

humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Fri May 06, 2022 2:08 pm

mutools wrote: Fri May 06, 2022 1:22 pm Is it using MuLab App or MuLab Plugin?
Are you playing the preview via the on screen keyboard at the top or via MIDI?
Both issues on Mulab Plugin run in Reaper on Windows 10, I'm playing via MIDI, just checked and it plays well by using the on screen keyboard. How can I make this work with a MIDI controller?

User avatar
dakkra
KVRian
1342 posts since 4 Oct, 2012 from Utah

Post Fri May 06, 2022 3:30 pm

Resolve_075ampzt4V.png
Video is great! I didn't even think about using Mulab inside a video editor, that's awesome! Davinci Resolve Studio + Mulab Plugin makes for quite the multi-media workspace :D
You do not have the required permissions to view the files attached to this post.

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Fri May 06, 2022 9:46 pm

humanboeing wrote: Fri May 06, 2022 2:08 pm Both issues on Mulab Plugin run in Reaper on Windows 10,
Ok i can repeat issue 1 when Reaper is set to "Always On Top".
Reaper is quite aggressive in that mode, window-wise.
I'm playing via MIDI, just checked and it plays well by using the on screen keyboard. How can I make this work with a MIDI controller?
It's all related to the "Focused Module", please see
https://www.mutools.com/info/M9/docs/mu ... board.html
https://www.mutools.com/info/M9/docs/mu ... uting.html

So if you want you can reserve a certain MIDI channel for live play and set the MIDI Input Channel Targets so that this MIDI channel is mapped to Focused Module + Focused Channel.

humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Sat May 07, 2022 2:27 am

I have "always on top" set to off, the issue happens when the Mulab window is in floating mode.

From docs: "For example, when clicking a track or rack, MuLab will set the Focused Module to that track module or rack so that you can instantly play that module from your MIDI keyboard."

I understand it, that if I click on the previewer rack it becomes a focused module and should get midi input, right? If so, then it isn't working for me.

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Sun May 08, 2022 3:54 am

humanboeing wrote: Sat May 07, 2022 2:27 am I have "always on top" set to off, the issue happens when the Mulab window is in floating mode.
Ok, had another look at this issue and it will be fixed in the next update. Thx for reporting this.
From docs: "For example, when clicking a track or rack, MuLab will set the Focused Module to that track module or rack so that you can instantly play that module from your MIDI keyboard."

I understand it, that if I click on the previewer rack it becomes a focused module and should get midi input, right? If so, then it isn't working for me.
It indeed becomes the focused module but then the question is: How is your MIDI Input mapped.
In MuLab App the default MIDI Input mapping is that all incoming channels play the focused module. But in MuLab Plugin that's another context and the default MIDI Input mapping is that all incoming channels are mapped to the project MUX event input.
If you want you can reserve a certain MIDI channel to always play the focused module, as explained above. Does this clarify it?

humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Sun May 08, 2022 7:07 am

Yes, I understand it now, thanks.

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Sun May 08, 2022 8:05 pm

humanboeing wrote: Thu May 05, 2022 12:56 am I really like the new look of modules with no sharp contours, easier on the eyes :tu:
I only now realize what you mean with this. But in fact it's a little bug in M9.0.36. Those module boxes do need some contour when selected otherwise they can become too much the same as the background. M9.0.36 still intended to draw that contour but so due to a little bug the contour was not drawn. Will be fixed in M9.0.37, but the contour will be less sharp = easier on the eye than in M9.0.35.

humanboeing
KVRist
218 posts since 17 Nov, 2020

Post Sun May 08, 2022 9:42 pm

True, the selected ones blend with the background too much, but my eyes quickly adjusted, funny situation :)

User avatar
dakkra
KVRian
1342 posts since 4 Oct, 2012 from Utah

Post Mon May 09, 2022 10:41 pm

Small UI bug: when changing rack color the associated track changes color, but the subtrack only changes color when zooming instead of immediately

https://www.youtube.com/watch?v=vNn7qIg8qHA

Super small bug, looks like a missing event when setting color. Nothing that prevents work getting done

User avatar
mutools
KVRAF
Topic Starter
11634 posts since 24 Jun, 2008 from Europe

Post Tue May 10, 2022 4:49 am

dakkra wrote: Mon May 09, 2022 10:41 pm Small UI bug: when changing rack color the associated track changes color, but the subtrack only changes color when zooming instead of immediately
Super small bug, looks like a missing event when setting color. Nothing that prevents work getting done
Taken note about it, thanks for reporting this :tu:

HarmonicD
KVRist
126 posts since 18 Apr, 2021

Post Tue May 10, 2022 10:32 am

still need a quick way to drag and drop presets from the browser

Return to “MUTOOLS”