Syntronik 2 Discussions

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
SoundPorn
KVRian
1083 posts since 24 Jul, 2018

Post Sat May 07, 2022 10:52 am

Syntronik is ridiculously underrated. Like you can have a ton of fun just playing with the effects, basically MixBox, that comes built into the software.
Also speaking of MixBox, it comes free with any iRig purchase, that sounds crazy so you can basically get the full $200 software for just $40 the price of the cheapest iRig.

Anybody know if you own Syntronik and Sampletank for pc if I need a different license to use it on iPad?

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat May 07, 2022 2:25 pm

Synthient Sound wrote: Sat May 07, 2022 5:55 am @Teksonik...I have the same problem with the EQ in Amplitube. What were they thinking, haha!? I really like IKM software, but often scratch my head about some of the design decisions.
Exactly. Going all the way back to Sampletank 1 with every IK instrument I've owned I've been saying "wait...what?...why?" over things that just don't make sense. At times I've wondered if they're developed by people who don't actually use music software. :?
kitekrazy wrote: Sat May 07, 2022 10:27 am
Teksonik wrote: Fri May 06, 2022 3:51 pm
kitekrazy wrote: Fri May 06, 2022 3:31 pm So how does one remove Syntronik 1 and sounds. I need to remove bloat.
The problem is that the Syntronik 1 content is still used in S2. So if you remove those S1 sounds they won't be available in S2.
The fact that we can have S1 and 2 running on the same system leads me to believe you'll need to keep S1 installed for compatibility in older projects but someone would have to confirm that.
I don't think they are. I had Max 3.5 and there is S2 versions of each. There is no uninstaller for v1.
Here the Syntronik 1 samples are installed in the Sampletank 3 folder. The new version 2 samples go into their own folder. So if I tried to delete the S1 content it would delete the content from S2 as well.

I'd like to clear up some space as well but the way IK has installed the stuff at least on my system I'm more likely to break something. Deleting the actual Syntronik 1.dll wouldn't really free up much space so I guess I'll just live with the bloat.

Things may have installed differently on your system depending on what you installed in the past. :shrug:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sat May 07, 2022 5:11 pm

*Sigh*......

S2 crash.png

I have never seen that error message in any other plugin in all the time I've used Cakewalk.

Just trying to load a project with a single instance of S2....it's not even a layer preset.

:bang:
You do not have the required permissions to view the files attached to this post.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

kitekrazy
KVRist
276 posts since 26 Oct, 2002

Post Sat May 07, 2022 6:28 pm

Teksonik wrote: Sat May 07, 2022 5:11 pm *Sigh*......


S2 crash.png


I have never seen that error message in any other plugin in all the time I've used Cakewalk.

Just trying to load a project with a single instance of S2....it's not even a layer preset.

:bang:
Is it Bndlab or Sonar? Both VST versions load for me in Bandlab.

GusGranite
KVRist
310 posts since 18 Feb, 2019

Post Sat May 07, 2022 7:56 pm

SoundPorn wrote: Sat May 07, 2022 10:52 am Syntronik is ridiculously underrated. Like you can have a ton of fun just playing with the effects, basically MixBox, that comes built into the software.
Also speaking of MixBox, it comes free with any iRig purchase, that sounds crazy so you can basically get the full $200 software for just $40 the price of the cheapest iRig.

Anybody know if you own Syntronik and Sampletank for pc if I need a different license to use it on iPad?
Yes, different licenses.

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun May 08, 2022 5:15 am

kitekrazy wrote: Sat May 07, 2022 6:28 pm Is it Bndlab or Sonar? Both VST versions load for me in Bandlab.
It's Cakewalk by Bandlab, latest version. Syntronik will load which is how I was able to save a project with one instance as mentioned above but it just crashed while trying to reload that simple project.

Cakewalk has been rock solid here going back quite some time. Like I said I've never seen that message with any of the other plugins I own.

I've also gotten crashes in FL Studio so that would tend to indicate it's not a DAW issue but an issue with Syntronik 2. I don't remember ever having similar issues with Syntronik 1 going back several years.

It seems to be related to Multis but the crash yesterday was caused by a single layer patch although with an edited preset.

I suppose I should report it to IK support but that's such an unpleasant process and I have little faith they'll actually be able to find the cause of the crashes. :?

I'd suggest everybody try the free Syntronik CS version to check stability on your system before committing to purchase.

Anyway we're only 6 more to the next freebie making it 16 for the price of 1 so we should see that level hit by the end of the day.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

zzz00m
KVRAF
3140 posts since 17 Sep, 2016

Post Sun May 08, 2022 5:59 am

Teksonik wrote: Sat May 07, 2022 5:11 pm *Sigh*......


S2 crash.png


I have never seen that error message in any other plugin in all the time I've used Cakewalk.

Just trying to load a project with a single instance of S2....it's not even a layer preset.

:bang:
Is it every time, or intermittent?

"c0000005" is an access violation:
  • An Access Violation is a type of Exception caused when an application Reads, Writes or Executes an invalid Memory Address.

    The Exception Code is 0xC0000005
Geek stuff: https://docs.microsoft.com/en-us/shows/inside/c0000005
Windows10; AAS, AIR, Ample, Arturia, Cherry, IKM, Intermorphic, iZotope, Indiginus, Kilohearts, KORG, KV331, Melda, NI, Orange Tree, PluginGuru, PreSonus, Spitfire, Surge, Tone2, Toontrack, Tracktion, u-he, UJAM, Vital, Waves

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun May 08, 2022 6:37 am

Ok I'm starting to figure out what's going on. It appears to be a file path issue. So far with two of the Syntronik 1 instruments I've updated to version 2 there is an issue with the sample file path with edited presets.

For example if I select the preset "Moving Those Pictures" for the OX-a it loads just fine, no problem finding the samples but if I edit that patch and save a new version I get:

S2 Error 2.png

It's looking for samples in the wrong location. I reinstalled the Ox-a content but get the same results.

I tried it with the J8 as well. All I did was select a patch, rename that patch and did a save as, not editing the patch in any way and get the following error message:

S2 Error 3.png

So for some reason saved patches are looking for their samples in a different location than the original presets and for some reason the IK installers are not putting the content in that location. They are put in the Sampletank folder instead.

Of note, I don't own Sampletank 4 only ST3. On the setting page the file path to the Sampletank 3 location is added so Syntronik 2 should be able to find those samples.

I imagine that may be what's causing the crashes with saved Presets and Multis.

Maybe someone else can give it a go if you've chosen one of the legacy instruments as one of your freebies so far. It would probably help if you have the original Synthronik 1 installed to keep the testing environment consistent.

Load a preset, simply rename and save it then try to reload that patch and see if you get the above error message.
You do not have the required permissions to view the files attached to this post.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun May 08, 2022 6:53 am

Ok further testing....If I manually move the whole sample folder into the location shown in the above error message the edited patch will still not load but....if I place the missing sample outside of any folders (OXa Unison FM Filter Sweep.pak) the preset will load which is a clusterf*ck of a bug. :bang:

S2 Error 4.png
You do not have the required permissions to view the files attached to this post.
Last edited by Teksonik on Sun May 08, 2022 6:54 am, edited 1 time in total.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
LoveEnigma18
KVRAF
4863 posts since 12 Jan, 2018

Post Sun May 08, 2022 6:54 am

I remember getting this message too. IIRC, it was due to one of these: I was using a preset for which the corresponding sounds were not there or due to a need for a rescan of the contents. For the former, installing the V2 content fixed it.

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun May 08, 2022 6:56 am

I've tried that several times and the content has been re-scanned. The original preset will load but not the edited preset. The edited preset is looking for the sample content in a different location, see my post above.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
Teksonik
KVRAF
Topic Starter
17027 posts since 16 Sep, 2001 from Las Vegas,USA

Post Sun May 08, 2022 7:05 am

And now the project that was causing the crashes in Cakewalk shown in the screenshots above will load just fine by moving the individual samples so that was the cause of the crashes. The edited preset was looking for its sample in the wrong location.

The same for the J8 preset I simply renamed and saved. After moving the individual samples it uses outside of any folders in the Syntronik 2 folder it will load fine now as well.

So the problem is saved presets are looking for the samples they use in the wrong location.

I absolutely love beta testing plugins but I absolutely hate beta testing plugins I've paid for. :bang:

I'll send the report to IK support tomorrow but it's going to be a nightmare getting them to even understand the problem let alone issue a fix. :?

EDIT: This appears to occur only with Syntronik 2 presets. S1 presets can be edited and saved and they will reload just fine as they are looking for their samples in the proper location.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
LoveEnigma18
KVRAF
4863 posts since 12 Jan, 2018

Post Sun May 08, 2022 7:41 am

Teksonik wrote: Sun May 08, 2022 6:56 am I've tried that several times and the content has been re-scanned. The original preset will load but not the edited preset. The edited preset is looking for the sample content in a different location, see my post above.
Sorry, I misunderstood it then. I just tried the same patch you mentioned and saved a new one. Surprisingly, there is no issue for me. The edited patch loads perfectly fine.

I think the problem seems to be installation and/or path related.

My folder structure is pretty simple. All the IK content is in this single main folder and this path is set in all the plugins' library preferences:

ik folder.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
LoveEnigma18
KVRAF
4863 posts since 12 Jan, 2018

Post Sun May 08, 2022 9:11 am

Am I overlooking or there is no switch to bypass the entire effects chain with one click?

OllieBoi
KVRist
43 posts since 3 May, 2022

Post Sun May 08, 2022 9:53 am

Teksonik wrote: Sun May 08, 2022 7:05 am And now the project that was causing the crashes in Cakewalk shown in the screenshots above will load just fine by moving the individual samples so that was the cause of the crashes. The edited preset was looking for its sample in the wrong location.

The same for the J8 preset I simply renamed and saved. After moving the individual samples it uses outside of any folders in the Syntronik 2 folder it will load fine now as well.

So the problem is saved presets are looking for the samples they use in the wrong location.

I absolutely love beta testing plugins but I absolutely hate beta testing plugins I've paid for. :bang:

I'll send the report to IK support tomorrow but it's going to be a nightmare getting them to even understand the problem let alone issue a fix. :?

EDIT: This appears to occur only with Syntronik 2 presets. S1 presets can be edited and saved and they will reload just fine as they are looking for their samples in the proper location.
I had the same experience when editing a J-8 Syntronik 2 preset on my Mac. When I tried to reload the preset, I got a file path error message telling me that Syntronik 2 is looking for the sample set in the SampleTank 3 directory. But that's not where the sample is located.

Return to “Instruments”