Login / Register 0 items | $0.00 New @ KVR
Discussion

Discussion

Discussion: Active
Vospi
Vospi
26 January 2017 at 7:41am

I've seen bass.dll present in numerous games' folders. I'm trying to wrap my head around this VST — what's it for, how it could be useful? Is it different from an SF2/SFZ player in terms of features or structure?

Falcosoft
Falcosoft
26 January 2017 at 12:48pm

Hi, .

Do you remember Cakewalk/rgc:audio SFZ? It's something like that but tries to correct some of its issues:

1. It cannot run reliable on systems with more than 2GB of RAM.

2. It can only load 1 SF2/SFZ file at once.

3. It uses a buggy XG/GM2 addressing mode that is weird since Sondfonts are inherently more GS like.

4. It's does not follow the SF2 specification. Bassmidi library is much more reliable in this respect, ans it's still constantly evolving.

But the most important one: there is a need for it :)

https://schristiancollins.wordpress.com/2016/03/02/using-soundfonts-in-2016/.

THIS POST HAS BEEN REMOVED

Archer6621
Archer6621
12 June 2018 at 5:49pm

So I've been using this for a bit, but I'm sometimes experiencing a recurring crash when I try to load a soundfont.

I'm using Ableton Live 9, 32-bit, on Windows 10 Educational. I have an instrument track using this VSTi with a soundfont loaded into it. When I go into its control panel to load a different soundfont, the plugin and Ableton Live crash when the explorer window for selecting a soundfont appears. This problem will persist when re-opening the arrangement. In fact, I'm unable to open any sort of soundfont anymore now it seems... Even when making new instances of the plugin on different tracks, or even in entirely new arrangements.

The weird thing is, when I try to load additional soundfonts (the load buttons and fields further down below) instead of the main soundfont on the soundfont selection screen, it doesn't crash.

Any idea what it could be?

Archer6621
Archer6621
12 June 2018 at 5:54pm

Actually, now it also starts to crash using those buttons...

Archer6621
Archer6621
12 June 2018 at 6:01pm

Unable to use this plugin for anything anymore... So far this bug is ocurring on two computers, both running Windows 10.

Falcosoft
Falcosoft
15 June 2018 at 8:29pm

Hi, .

Since I cannot test with Windows 10 Educational I can only give you some tips about testing what can be the problem.

1. Try another VST host. A very simple one like SAVIHost can be useful here. If the issue also occurs with other hosts then it can be concluded that your issue is system wide, else it's most likely host related.

2. Try to disable your AV solution temporarily. Many AV software are notoriously paranoid nowadays an tend to falsely detect Bass/Bassmidi libraries as harmful.

3. If the issue started to appeared at the same time when Windows 10 upgraded itself to a new version/ installed a bigger update, try to restore your Windows 10 a previous system state.

Report back, and based on your results I may able to find some workarounds.

Archer6621
Archer6621
15 June 2018 at 8:41pm

Hi, thanks for your response.

I also had this happen on another system (my main system, the other one with Educational is a laptop) running Windows 10 Professional. As far as I know, Windows 10 Educational's feature set is nearly identical, so I don't think it is related to that.

It's also unlikely to be related to the anti-virus, as I have none on the laptop (though I have AVG on my desktop), in both cases the issue occurred.

Never really upgraded Windows between when I started using the plugin and now, so that can be ruled out as well.

It could possibly be the VST host, but the problem is that it happens pretty much at random, but when it occurs once, it will keep happening indefinitely. I haven't checked whether a system reboot fixes it, but I can also try some other VST hosts to see whether they remain stable over time.

I'll let you know.

Archer6621
Archer6621
15 June 2018 at 8:48pm

So one identical thing I had when the crashes happened, was that the soundfonts were located on an external harddrive which can be quite slow at times (in fact, on the same drive, as I moved it to my laptop). Could this be related?

Right now the plugin seems to work on my main rig again, but it's a different version of the plugin (64-bit one), and the soundfont I load is on my SSD. I'll try adding some more soundfonts to see what will happen.

Falcosoft
Falcosoft
15 June 2018 at 9:18pm

I understood. But unfortunately I cannot reproduce the problem on Windows 10 Professional either with the 32 or 64-bit version of the plugin. You can also try drag&drop the affected soundfont file to the plugin's interface instead of opening it by the file select dialog. This way you can figure out if the problem mysteriously related to the file select dialog or actually the reading/interpreting process of the soundfont file by the plugin's engine. Also it would be good to know if only special soundfont files are affected or all of them. If only special ones please try to upload them somewhere so I could inspect them.

Falcosoft
Falcosoft
15 June 2018 at 9:33pm

Also as a useful info: there's a memory size limitation of the 32-bit plugin version. Namely you cannot load reliably soundfonts if the overall used sample sizes are equal/bigger than 2GB. Actually some stability problems can happen even close to this absolute 2GB limit. This problem manifests itself sooner if you also enable the 'Preload Soundfonts' or 'Map Soundfonts into Memory' options.

Archer6621
Archer6621
17 June 2018 at 9:38am

Good one, forgot about the drag and drop feature. I'll try to use this on the problematic device tomorrow, when I move back to it. There I have the case that it always crashes, 32-bit version indeed, and I may have happened to tick those boxes that you mentioned due to hickups when reading from the external drive.

I will let you know.

Archer6621
Archer6621
18 June 2018 at 10:30pm

So it seems that it no longer crashes now, after not having used the laptop for a while. I'll have to wait until the issue occurs again before I can trace it down properly.

THIS POST HAS BEEN REMOVED

vekdigital
vekdigital
19 August 2018 at 7:51am

I have tried, to no avail, to natively save the plugin state (settings) so that I don't have to set it up with my chosen defaults every time I use it in a project. Apparently the plugin isn't capable of this on its own and requires outside assistance (via the plugin host). Is this correct? Or am I missing something.

BTW, thanks a ton for making this plugin. Aside from the above noted issue, it works flawlessly in my DAW (REAPER) on my Windows 7 Pro system. I recently resurrected my 20 year old MIDI system (AMD K6II+/500MHz, 128MB RAM, Win98se) which has a (STILL WORKING) 16-bit ISA Sound Blaster AWE 64 Gold (4MB SoundFont memory onboard) with an 8MB daughter board. Yay me.

Your Bassmidi VSTi allows me to similarly "resurrect" my old SoundFont-based MIDI files on my new production system with REAPER and really add new life to them. So a million thanks for your ingenuity and gracious efforts.

Please log in to join the discussion

BassMidi VSTi

Average user rating of 5.00 from 2 reviews

Falcosoft
 My KVR - Version Control & Lists
Not In Your MY KVR Groups
(or group limitation prevents versioning)
5 people have added BassMidi VSTi to 4 My KVR groups 7 times

KVR Rank (Based on page views)

Overall: 219  219

30-Day: 327; 7-Day: 599; Yesterday: 1252

Advertisements