Login / Register 0 items | $0.00 New @ KVR
User avatar
zvenx
KVRAF
 
6539 posts since 16 Feb, 2005, from Kingston, Jamaica
kv331 wrote:
zvenx wrote:That explains why some seem fixed.
those that were fixed are in the factory banks, those that aren't are expansions.
thanks
rsp


We're gonna update the expansions as well. Gercek has been working on that.


Fantastic,
Thanks
rsp
User avatar
freecham
KVRer
 
26 posts since 2 Jan, 2016, from France

Postby freecham; Wed Jan 10, 2018 6:09 am Re: SynthMaster and SynthMaster Player updated to v2.9.6

Hi Bulent, i'm triying to extract the archive of the new version 2.9.6 but i've got an CRC error. I've tried to download several times but always the same error... The installation is not possible.

Thanks
kv331
KVRAF
 
5421 posts since 14 Nov, 2006, from Ankara, Turkey
freecham wrote:Hi Bulent, i'm triying to extract the archive of the new version 2.9.6 but i've got an CRC error. I've tried to download several times but always the same error... The installation is not possible.



Hi

I tested all of the uploaded files on the server, no unzip errors on my end. Try to download the file again.
Works at KV331 Audio
SynthMaster voted "Best VST/AU Synth of 2016" by MusicRadar readers
SynthMaster One voted "Best New Virtual Instrument of 2017" by MusicRadar readers
User avatar
freecham
KVRer
 
26 posts since 2 Jan, 2016, from France

Postby freecham; Wed Jan 10, 2018 6:41 am Re: SynthMaster and SynthMaster Player updated to v2.9.6

kv331 wrote:
freecham wrote:Hi Bulent, i'm triying to extract the archive of the new version 2.9.6 but i've got an CRC error. I've tried to download several times but always the same error... The installation is not possible.



Hi

I tested all of the uploaded files on the server, no unzip errors on my end. Try to download the file again.


Yes i tried several times but always the crc error (unzip with to 7-Zip, Bandizip). Did you tried to dowload the file and unzip it ?
User avatar
zvenx
KVRAF
 
6539 posts since 16 Feb, 2005, from Kingston, Jamaica
I only download the full install.
On Both mac and pc and had no issues.

@Bulent, a minor issue,
The bank Synthmaster Club Sequences Volume 1

is listed incorrectly in your purchased items browser (Sythmaster Club Sequences Volume 1) so when you click to download it, it does download and install but never changes from Download to Install, although it does appear in the installed preset folders spelled correctly.

https://www.dropbox.com/s/e6hv0jp8yggg0 ... d.png?dl=0

https://www.dropbox.com/s/i12v36isvm7u5 ... d.png?dl=0

thanks
rsp
Enkerli
KVRist
 
79 posts since 31 Jan, 2017

Postby Enkerli; Wed Jan 10, 2018 12:22 pm Re: SynthMaster and SynthMaster Player updated to v2.9.6

kv331 wrote:We finally released SynthMaster v2.9.6 and also SynthMaster Player v2.9.6.

Yay!

kv331 wrote:1. FIX: SynthMaster might crash when warning messages are generated after loading a preset
2. FIX: SynthMaster crashes when a wavetable with more than 256 waveforms is imported
3. FIX: When user drags and drops a modulation source from the modulation sources tab, SynthMaster might crash
4. FIX: When a preset is initialized, drag and drop of a modulation source from the modulation sources tab results in an empty modulation matrix entry
5. FIX: SynthMaster might crash when the mod matrix source filter is changed.
6. FIX: Modulation of amount parameter of LoFi effect causes zipper noise
7. FIX: Modulation of amount parameter of Distortion effect causes zipper noise
8. FIX: Modulation of amount parameter of Echo effect causes zipper noise
9. FIX: Modulation of amount parameter of Chorus effect causes zipper noise
10.FIX: When a new modulation matrix entry is created, SynthMaster incorrectly creates an additional entry
11.FIX: Modulation tab header requires two clicks to display modulation sources menu for a different category
12.FIX: When the oscillator algorithm is changed from sample playback to wavetable, the oscillator doesn't play the wavetable correctly
13.FIX: Some text labels are clipped when being displayed
14.FIX: SynthMaster fails to read some factory waveforms/wavetables when the operating system doesn't return files and folders in sorted order (MacOS High Sierra)
14.FIX: Edited factory presets
15.FIX: Edited factory skins


Had noticed several of these, especially those related to modulation or wavetables. Number 14, combined with number 1, produced the most glaring issue.

Still got issues with getting MIDI Learn to show up in the modulation matrix or to have an effect. But it sounds like some of the weirdness may have disappeared?

Wonder if there’s a way to “hack” a .smpr file so that it produces the right modulation.
(Trying to use CC#74 from a ROLI Lightpad Block to modulate the wave index. But the same or similar modulation issues happen with other plugin parameters and other controllers.)

Still, further troubleshooting should probably wait until after NAMM. SM1 for iOS can make a bit of a splash as some of us want more diverse MPE-enabled synths. Hope it can be AUv3, as it’s become a kind of requirement on that platform.
GreyLion
KVRAF
 
2934 posts since 21 May, 2004, from Deep in the Heart of Texas

Postby GreyLion; Wed Jan 10, 2018 11:39 pm Re: SynthMaster and SynthMaster Player updated to v2.9.6

freecham wrote:
kv331 wrote:
freecham wrote:Hi Bulent, i'm triying to extract the archive of the new version 2.9.6 but i've got an CRC error. I've tried to download several times but always the same error... The installation is not possible.



Hi

I tested all of the uploaded files on the server, no unzip errors on my end. Try to download the file again.


Yes i tried several times but always the crc error (unzip with to 7-Zip, Bandizip). Did you tried to dowload the file and unzip it ?


It's almost a relief to see that you're having this issue, freecham, as you're the first one I've seen here who does. :P

I've had the same problem for some time, but I also have the same issue with downloads from several other vendors. In my case, I'm about 90% sure that it's the combination of having AT&T as my ISP and the vendor distributing their software from AWS servers. I haven't found a fix for this, other than to connect up to the network at a local coffee shop and do the downloads there. Is this maybe your combination?
User avatar
freecham
KVRer
 
26 posts since 2 Jan, 2016, from France

Postby freecham; Thu Jan 11, 2018 12:18 am Re: SynthMaster and SynthMaster Player updated to v2.9.6

GreyLion wrote:
freecham wrote:
kv331 wrote:
freecham wrote:Hi Bulent, i'm triying to extract the archive of the new version 2.9.6 but i've got an CRC error. I've tried to download several times but always the same error... The installation is not possible.



Hi

I tested all of the uploaded files on the server, no unzip errors on my end. Try to download the file again.


Yes i tried several times but always the crc error (unzip with to 7-Zip, Bandizip). Did you tried to dowload the file and unzip it ?


It's almost a relief to see that you're having this issue, freecham, as you're the first one I've seen here who does. :P

I've had the same problem for some time, but I also have the same issue with downloads from several other vendors. In my case, I'm about 90% sure that it's the combination of having AT&T as my ISP and the vendor distributing their software from AWS servers. I haven't found a fix for this, other than to connect up to the network at a local coffee shop and do the downloads there. Is this maybe your combination?


I don't have AT&T but maybe, it's the same trouble. I've tried to download with my phone but the error is still there. Finally, i'v downloaded only the update 2.9.6 and it's ok. But no full install file...

Edit : GreyLion, you're right, when i use a proxy for download, the full setup is ok. Really strange
kv331
KVRAF
 
5421 posts since 14 Nov, 2006, from Ankara, Turkey
freecham wrote:I don't have AT&T but maybe, it's the same trouble. I've tried to download with my phone but the error is still there. Finally, i'v downloaded only the update 2.9.6 and it's ok. But no full install file...

Edit : GreyLion, you're right, when i use a proxy for download, the full setup is ok. Really strange


We have been using Stackpack as our CDN provider. It could be something related to that.

Also, even if your connection to our server is https (that's used for authentication), the file is downloaded via http from the CDN. Maybe that's causing an issue, I don't know.
Works at KV331 Audio
SynthMaster voted "Best VST/AU Synth of 2016" by MusicRadar readers
SynthMaster One voted "Best New Virtual Instrument of 2017" by MusicRadar readers
User avatar
braj
KVRAF
 
9090 posts since 4 Feb, 2004
The skins red-lines issue still isn't fixed :( and I forgot to back up my edited skins, at least it only takes a few minutes to fix.

Edit: I DID have a backup! But using it caused SM to crash.
If you have requests for Korg VST features or changes, they are listening at https://support.korguser.net/hc/en-us/requests/new
User avatar
zvenx
KVRAF
 
6539 posts since 16 Feb, 2005, from Kingston, Jamaica
Yeah I was hoping
5.FIX: Edited factory skins
was about or included that.. alas no.

rsp
robbluda
KVRer
 
10 posts since 25 Jun, 2014

Postby robbluda; Fri Jan 12, 2018 4:54 am Re: SynthMaster and SynthMaster Player updated to v2.9.6

Hi, I've identified errors in the GUI.

If the Oscillator is Additive type then
Wave7 and Wave8 Algorithm incorrectly displayed.
The issue is in Layer1/Osc1, Layer2/Osc1, and Layer2/Osc2, all factory skins.
kv331
KVRAF
 
5421 posts since 14 Nov, 2006, from Ankara, Turkey
braj wrote:The skins red-lines issue still isn't fixed :( and I forgot to back up my edited skins, at least it only takes a few minutes to fix.

Edit: I DID have a backup! But using it caused SM to crash.


I converted all red colors to transparent as you suggested.

I would suggest deleting the data folder folder and then do a full clean install.
Works at KV331 Audio
SynthMaster voted "Best VST/AU Synth of 2016" by MusicRadar readers
SynthMaster One voted "Best New Virtual Instrument of 2017" by MusicRadar readers
User avatar
zvenx
KVRAF
 
6539 posts since 16 Feb, 2005, from Kingston, Jamaica
........... please do a CLEAN install (delete /library/application support/kv331 audio/synthmaster .........


and on PC I uninstall almost all the folders and files in the vst folder which was my default data folder.



that folder or another one.....I did delete that one and did a full install to ensure all factory presets were indeed fixed (they were, thanks again),
but I still have the red lines too.
rsp
User avatar
braj
KVRAF
 
9090 posts since 4 Feb, 2004
I did, it overwrite my edited skin the first time, bringing back the red lines, I was using the blue skin version. I'll try testing it later today and see if anything was fixed, but again, at least for the blender one, it wasn't.
If you have requests for Korg VST features or changes, they are listening at https://support.korguser.net/hc/en-us/requests/new
PreviousNext

Moderator: KVR Moderators (Main)

Return to Instruments