Login / Register 0 items | $0.00 New @ KVR
EJRAudio
KVRer
 
4 posts since 8 Sep, 2017

Postby EJRAudio; Fri Sep 22, 2017 3:39 pm Re: Plugin Boutique's Carbon Electra

Two weeks later I haven't heard back from squigls regarding their "issue".

No one involved in this project has been able to reproduce such an issue on any of the systems, OSes, hosts and configurations available to us. Being able to reproduce an issue is needed in the process of identifying the cause before a solution can be found.

There are two possible ways in which the plug-in could act in such a way:
  1. If the host loads the project then instructs the plug-in to switch to another preset (obviously the plug-in would obey)
  2. If the serial key is invalid and the copy protection does not operate correctly (it would operate in demo mode)

Unfortunately I have requested that sqigls provide me with a copy of their user bank file to diagnose this issue but this was met with a flat refusal and I haven't heard back from them since a few hours after my last post.

We had a similar communication via the support channel near the beginning of this year with the same outcome: the user refused to follow instructions and wasn't heard from again.

If anyone ever were to run in to a similar problem or any other problem with this plug-in; please contact either Plugin Boutique support directly (they handle a wide variety of products) or you can contact myself (the author of the main parts of the plug-in) via this account.
ttamelbon
KVRer
 
3 posts since 30 Aug, 2015

Postby ttamelbon; Thu Jan 11, 2018 5:23 am Re: Plugin Boutique's Carbon Electra

Hi EJRAudio,

I also experience the same issue with Carbon Electra and would be happy to give you whatever help you need to figure out the issue. Please let me know what you need and how I can transfer it to you, and I'd be happy to do it. I quite like the synth, but the number of patches I've created and lost makes me shy away from it in a project.

Cheers,

Matt
User avatar
sqigls
KVRAF
 
2954 posts since 24 Dec, 2004, from Melbourne, Australia

Postby sqigls; Thu Jan 11, 2018 6:52 am Re: Plugin Boutique's Carbon Electra

EJRAudio wrote:Two weeks later I haven't heard back from squigls regarding their "issue".
...
Unfortunately I have requested that sqigls provide me with a copy of their user bank file to diagnose this issue but this was met with a flat refusal and I haven't heard back from them since a few hours after my last post.


yeah, KVR a user contacts me, with 0 posts at KVR, requests me to send them one of my system files (admittedly at first i thought was a keyfile and a scammer, but was simply a user bank), sorry if my refusal was a tad blunt, but dude, searching your email address led me to a few random weird websites and not to anything related to Carbon Electra. So alarm bells were ringing. After that, coupled with the fact that apparently mouse wheel support is gonna take weeks to implement and probably never going to happen, I sold my license. I'll buy it again when mouse wheel support is added. I can't use plugins without mouse-wheel support anymore. I don't care how good they are.
EJRAudio
KVRer
 
4 posts since 8 Sep, 2017

Postby EJRAudio; Thu Jan 11, 2018 7:27 am Re: Plugin Boutique's Carbon Electra

Technically the mouse-wheel works fine in the existing version. There is a disablemousewheel executed on startup if the plug-in is running on MacOS. That is because the typical Apple mouse configured with default settings has the threshold too low and will slightly nudge knobs when you move the mouse and the palm of your hand activates the wheel feature.

That was added by request by users of Apple mice. In retrospect I wish I hadn't so easily accepted this and I should have fought against it. Unfortunately it is now too late to "fix" such things by adding a lot of code that should have been implemented before the product was originally released. These are details that ought to be handled in the design phase and in this case the design specified that mousewheel would be disabled on MacOS.
ttamelbon
KVRer
 
3 posts since 30 Aug, 2015

Postby ttamelbon; Fri Jan 12, 2018 6:06 am Re: Plugin Boutique's Carbon Electra

I just wanted to post that EJRAudio contacted me very quickly after I posted here and, with a few emails back and forth, was able to send me a new exe which seems to have completely cleared up my saving issue with Carbon Electra. He was a class act all the way. Too often we hear about the complaints but not enough praise when somebody comes through and solves a problem.

Anyway, thanks for everything and keep doing what you do!

Matt
User avatar
exmatproton
KVRAF
 
2017 posts since 24 Apr, 2011

Postby exmatproton; Fri Jan 12, 2018 6:45 am Re: Plugin Boutique's Carbon Electra

so...is it fixed?
EJRAudio
KVRer
 
4 posts since 8 Sep, 2017

Postby EJRAudio; Fri Jan 12, 2018 9:07 am Re: Plugin Boutique's Carbon Electra

Anyone with this issue should contact me directly via PM until such time as the fix is complete, confirmed and the version distributed by Plugin Boutique has been updated.

It seems some hosts send a set preset instruction to the plug-in immediately after loading the project. This causes the plug-in to follow the instruction and load a preset from the bank which overwrites the current preset which had been loaded along with the project.

The only solution to this problem is to ignore the set preset command from the host. I've been able to apply this to the plug-in on Windows and you can contact me for this beta/fix version as a temporary solution if you experience the problem.
Previous

Moderator: Moderators (Main)

Return to Instruments