Login / Register  0 items | $0.00 New#KVRDeals
User avatar
Naenyn
KVRian
 
818 posts since 26 Sep, 2013, from Arizona, USA

Postby Naenyn; Sat Jun 21, 2014 10:06 pm SplineEQ v1.1; 64-bit AU?

For some reason, v1.1 isn't showing up in Logic Pro X. Any idea why? For the previous version, there were separate 32-bit and 64-bit plugins.. but this version seems to have just one (32-bit?). Should there be two versions?

Thanks for the help!
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 1:03 am Re: SplineEQ v1.1; 64-bit AU?

Just bought this - I too thought there was a 64 bit AU but it hasn't installed one
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 1:58 am Re: SplineEQ v1.1; 64-bit AU?

They were supposed to be 32/64 bit builds but for some reason the 64 bit part isn't working at all. I'm investigating.
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 2:21 am Re: SplineEQ v1.1; 64-bit AU?

OK looks like the problem has to do with using an old version of the framework that does all the AU/VST stuff. So I'll just upgrade and that should do the trick.
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
User avatar
Tp3
KVRAF
 
2025 posts since 7 Feb, 2007

Postby Tp3; Sun Jun 22, 2014 3:02 am Re: SplineEQ v1.1; 64-bit AU?

are we supposed to receive an update e-mail ?

cheers
What is best ? How do you define 'best'? If you're talking about what you can think, what you can feel, what you can listen and hear, then 'best' is simply marketing signals (ie. hype) interpreted by your brain.
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 3:30 am Re: SplineEQ v1.1; 64-bit AU?

Can anyone test this and see if it works on 64-bit Mac? It should work, thanks.

http://photosounder.com/splineeq/splineeq_mac_64.zip
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 3:53 am Re: SplineEQ v1.1; 64-bit AU?

Tp3 wrote:are we supposed to receive an update e-mail ?

cheers

I'll send a newsletter, otherwise no, you just download it with your download link, and if you don't have it anymore just enter your e-mail address in the form in the download page on the site.
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 4:04 am Re: SplineEQ v1.1; 64-bit AU?

A_SN wrote:Can anyone test this and see if it works on 64-bit Mac? It should work, thanks.

http://photosounder.com/splineeq/splineeq_mac_64.zip


Yes it's loading in 64 and 32 bit hosts now - thanks

Interface resize doesn't seem to do anything though
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 4:17 am Re: SplineEQ v1.1; 64-bit AU?

aMUSEd wrote:
A_SN wrote:Can anyone test this and see if it works on 64-bit Mac? It should work, thanks.

http://photosounder.com/splineeq/splineeq_mac_64.zip


Yes it's loading in 64 and 32 bit hosts now - thanks

Interface resize doesn't seem to do anything though

Awesome! I've just updated everything with the new builds so it should work for everyone now.

And you have to close down the instance of SplineEQ entirely (not just the interface) and then open it again.
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 6:24 am Re: SplineEQ v1.1; 64-bit AU?

A_SN wrote:And you have to close down the instance of SplineEQ entirely (not just the interface) and then open it again.


I know - doesn't work - just stays stuck on the middle setting.
Last edited by aMUSEd on Sun Jun 22, 2014 6:36 am, edited 5 times in total.
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 6:27 am Re: SplineEQ v1.1; 64-bit AU?

aMUSEd wrote:
A_SN wrote:And you have to close down the instance of SplineEQ entirely (not just the interface) and then open it again.


I know - doesn't work - just stays stuck on the middle setting.

That's weird, does it remember your other settings like the visualisation settings?
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 6:29 am Re: SplineEQ v1.1; 64-bit AU?

A_SN wrote:
aMUSEd wrote:
A_SN wrote:And you have to close down the instance of SplineEQ entirely (not just the interface) and then open it again.


I know - doesn't work - just stays stuck on the middle setting.

That's weird, does it remember your other settings like the visualisation settings?


Nope
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 7:37 am Re: SplineEQ v1.1; 64-bit AU?

Also is there any way to get rid of the latency? It's quite noticeable.
A_SN
KVRian
 
926 posts since 6 May, 2008, from Poland

Postby A_SN; Sun Jun 22, 2014 7:39 am Re: SplineEQ v1.1; 64-bit AU?

aMUSEd wrote:
A_SN wrote:
aMUSEd wrote:
A_SN wrote:And you have to close down the instance of SplineEQ entirely (not just the interface) and then open it again.


I know - doesn't work - just stays stuck on the middle setting.

That's weird, does it remember your other settings like the visualisation settings?


Nope

Oops, I guess I had only fixed the Mac preference saving in Spiral and not SplineEQ. Anyway I've fixed it and updated the whole thing, you should try it again.

As for the latency you can turn the Delay knob all the way down (maybe I should make this the default actually..) which should help. Also increasing the resolution increases the latency. Otherwise remember that it's a linear phase EQ.
Developer of Photosounder (a spectral editor/synth), SplineEQ and Spiral
User avatar
aMUSEd
KVRAF
 
28153 posts since 14 Sep, 2002, from In teh net

Postby aMUSEd; Sun Jun 22, 2014 7:53 am Re: SplineEQ v1.1; 64-bit AU?

OK great - working now. Thanks. It looks awesome in widescreen mode. Could you please make it save the path to presets too though, it keeps defaulting to the desktop which is the last place I would keep them.

I can get latency down to 7ms which isn't bad, maybe it would be useful to have a minimum phase mode for tracking?
Next

Moderator: A_SN

Return to Photosounder