What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  
KVRist
 
69 posts since 10 Jan, 2012, from Chicago Ill

Postby dathyr1; Mon Nov 12, 2012 12:18 pm Still having the problem playing with the Sustain pedal using Synthmaster.

Hello,

I sent you a message though the contact page also on this problem. This problem has existed if past versions also and is still there is your latest version.

I am using latest update of Synthmaster and with two different DAW's. They are Mixcraft 6.0 and Ableton 8. I am using the 32 bit version of Synthmaster on my Windows 7 system. Mixcraft only excepts 32 bit plugins at this time is why I am using 32 bit.

Problem:

Using the sustain pedal, playing the same note multiple times with sustain pedal down, first time note played I get the sound, any other strikes of that same note, does not play any subsequent sounds.

It is as the notes get stuck after the first occurance of hitting that note.
It does this on all the patches I have tried. It only does this with the sustain pedal down or on. Synthmaster works fine without using the sustain pedal.

This problem has been present in all the past versions since I have bought the product.

No complaints, just an observation of what I am seeing as I am doing live playing on my keyboard.

Surpised there arent more people seeing this. I just posted this on Acousticas(mixcraft DAW) forum yesterday and another person said he is seeing the same thing.

Besides this, all other features work great for me and sounds.

take care,

Dave
KVRAF
 
4877 posts since 14 Nov, 2006, from Ankara, Turkey
   

Postby kv331; Mon Nov 12, 2012 1:58 pm

I remember fixing a sustain pedal issue in one of the recent versions.

If you could send me a MIDI file that demonstrates the problem, that'd really really speed up my fix time!

Thanks,

Bulent
KVRist
 
69 posts since 10 Jan, 2012, from Chicago Ill

Postby dathyr1; Mon Nov 12, 2012 3:03 pm

Hi Bulent,

thanks for your quick reply.

This is going to be a very simple midi file.

1. All I have to do is hold down the sustain pedal. Keep it held down through steps 2-4 below. Select any patch.

2. press just one key on my keyboard- this first key produces a sound of the patch.

3. press same key on the keyboard again-the 2nd keypress does not produce a new sound.

4. continue to press same key on keyboard, still does not produce a new sound.

Note: Steps 3-4: I now either continue to hear the sound only from the first key(step2) that was pressed, or no sound at all, depending on the type of patch selected. It is like the first key pressed gets stuck preventing new keystrokes to sound when sustain pedal is held down.

Once the sustain pedal is released, Synthmaster works normally.

I dont know what DAW you use for your testing, but for some reason Synthmaster does not work the same for all DAW's. If you could download a trial version of Acoustica Mixcraft 6.0, you will see what is happening above.

Is there any difference between the 32 bit and 64 bit versions?

Just throwing out ideas. Am I missing a setting somewhere, dont knnow.

I will send you the midi file later tonight, but I feel this will probably work fine on your DAW. Weird isnt it, something so simple.

take care,

Dave
KVRist
 
69 posts since 10 Jan, 2012, from Chicago Ill

Postby dathyr1; Mon Nov 12, 2012 5:07 pm

Hi Bulent,

Sustain test Midi file has been just emailed to you.

Let me know that you have received it.

take care,

Dave
ukm
KVRist
 
64 posts since 28 Sep, 2002, from Germany

Postby ukm; Tue Nov 27, 2012 12:36 pm

This is a major problem. Did you get an answer from the developer?
KVRist
 
69 posts since 10 Jan, 2012, from Chicago Ill

Postby dathyr1; Tue Nov 27, 2012 6:17 pm

Hi Ukm,

Yes, If your a live player like I am, playing with the sustain pedal having stuck notes can be distracting with using the Synthmaster VST.

I sent Bulent another MIDI file a couple weeks ago showing him the problem and he now sees what I am talking about and what the problem is with the sustain pedal. He said he was going to have a fix for it, but havent heard from him since then.

There will probably be another fix release but dont know when. He may be working on other problems to add to it.

Thats about all I know right now. I will send him another email to find out when the fix may be implemented

Bulent may be monitoring this KV331 forum and he may respond also and let us know when the sustain fix will be implemented.

take care,

Dave
KVRAF
 
4877 posts since 14 Nov, 2006, from Ankara, Turkey
   

Postby kv331; Wed Nov 28, 2012 4:32 am

Guys, I am working on current SM issues, and this is in my todo list.

The problem with the hold pedal implementation is, if you press the same note more than once when hold is pressed, the note doesnt retrigger. Will fix that this week.

Should have a new update hopefuly this weekend!

Thanks,

Bulent
KVRist
 
69 posts since 10 Jan, 2012, from Chicago Ill

Postby dathyr1; Wed Nov 28, 2012 5:58 am

Hi Bulent,

Thank you for your update. I figured you were also working on other fixes or enhancements.

take care,

Dave :)
ukm
KVRist
 
64 posts since 28 Sep, 2002, from Germany

Postby ukm; Wed Nov 28, 2012 8:36 am

Hi Bulent and dathyr1;

thanks for quick reply. Nice to hear that the problem will be solved.
KVRAF
 
4877 posts since 14 Nov, 2006, from Ankara, Turkey
   

Postby kv331; Thu Nov 29, 2012 7:25 am

dathyr1 wrote:Hi Bulent,

Thank you for your update. I figured you were also working on other fixes or enhancements.

take care,

Dave :)


Hi again Dave,

Just managed to fix this longstanding bug!

Now I have other fixes to complete as well! I will be releasing updates constantly as I continue fixing bugs, and will let you know tonight (my time :p)

BTW, I have to fix the issues on CM/BE versions as well as I separated the codebase for them.

Cheers,

Bulent

Moderators: Teoman, kv331

Return to KV331 Audio