What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

RMV ECS Popup Doesn't Pop Up

Official support for: linplug.com

Moderator: Peter from LinPlug

KVRist
 
131 posts since 31 Oct, 2009

Postby kmmcdonald; Sun Jan 13, 2013 5:09 pm

I cannot access the ECS popup. When I press the ECS indicator at the upper left (after which it turns red), no popup occurs. What am I doing wrong?

Also, are the CC destinations restricted only to those modulator destinations listed in the manual, or can ANY parameter be controlled via MIDI CC?

thanks

Keith
Keith
Glendale, AZ USA
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Wed Jan 16, 2013 12:29 am

Hi Keith,
you need to click the ECS label above the indicator light; clicking the indicator light is a shortcut to just turn it on/off, for more options click the label.
KVRist
 
131 posts since 31 Oct, 2009

Postby kmmcdonald; Sun Jan 20, 2013 8:21 am

Thanks; I need more help, however. I can't get ECS to work.

First, I enable ECS "learn" mode (pulldown: select "learn). Then, on RMV, I move the parameter that I want to control (in this case, the volume for the loop 1 player in the mixer panel) while at the same time sending MIDI CC70 messages from my controller to RMV. Then, I turn ECS off (pulldown: select "off"). Then mixer volume for loop 1 does not respond to MIDI CC70 messages.

I know that RMV is receiving MIDI from my controller, because I am able to play the loop slices from my keyboard controller.

What am I doing wrong?

thanks again

Keith
Keith
Glendale, AZ USA
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Fri Feb 08, 2013 11:27 pm

That RMV is receiving Notes does not mean it receives MIDI CC (controller messages), some hosts apply some filtering, while having ECS on you can see the parameter responding to the MIDI CC immediately when its received. If in your case the Volume control doesnt react it only means the MIDI CC did not make it to the RMV. Sorry for the delay in responding.
KVRer
 
14 posts since 5 Dec, 2010

Postby solareus; Tue Feb 19, 2013 8:08 am

It doesn't work, some reason the RMV is not letting Ableton take control of it's parameters. Nothing works.


150dollars in usa is a lot for poor folk like me of money and I'm kind of frustrated at the whole thing.
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Tue Feb 19, 2013 9:12 am

Its not Ableton, ECS works in any host which lets the MIDI CC to the plugin, it might be you need to adjust your settings in Live so that RMV gets the MIDI CC, if it reaches the plugin, the MIDI learn work...
KVRer
 
14 posts since 5 Dec, 2010

Postby solareus; Tue Feb 19, 2013 10:18 am

Live allows me to configure any vsti though the wrench icon, every vsti works this way except RMV.

Image
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Tue Feb 19, 2013 10:13 pm

Yes, because thats _not_ a ***MIDI CC*** ,this is the ***Parameter*** automation which RMV does not offer as it has more parameters as almost every host can handle.
KVRist
 
131 posts since 31 Oct, 2009

Postby kmmcdonald; Sat Jun 22, 2013 6:58 pm

After working on this on and off, I can still not get it to work. As far as I can tell, Sonar does not have a MIDI filter option for VST's. I do not have this kind of problem assigning controllers for other VST's. Do you have access to Sonar so you might verify my problem (or lack thereof) and tell me what I'm doing wrong?
Keith
Glendale, AZ USA
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Mon Jun 24, 2013 6:41 am

I tried in Sonar X2 and it works right away; I cannot say what you are doing wrong, all I did was:
- loading RMV
- making sure my keyboard is connected correctly so RMV gets its MIDI events and
- switched on ECS

Now, when I touch a parameter and change a hardware control (thus creating a MIDI CC, RMV responds as expected.

No secrets really, so I've no idea what might go wrong at your end.
KVRist
 
131 posts since 31 Oct, 2009

Postby kmmcdonald; Mon Jun 24, 2013 10:39 am

Peter, thanks for the quick reply; I think that I have finally discovered the problem.

I typically use Sonar drum maps for MIDI tracks which drive RMV. The track MIDI output is mapped to the drum map which, in turn, consists of map entgries assigned to drive RMV. If I do not use drum maps, and instead map the MIDI out of the MIDI track directly to RMV, controller assignment works as expected.

Drum maps evidently do not pass controller data, which I believe makes sense, since each entry in the drum map could be theoretically mapped to different instruments.

I need to try to create a separate MIDI control track and map that directly to RMV to see if that works concurrently with the MIDI track that contains the notes and drum map.

Keith
Keith
Glendale, AZ USA
User avatar
KVRian
 
1157 posts since 24 Oct, 2000
 

Postby Peter from LinPlug; Mon Jun 24, 2013 9:47 pm

Thank you for the info Keith, I wasnt aware of drum maps filtering the MIDI CC, some useful info :tu:

Moderator: Peter from LinPlug

Return to LinPlug