What is KVR Audio? | Submit News | Advertise | Developer Account

Options (Affects News & Product results only):

OS:
Format:
Include:
Quick Search KVR

"Quick Search" KVR Audio's Product Database, News Items, Developer Listings, Forum Topics and videos here. For advanced Product Database searching please use the full product search. For the forum you can use the phpBB forum search.

To utilize the power of Google you can use the integrated Google Site Search.

Products 0

Developers 0

News 0

Forum 0

Videos 0

Search  

BR: T4 Midi timing offset issue

Discussion about: tracktion.com

Moderators: valley, jules, TSC, ModuLR

bk
KVRian
 
1426 posts since 15 Aug, 2003, from Indianapolis

Postby bk; Fri Jan 25, 2013 10:25 pm BR: T4 Midi timing offset issue

Just recorded a short midi thing using a keyboard controller and a softsynth. when playing it in, it sounded fine, and close to "in time". When played back, it was horrendously off. I had to offset around 400 ticks to get it to play in time with the other stuff (midi drum pattern dragged in from Superior Drummer).

I tried the same thing in T3, and it worked like it always has: perfectly in time. Seems like I must be missing something. Any ideas?

winXP 32 bit.
Image
bk
KVRian
 
1426 posts since 15 Aug, 2003, from Indianapolis

Postby bk; Fri Jan 25, 2013 10:46 pm

Tried in Reaper 4. It worked fine. Went back and tried it again in T4 and it worked fine too! WTF. It failed on 2 different tracks with two different synths before. Nothing changed. :nutter:
Image
paradiddle
KVRian
 
1309 posts since 14 Aug, 2001, from montreal, canada

Postby paradiddle; Sat Jan 26, 2013 9:18 am

I'm getting this also. PLaying a drumbeat on the keyboard to the click. It's fine when recording but on playback, it's all desynced.
Stuck in Aperture Laboratories for a 2nd time!
bk
KVRian
 
1426 posts since 15 Aug, 2003, from Indianapolis

Postby bk; Sat Jan 26, 2013 9:21 am

Yeah, I'm pretty sure I wasn't imagining it, but can't recreate it at the moment. The notes were played in "on the beat", and sounded that way while recording, but the midi notes shown in the clip after recording were shifted late around 400 ticks.
Image
paradiddle
KVRian
 
1309 posts since 14 Aug, 2001, from montreal, canada

Postby paradiddle; Sat Jan 26, 2013 9:52 am

Yep same here again! I can reproduce this all the time.

I've also put a quarter note kick on on the grid and I've overdubbed the upbeats on the hh. Same thing again.

Haven't tried with audio yet.
Stuck in Aperture Laboratories for a 2nd time!
fedexnman
KVRian
 
1342 posts since 3 Jan, 2005

Postby fedexnman; Sat Jan 26, 2013 2:51 pm

Same here , ezdrummer , i even went back and turned metronome on and recorded straight quarter notes to the click and it was way off .
pquenin
KVRist
 
439 posts since 26 Jul, 2001, from france

Postby pquenin; Sat Jan 26, 2013 2:58 pm

todd sweetland wrote:Same here , ezdrummer , i even went back and turned metronome on and recorded straight quarter notes to the click and it was way off .


have you set a "quantise" value to your midi in device ?
fedexnman
KVRian
 
1342 posts since 3 Jan, 2005

Postby fedexnman; Sat Jan 26, 2013 3:02 pm

0 quantize value but whats weird its default setting underneath says 100% I even set that to zero too , never had this problem with the T1 T2 or T3 ....
fedexnman
KVRian
 
1342 posts since 3 Jan, 2005

Postby fedexnman; Sat Jan 26, 2013 6:25 pm

Temporary FIXED the PROBLEM :
1. go to " settings "
2. then to MIDI i/o
3. look at the middle of the screen 3 quarters way to the bottom, SEE...
(o) use MIDI driver for MIDI timing
^ unclick that circle so its not filled or marked
( ) use MIDI driver for MIDI timing
So it was just a bad default setting . I had the same problem as the OP timing was right but playback wasn't , this fixed it . Might want to send this fix to JULES .....
Last edited by fedexnman on Sat Jan 26, 2013 6:46 pm, edited 1 time in total.
fedexnman
KVRian
 
1342 posts since 3 Jan, 2005

Postby fedexnman; Sat Jan 26, 2013 6:27 pm

Oh , I was using a m-audio trigger finger 4x4 pad controller .
valley
KVRAF
 
4631 posts since 28 Nov, 2002, from Chicago

Postby valley; Sat Jan 26, 2013 6:38 pm

OK, I've passed this on to Jules.

Disabling this setting should probably be considered a temporary fix only, 'cos in principal you should get better timing from the MIDI driver.
Someone shot the food. Remember: don't shoot food!
bk
KVRian
 
1426 posts since 15 Aug, 2003, from Indianapolis

Postby bk; Sat Jan 26, 2013 8:59 pm

valley wrote:OK, I've passed this on to Jules.

Disabling this setting should probably be considered a temporary fix only, 'cos in principal you should get better timing from the MIDI driver.

Yeah, I always thought the midi driver should control this.

I'm off to test this again. I'll report back.
Image

Moderators: valley, jules, TSC, ModuLR

Return to Tracktion