Close to Giving Up on ACPI

Configure and optimize you computer for Audio.
geeseaplenty
KVRist
418 posts since 19 Nov, 2002

Post Tue Jan 11, 2005 11:15 am

I simply cannot record MIDI in ACPI mode in Windows XP. The timing is horrible--a terrible, annoying quarter-note lag. I was thinking SP2 would fix the problem, but it did not.

Thanks Microsoft. I now have a perfectly good USB audio/MIDI interface (Tascam us-122) that can't perform the most basic of functions because of this unfixable problem. For the umpteenth time, I now have to re-install in Standard PC mode.

What are the disadvantages of installing in Standard PC mode? I've heard it causes instability. Does anyone else here have to run Win XP in Standard PC mode because of this problem?

Jeremy_NSL
KVRAF
2978 posts since 24 Apr, 2003 from Canada

Post Tue Jan 11, 2005 11:20 am

Are you absolutely sure its ACPIs fault? Have you run your audio interface on another PC to test? Some USB interfaces are known to add ~30ms+ to latency. But perhaps your interface just doesnt like ACPI I suppose.

ericj23
KVRAF
2438 posts since 26 Aug, 2002 from here

Post Tue Jan 11, 2005 11:23 am

and if its cubase your using have you tried all the differnt midi configs

system timestamp and non emulated ports and some such

geeseaplenty
KVRist
418 posts since 19 Nov, 2002

Post Tue Jan 11, 2005 11:28 am

All I know is this:

I have installed XP in ACPI mode countless times and have ALWAYS had the poor MIDI timing.

And I have installed in Standard PC mode countless times and have always had NO MIDI timing problems whatsoever.

I'd say that has nothing to do with latency or settings within Cubase.

The only reason I'd rather not install in Standard PC is because everybody says not to in Win XP. They say it's not necessary.

As to why they say this and how it relates to me, I have no clue.

ericj23
KVRAF
2438 posts since 26 Aug, 2002 from here

Post Tue Jan 11, 2005 11:44 am

from rme regarding hammerfall cards

Under Windows XP Microsoft has significantly improved both interrupt handling and ACPI. In most cases the interrupts will not be sharing IRQ 9. Even when, problems like with the above mentioned simultaneous network transmission are no longer found. Furthermore XP operates more reliable and stable using the ACPI mode. Therefore changing to Standard-PC mode under Windows XP is not recommended.

The worst thing to do is to use Standard-PC mode with the latest generation of single CPU motherboards, having an advanced programmable interrupt controller (APIC.) These boards offer 24 interrupts under Windows XP in ACPI mode (else found on dual CPU boards only) - but only 15 when using Standard-PC mode!

from music xp

ACPI or "Standard PC"
ACPI works extremely well with Windows XP, and has been significantly improved upon over Windows 2000.

Therefore, it is recommended that you first try installing Windows XP with the default option, which is as an ACPI computer.

The only time that the "Standard PC" mode can be recommended with XP, is when you are experiencing audio card or other problems (possibly relating to IRQ sharing/stacking), and only when you have exhausted all other possible causes.

If you have one of the more modern motherboards that has APIC capabilities, then it is definitely recommended that you install Windows XP as an ACPI computer.

In fact, installing Windows XP as a "Standard PC" on an APIC compatible computer will probably result in reduced performance and a reduction with overall reliability.

so is it an old computer -

and is it cubase your using -
it has had some serious midi timing problems which were caused by OS midi setup - if you changed to standard mode you might fix the os midi but the cubase problem can now be fixede from within cubase

DevonB
KVRAF
7775 posts since 24 Feb, 2003 from Earth, USA

Post Tue Jan 11, 2005 11:51 am

Need to reinstall for Standard PC mode? You don't have to. Just select Standard PC as the driver, it'll reboot like 3 times, reinstalling all the drivers for your devices (make sure you got your driver disks ready), and you're done. Going back to APCI from Standard PC mode requires a reinstall.

Devon
Simple music philosophy - Those who can, make music. Those who can't, make excuses.
Read my VST reviews at Traxmusic!

geeseaplenty
KVRist
418 posts since 19 Nov, 2002

Post Tue Jan 11, 2005 11:54 am

so is it an old computer -

and is it cubase your using -
it has had some serious midi timing problems which were caused by OS midi setup - if you changed to standard mode you might fix the os midi but the cubase problem can now be fixede from within cubase
No...it's a latest generation apci board. An MSI k7n2 delta mainboard.

OK, so what must I do within Cubase SX to fix this timing problem that installing in Standard PC mode does automatically?

seamoss
KVRian
1169 posts since 27 Apr, 2004 from Houston, Texas

Post Tue Jan 11, 2005 12:04 pm

I HAVE to run standard pc mode for the same reason. Midi timing is awful under cubase/nuendo.

Nothing special or too old on my system either.


P4 2.8
Asus P4B533-E MB
Delta 66
Midisport 2x2


ACPI is NOT an option for me and it sounds like you have a similar problem.


IRQ chaning won't change anything either.

geeseaplenty
KVRist
418 posts since 19 Nov, 2002

Post Tue Jan 11, 2005 12:15 pm

I HAVE to run standard pc mode for the same reason. Midi timing is awful under cubase/nuendo.

Nothing special or too old on my system either.


P4 2.8
Asus P4B533-E MB
Delta 66
Midisport 2x2


ACPI is NOT an option for me and it sounds like you have a similar problem.


IRQ chaning won't change anything either.
Glad I'm not the only one, seamoss!

And I've checked my IRQs, too. Only two are sharing (a networking device and USB controller). And many have said this isn't a problem.

So basically it's inexplicable, as IRQ sharing has nothing to do with it. ACPI just sucks.

Have you had any problems running in Standard PC mode within Win XP, seamoss?

UltraJv
KVRAF
6234 posts since 30 Dec, 2004 from London uk

Post Tue Jan 11, 2005 12:19 pm

Some hardware combinations are susceptable to bad midi timing. USB is known to be troublesome. Have you tried the Nuendo/Cubase forums? First place to go if you have trouble.


http://forum.cubase.net/phpbb2/

http://forum.nuendo.com/phpbb2/

ericj23
KVRAF
2438 posts since 26 Aug, 2002 from here

Post Tue Jan 11, 2005 12:21 pm

as im sure you know their is the ignoreport filter thing into your main directory to remove all emulated devices from your midi options

but it does not work for all setups - and in fact with some setups you should use the emulated inputs - in device setup under midi their is an option to use system timestamp - this apparently helps with this

in truth im saying this from memory as the detailed explantion that was on cubase.net no longer seems to be there

anyway hopefully one of thsose will help - but the system timestamp one is the one im guessing might

DevonB
KVRAF
7775 posts since 24 Feb, 2003 from Earth, USA

Post Tue Jan 11, 2005 12:35 pm

I have no problems with Cubase SX under STandard PC mode.

There is an article though with MIDI timestamps for SX 2.2.0 and what combinations work and what ones don't. Hmmmm wonder if I can find it. It was a web page dedicated to it.

Devon
Simple music philosophy - Those who can, make music. Those who can't, make excuses.
Read my VST reviews at Traxmusic!

DevonB
KVRAF
7775 posts since 24 Feb, 2003 from Earth, USA

Post Tue Jan 11, 2005 12:41 pm

FOUND THE ARTICLE! Yay! :)

http://www.jay.fm/blog/pc-midi-timing-and-nuendo.html

Read it and enjoy.

Devon
Simple music philosophy - Those who can, make music. Those who can't, make excuses.
Read my VST reviews at Traxmusic!

geeseaplenty
KVRist
418 posts since 19 Nov, 2002

Post Tue Jan 11, 2005 3:40 pm

Thanks for the article link, Devon. As I only have Cubase SX 1, it won't help, however.

I never in my wildest imagination could have guessed the problem could be attributed to so many factors (as the article seems to suggest)! The only fix seems to be within a version of Cubase that I don't have.

All just chalk it up to a big mystery and re-install in Standard PC mode...again.

DevonB
KVRAF
7775 posts since 24 Feb, 2003 from Earth, USA

Post Tue Jan 11, 2005 3:43 pm

geeseaplenty wrote:All just chalk it up to a big mystery and re-install in Standard PC mode...again.
Just select Standard PC mode driver in Device Manager instead, dont' reinstall. You'll be done in about 5 minutes.

Devon
Simple music philosophy - Those who can, make music. Those who can't, make excuses.
Read my VST reviews at Traxmusic!

Return to “Computer Setup and System Configuration”