One Synth Challenge #146: Sinmad by NUSofting (New prize added!)

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
KVRist
125 posts since 11 Sep, 2007 from NJ, USA

Post Sat Apr 03, 2021 9:12 am

"Saving preset should be as simple as clicking [save] on the GUI, write a name and use "Save new user preset" button in the popup. Does not work?"

Solution:

Since I am on Windows 10, I try to "run as administrator" when opening Ableton Live. That helps save the edited preset.
Cheers.

DASH Guy
7616 posts since 20 Sep, 2001

Post Sat Apr 03, 2021 9:37 am

gigue07 wrote:
Sat Apr 03, 2021 9:12 am
"Saving preset should be as simple as clicking [save] on the GUI, write a name and use "Save new user preset" button in the popup. Does not work?"

Solution:

Since I am on Windows 10, I try to "run as administrator" when opening Ableton Live. That helps save the edited preset.
Cheers.
For the latest Windows 10 we need to move (in one next release) the Sinmad "User Preset" folder outside "Program Files" that is write protected by default. Otherwise yes you need to be in admin mode.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

DASH Guy
7616 posts since 20 Sep, 2001

Post Sat Apr 03, 2021 9:40 am

marks-a-whybikky wrote:
Sat Apr 03, 2021 6:38 am
... VST-Version is not been recognized in StudioOne5 and not in PlougeBidule (latest Version). AU-Version works fine in Logic X and StudioOne5 ...
Which macOS? Thanks.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

IV!
KVRist
257 posts since 31 Oct, 2019

Post Sat Apr 03, 2021 10:58 am

Wow, a great synthesizer and a suggestion that is a strong additional incentive to create a track this month! :hail: :lol: I'm on Windows 7 64bit, Cakewalk, and it really worked after I installed that version of vcredist) It seems that these vcredists are all unique - you can have the newest version, but any game or program will not work without a certain old version. :shrug:
The only problem up to this point is this: when, after first starting and closing SinMad, I tried to rename or move the synth folder, I got: "The font file 'Arvin' is open in system", and it looks like this won't go away until the computer restarts. It's not a big problem, to be honest...
In "first run message" I accidentally noticed an empty space :roll: ; perhaps it was prepared for the Russian language? :D Just in case, I made a translation for him, as short as possible but with a soul (and without the double "the" error in the English version :hihi: How disgusting I am! :cry: ):
"Добро пожаловать в SinMad!
Это ваш первый запуск синтезатора Sinmad, вам нужно знать следующее: есть два вида интерфейса - "easy" и "full". Вы можете выбрать один из них в правом верхнем углу. Вид "easy" предназначен для базового редактирования предустановок из заводской или пользовательской библиотеки.
Если вы прошли обучающий банк 'I start U', выберите вид "full". Развлекайтесь!) [Это сообщение больше не появится; пожалуйста, прочтите руководство, чтобы узнать больше!]"
If not, take it as a joke and don't take offense at me please! :pray:
Thank you for your great work! :hail: :clap: ""1 Start U" (it's written in the synthesizer, honestly!) already sounds great, it's time to dive into SinMad with your head, and I already feel that it is very deep!

DASH Guy
7616 posts since 20 Sep, 2001

Post Sat Apr 03, 2021 1:12 pm

IV! wrote:
Sat Apr 03, 2021 10:58 am
In "first run message" I accidentally noticed an empty space :roll: ; perhaps it was prepared for the Russian language? :D Just in case, I made a translation for him, as short as possible but with a soul (and without the double "the" error in the English version :hihi: How disgusting I am! :cry: ):
Thanks a lot! I wanted to put Russian as well, now I got this, Italian and German ready, I will fix the others and update the "first run" screen for the release in May, hopefully with no more errors, <wink>
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

KVRist
125 posts since 11 Sep, 2007 from NJ, USA

Post Sat Apr 03, 2021 2:10 pm

liqih wrote:
Sat Apr 03, 2021 9:37 am
gigue07 wrote:
Sat Apr 03, 2021 9:12 am
"Saving preset should be as simple as clicking [save] on the GUI, write a name and use "Save new user preset" button in the popup. Does not work?"

Solution:

Since I am on Windows 10, I try to "run as administrator" when opening Ableton Live. That helps save the edited preset.
Cheers.
For the latest Windows 10 we need to move (in one next release) the Sinmad "User Preset" folder outside "Program Files" that is write protected by default. Otherwise yes you need to be in admin mode.
liqih wrote:
Sat Apr 03, 2021 9:37 am
For the latest Windows 10 we need to move (in one next release) the Sinmad "User Preset" folder outside "Program Files" that is write protected by default. Otherwise yes you need to be in admin mode.
Thanks for the incoming update.

IV!
KVRist
257 posts since 31 Oct, 2019

Post Sat Apr 03, 2021 3:25 pm

As I understand it, there is no Guide for SinMad yet, so all links lead to Sinnah?
I would also like to warn everyone that some presets are very loud, especially from the "Older Betas" category! :phones:

KVRist
137 posts since 30 Jul, 2007

Post Sat Apr 03, 2021 10:55 pm

@liqih: sorry for my late replay ... My OS: 10.15.7 on iMac 2020, 3.6GHz 10-Core, 64GB Ram, AMD Radeon Pro 8GB ...
one single instance of SINMAD takes about 10% CPU in Logic X (10.6.1) and same in StudioOne 5 (5.2) ...

DASH Guy
7616 posts since 20 Sep, 2001

Post Sun Apr 04, 2021 5:25 am

IV! wrote:
Sat Apr 03, 2021 3:25 pm
As I understand it, there is no Guide for SinMad yet, so all links lead to Sinnah?
I would also like to warn everyone that some presets are very loud, especially from the "Older Betas" category! :phones:
Yes, some presets in "Older Betas" may not play at all or explode, those are there to be reviewed and updated.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

DASH Guy
7616 posts since 20 Sep, 2001

Post Sun Apr 04, 2021 5:31 am

marks-a-whybikky wrote:
Sat Apr 03, 2021 10:55 pm
@liqih: sorry for my late replay ... My OS: 10.15.7 on iMac 2020, 3.6GHz 10-Core, 64GB Ram, AMD Radeon Pro 8GB ...
one single instance of SINMAD takes about 10% CPU in Logic X (10.6.1) and same in StudioOne 5 (5.2) ...
ok, that's the latest Catalina I guess, I will find out why the VST2 are not recognize in those hosts, could you meanwhile try another free or demo VST host?
Here is one:
https://lmms.io/download#mac
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

DASH Guy
7616 posts since 20 Sep, 2001

Post Sun Apr 04, 2021 5:34 am

I could reproduce the "sound off" bug on Windows 10, it's related to high FM modulation (wave 1) and switching between poly and mono, while playing. I fixed that in Windows VST so far. Stay tuned for an update.
liqih wrote:
Sat Apr 03, 2021 6:28 am
Many thanks for the tests, I will search for the bug.
z.prime wrote:
Sat Apr 03, 2021 5:43 am
Heya liqih, I've also had this happen, in the latest Bitwig:
MilksterX wrote:
Sat Apr 03, 2021 12:50 am
I too had the audio stop working
... however I tracked down a bit more information on an instance that suddenly went silent: I was using MONO mode, when I switched to POLY mode, the first voice was silent (e.g. when I pressed a single key) but the SECOND and third and other voices were working properly! (e.g. pressing 2 notes simultaneously or when a second voice is active due to release time). Changing presets back/forth still resulted in the first voice being silent but the others working properly. I tried adjusting every parameter to see if something might help reset a value somewhere, but it did not. Also, in my case, the synth stopped making sound while I was adjusting the wave 1 FM ratio in the GUI and playing notes. I'm pretty sure the first time it happened I was mucking about with the GUI and also playing notes on an external keyboard in a similar way. Knowing just a bit about plugin development, I suspect one of 2 things is happening: a voice index is going negative so the "first" voice is unable to actually map to a voice location -or- some bad value is being copied to the active voice that the synth is unable to recover from (or, of course, I could be all wet :ud:). Anyway, cheers, hope this helps in some way!
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

KVRist
137 posts since 30 Jul, 2007

Post Sun Apr 04, 2021 8:16 am

... just made a quick Test with SinMad in Logic X:
https://soundcloud.com/marks-a-whybikky ... rppgb52SB4

it is a very very interesting synth! chapeau and all thumbs up! :tu: :tu: :clap:

User avatar
KVRist
140 posts since 4 Nov, 2019

Post Sun Apr 04, 2021 9:08 am

I'm experiencing some inconsistency in the delay matrix. It seems to be skipped for some notes when the previous note is still sounding. I can reproduce this from a clean start by setting a short pulse envelope, with a release that's not too short, and setting a delay of 100ms or so. Played slowly, each note plays with the delay. With two notes played in quick succession, the first plays with the delay and the second does not.

After saving a patch, if I close the window before the save confirmation is removed, Reaper crashes. (Reaper 6.26, MacOS 10.13)

A few times, I have had trouble with the rectangular numeric fields not responding to mouse input, or responding erratically. For instance, a couple of times I set the LFO target to BR Hz and the depth appeared to be stuck at 12000.0. Testing just now, I could not get it stuck, but the distance I had to drag outside the box before it responded was variable. It may be related to responding to both horizontal and vertical mouse movement. It would behave more reliably if it only responded to the axis along which the mouse has moved farther.

Is there a way to see numeric values for envelope parameters? That would be useful.

Otherwise, I'm enjoying the synth so far.

DASH Guy
7616 posts since 20 Sep, 2001

Post Sun Apr 04, 2021 10:03 am

FrogsInPants wrote:
Sun Apr 04, 2021 9:08 am
I'm experiencing some inconsistency in the delay matrix. It seems to be skipped for some notes when the previous note is still sounding. I can reproduce this from a clean start by setting a short pulse envelope, with a release that's not too short, and setting a delay of 100ms or so. Played slowly, each note plays with the delay. With two notes played in quick succession, the first plays with the delay and the second does not.
Does that change with different "glide/smooth"knob values?
After saving a patch, if I close the window before the save confirmation is removed, Reaper crashes. (Reaper 6.26, MacOS 10.13)
I will check that in MacOS 10.14.
A few times, I have had trouble with the rectangular numeric fields not responding to mouse input, or responding erratically. For instance, a couple of times I set the LFO target to BR Hz and the depth appeared to be stuck at 12000.0. Testing just now, I could not get it stuck, but the distance I had to drag outside the box before it responded was variable. It may be related to responding to both horizontal and vertical mouse movement. It would behave more reliably if it only responded to the axis along which the mouse has moved farther.
Yes distance is 2D, because you can change the value faster or slower. Usually you click on the
value box to lock in and then move mouse around (any direction) to find the desired value.
Honestly I'm not sure yet if this works with any mouse or track pad. Please try some more and let me know if it would usable for you.
Is there a way to see numeric values for envelope parameters? That would be useful.
Not so far, maybe I will add that.
Otherwise, I'm enjoying the synth so far.
Good! Thanks for the report.
http://nusofting.com
NUSofting : Peti Modelonia Sinnah

KVRian
1119 posts since 9 Jan, 2013 from morf

Post Mon Apr 05, 2021 3:42 am

Many thanks to Liqih for the opportunity with this synth, I’ve only scratched the surface, yet it’s one great itch ;)

Not sure how much time I can spend this month, so this is either the finished track or a WIP
Mix is not all that, though I do like the style of roughness :D

https://soundcloud.com/eauson/eauson-sinmad-kvrosc



15 Sinmad
Dmg track
Span
Buttercomp2
Acceleration 2
Youlean
Mackity
ReaEq
Verbity, distance
Supermassive
Valhalla delay
Auto pan
Varimu
Last edited by Eauson on Tue Apr 06, 2021 1:34 am, edited 1 time in total.
Man is least himself when he talks in the first person. Give him a mask, and he'll show you his true face

Return to “Instruments”