New organ VST plugin

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
Teksonik
KVRAF
16488 posts since 16 Sep, 2001 from Las Vegas,USA

Post Wed Aug 18, 2021 9:31 am

Jonathan Shepherd wrote:
Wed Aug 18, 2021 1:30 am
This one is a definite keeper. Great sound. And tiny!
What are your system specs? What DAWs are you using? Are you using the 64 bit version? There is a reason why it's working for some people but not others.

I haven't tried it on my studio computer yet but I try all the freeware on this system (which is why it has 507 plugins on it) and all of it has scanned, loaded, and functioned just fine except for this plugin.

Maybe it requires newer specs and that would explain why it works for some but not others.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

Jonathan Shepherd
KVRist
492 posts since 28 Jan, 2003

Post Wed Aug 18, 2021 9:50 am

64 bit, on Bitwig 4.0. Windows 10. Hope it works out for you-

User avatar
Teksonik
KVRAF
16488 posts since 16 Sep, 2001 from Las Vegas,USA

Post Wed Aug 18, 2021 10:13 am

Jonathan Shepherd wrote:
Wed Aug 18, 2021 9:50 am
64 bit, on Bitwig 4.0. Windows 10. Hope it works out for you-
I'm on Windows 10 64 bit as well. I only have the Bitwig Studio demo but it returned an error with ttm as well.

ttm5.png

Here is the error message copied from Bitwig:

"D:\64 Bit Plugins\ttm000_x64.dll
com.bitwig.flt.library.metadata.reader.exception.CouldNotReadMetadataException: could not read metadata: Communications error with plugin host process
exit code:-1073741795
stdout:
PluginHost: Reading VST 2.4 plugin metadata for D:\64 Bit Plugins\ttm000_x64.dll"

So it must be a hardware issue since all other conditions seem to be the same. What CPU are you running?
You do not have the required permissions to view the files attached to this post.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Wed Aug 18, 2021 4:53 pm

Perhaps it is due to the fact that ttm000 is using AVX2.
I will try to make a DLL that does not use AVX2.
I will let you know here when it is completed.

User avatar
Teksonik
KVRAF
16488 posts since 16 Sep, 2001 from Las Vegas,USA

Post Wed Aug 18, 2021 5:18 pm

Ok that's probably it then. My internet computer has AVX but not AVX 2. My studio system does have AVX 2 support so it should run on that just fine. I'll give it a try tomorrow.
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Wed Aug 18, 2021 8:08 pm

Prepared DLL without AVX2.

ttm000_x64_avx.dll
>>use AVX (not AVX2).

ttm000_x64_no_avx.dll
>>not use any AVX.

You can get it from the link below.
[This link is no longer available.]
Last edited by ttm_mari on Thu Aug 19, 2021 6:16 am, edited 1 time in total.

User avatar
Teksonik
KVRAF
16488 posts since 16 Sep, 2001 from Las Vegas,USA

Post Thu Aug 19, 2021 5:52 am

Ok thanks using the (not AVX2) version does work so that was the issue.

Nice sounding Organ plugin with almost no CPU usage. :tu:
None are so hopelessly enslaved as those who falsely believe they are free. Johann Wolfgang von Goethe

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Thu Aug 19, 2021 6:05 am

Thanks for the test. :wink:
I'm glad you got it working.

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Thu Aug 19, 2021 6:12 am

I have updated the plugin file as I have confirmed that the 64-bit version works.

https://drive.google.com/file/d/19Kyh20 ... sp=sharing

fakemaxwell
KVRer
6 posts since 29 Apr, 2020

Post Thu Aug 19, 2021 9:30 am

The 64-bit version is still crashing Reaper. On 9900K, Windows 10 so it's not the AVX2.

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Thu Aug 19, 2021 3:35 pm

At what point does it crash?

Could you try this?

https://drive.google.com/file/d/1z2Wv9P ... sp=sharing

ttm000_x64_avx.dll
>>use AVX (not AVX2).

ttm000_x64_no_avx.dll
>>not use any AVX.

lucienz
KVRist
37 posts since 20 Sep, 2010 from Paris

Post Fri Aug 20, 2021 4:20 am

Well done, works perfectly in 64 bits and 32 bits.
Great sound.
Something that would be perfect ... midi learning for ordering the sliders.
midi learning, or manual assignment.

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Fri Aug 20, 2021 7:59 am

Thanks, I'll consider it.

lucienz
KVRist
37 posts since 20 Sep, 2010 from Paris

Post Sat Aug 21, 2021 5:55 am

Thanks to you.
And my Motif XS6 thanks you too.

User avatar
ttm_mari
KVRist

Topic Starter

61 posts since 13 Aug, 2021

Post Sat Aug 21, 2021 6:18 am

This is an example for Reaper, can't you set MIDI Learn from the automation settings function?
You do not have the required permissions to view the files attached to this post.

Return to “Instruments”