EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Configure and optimize you computer for Audio.
mcmilliron
KVRer
2 posts since 1 Aug, 2004

Post Mon Nov 11, 2019 1:22 pm

First I need to give a huge thanks to ClubHouseKey! Seriously, you are amazing!

One negative that I've noticed with my 1212M after applying the fix (I also saw someone else mention it in this thread ). The mute button's in Patchmix no longer work for me. Not a big deal at all but I wanted to share.

emulator01
KVRist
141 posts since 8 Dec, 2006 from Germany

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Tue Nov 12, 2019 12:09 pm

No issues after upgrade from Win 10 pro (1903) to 1909 with EMU 0404PCIe. Thank you very much again for your workaround.

l_maseroni
KVRist
42 posts since 22 Jun, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Wed Nov 13, 2019 10:48 am

I finally found a Group Policy setting which said do not automatically install driver software for a specific driver ID (which you can find on the E-MU E-DSP properties page in Device Manager). Once I was able to boot Windows with no E-MU device installed, everything went smoothly with no further issues. (Minor edit to the PowerScript file to adjust the Friendly Name, but that was all.)


[/quote]

Hi, where did you find the group policy you mentioned? I would appreciate your contribution!

l_maseroni
KVRist
42 posts since 22 Jun, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Wed Nov 13, 2019 10:52 am

rbratton wrote:
Sat Oct 26, 2019 2:00 pm
ClubHouseKey wrote:
Thu May 30, 2019 6:06 pm
Driver fix for EMU 1820 and probably all other EMU cards on Windows 10 1903.

Here are some instructions:

1. Uninstall any existing EMU drivers and PatchMix versions.
2. Install 2.30 beta drivers (EmuPMX_PCDrv_US_2_30_00_BETA.exe) and reboot.
4. Download XFTI_PCDRV_L11_2_40_0018.exe, then extract it with 7-Zip to a temp folder like C:\temp. Example file structure should look like this: c:\temp\XFTI_PCDRV_L11_2_40_0018\setup.exe
5. Unzip the attached ScriptFiles.zip to c:\temp. You should now have FilesToReplace.csv, EMU_Driver_Fix.ps1, and the XFTI_PCDRV_L11_2_40_0018 folder together in c:\temp.
6. Open an Elevated powershell window and change directory to c:\temp.
7. Run .\EMU_Driver_Fix.ps1 from the Elevated powershell window. The script does 3 things: 1) Disables the EMU card in device manager so we can overwrite some of the driver files. 2) Reads the csv, loops through each entry, and overwrites the necessary files. 3) Re-enables the EMU card in device manager.
8. Install PatchMix 2.20 (EmuPMX_PCApp_US_2_20_00.exe) and reboot.
9. Your card should be fully functional now.

Links:

EmuPMX_PCDrv_US_2_30_00_BETA.exe - E-MU beta drivers for Windows Vista x64 compatibility. These can support most models.
https://support.creative.com/downloads/ ... adId=12479

EmuPMX_PCApp_US_2_20_00.exe - E-MU PatchMix software meant for the 1616M PCIe model
https://support.creative.com/downloads/ ... adId=11912

XFTI_PCDRV_L11_2_40_0018.exe - Updated Creative X-Fi drivers for Windows 10 1903
https://support.creative.com/downloads/ ... dId=100256

I encourage you to check out the script and csv before running it. If there is any concern about running a script, you can manually replace the files as listed in the csv, however it is 111 files.

My initial discovery of this method happened by a happy accident as I was examining Creative's X-Fi drivers which they fixed for 1903. I noticed many similarities to the EMU drivers, including many leftover references to the EMU products. I force installed the Creative drivers to be used with a virtual device (a Voicemeeter/VBAN virtual soundcard) and after a reboot magically my EMU started working. I came up with the method above after painstakingly examining what exact combination of these files it took to get success as I wanted something repeatable and shareable. I believe in 1903 MS has fixed a flaw, enforced a best practice, or enhanced the audio stack in a way that broke what EMU/Creative had done in the past.

Good luck!
Like SO MANY others, I've been lurking/reading this thread, but I just had to register to express my THANKS for your hard work. I had my E-MU 1820 setup working fine with Windows 10 1809, but Windows wouldn't offer the 1903 Feature Update -- said it was available, but my computer wasn't ready. I finally pulled the PCI card which allowed the 1903 update. I then ran into all the issues noted in this thread trying to get the reinstalled card working again.

I had tried your steps a few times without success, but I think that was due to Windows wanting to automatically reinstall the E-MU drivers. I uninstalled the drivers and the PatchMix s/w, but the E-MU installation app asked me to then reboot. I tried to just reinstall the BETA driver w/o rebooting, but it said it couldn't -- I had to reboot first. And every time I rebooted, Windows undid my work by reinstalling the drivers from "somewhere", even though I told it not to and even though I thought I had deleted the old drivers. I finally found a Group Policy setting which said do not automatically install driver software for a specific driver ID (which you can find on the E-MU E-DSP properties page in Device Manager). Once I was able to boot Windows with no E-MU device installed, everything went smoothly with no further issues. (Minor edit to the PowerScript file to adjust the Friendly Name, but that was all.)

Let's all hope Microsoft is finished messing with whatever they did to break the E-MU code between 1809 and 1903.

Again -- MANY THANKS!

randy
Hi, where did you find the group policy you mentioned? I would appreciate your contribution!

remondo
KVRer
1 posts since 14 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Thu Nov 14, 2019 11:40 am

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
BODYPRINT wrote:
Thu May 30, 2019 8:29 pm
Thanks heaps for all the details. You are a legend!!

You'll all be pleased to know that you don't need to run any scripts or anything difficult!

Here's what I did step by step.
1. I already had the EMU Beta drivers installed but probably not required. I didn't uninstall anything though.
2. Download the driver ClubHouseKey linked to... XFTI_PCDRV_L11_2_40_0018.exe - Updated Creative X-Fi drivers for Windows 10 1903
https://support.creative.com/downloads/ (https://support.creative.com/downloads/) ... dId=100256
3. Extract the .exe using 7-zip or winrar etc.
4. Do to Device Manager and update the EMU DSP Driver by Right clicking on EMU DSP (under Sound, Video and Game Controllers) and select Update Driver.
5. Select 'Browse my computer for driver software'
6. Let me pick from a list of available drivers on my computer
7. Click the 'Have disk..." button and then browse to extracted folder \XFTI_PCDRV_L11_2_40_0018\Drivers\wdm
8. Select wdma_emu.inf and Open... OK...
9. Choose 'Creative X-Fi Audio Processor'. Next and select Yes when it says Not Recommended...
10. You card will temporarily be called "Creative X-Fi Audio Processor" but when you re-boot it will be called "EMU E-DSP" and patchmix works as before.

Good luck all and thanks again for this driver link! :))
Thanks, this is way easier than running the script, which didn't work for me at all. My 0404 PCI is now working again :) after Windows force updated itself :x

For anyone getting "access denied" when clicking the download link for XFTI_PCDRV_L11_2_40_0018.exe, XFTI_PCDRV_L11_2_40_0019.exe (https://download.creative.com/manualdn/Drivers/AVP/100270/0xFA26C5A9/XFTI_PCDRV_L11_2_40_0019.exe) works fine.

vovi
KVRer
9 posts since 17 Jun, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Sat Nov 16, 2019 11:58 pm

thanks to ClubHouseKey!👍 :clap: :phones:

Lexx1
KVRer
14 posts since 7 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Mon Nov 18, 2019 4:29 am

Hello all. I recently installed my Emu 1820m drivers on my new Windows 10 64 bit computer using the ClubHouseKey method. I've had Windows XP and then Windows 7 32 bit for years and have been using my Emu 1820m since around 2005 with no issues. His method worked perfectly! I just keep experiencing audio stopping. Patchmix Dsp doesn't automatically open when the computer starts up, I have to open it manually. When I open up Patchmix Dsp, I see the meters input fully yellow to the top of the meter. My computer also freezes everything which forces me to hold the power button in order to turn my computer off.
I tried changing the regedit to ASIO64, and that hasn't fixed the issue. I also get an error in red when I run the script in safe mode (pictures attached). I also see a pop up on my desktop every time I restart my computer that says "Installing software, please wait".
Does anyone know why I am experiencing audio stopping, computer freezing and the error in red when I run the script in safe mode? And am I supposed to see that "Installing software, please wait" every single time I start my computer? Thank you all in advance!
You do not have the required permissions to view the files attached to this post.

auron
KVRist
64 posts since 4 Nov, 2013 from Germany

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Mon Nov 18, 2019 6:49 am

Hi there martin, thanks for your tremendous help ! Now i could run my EMU-1820m on my Windows 10 machine :) However your script seems to work but only Asio is missing, i tried the regedit entry changing to that ctasio64.dll but in 2 different DAWs there is no Asio-Device showing up. Anything that i missed here ?

RobLeXBreak
KVRer
10 posts since 17 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Mon Nov 18, 2019 1:43 pm

Dear Audio-Professional Colleagues and Fans of High Quality Audio, the users of the E-MU E-DSP sound cards,

Please check my "FULL REPORT ON THE E-MU DRIVERS FIX (after the previous abstract)" on the other thread: viewtopic.php?f=16&t=529349&p=7578102#p7578102

Perhaps it could help someone figure out the problems with the fix proposed there, which showed some improvements but on my two computers didn't end up with success.

Lexx1
KVRer
14 posts since 7 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Tue Nov 26, 2019 12:53 pm

Hello all. I have reached out to ClubHouseKey, but he hasn't been online in a while, so no reply. I put a post on here looking for help, but no reply. I have been trying to get my Windows 10 64Bit computer to work with this EMU E DSP script, and I have experienced pure aggravation for months! I've tried changing the script names to both "E-MU E DSP" and that has not fixed my red text error in safe mode Powershell. Attached is a image of the outcome of the powershell script being run in safe mode. Can anyone in here decode this error? I have tried the ClubHouseKey method, running the script in safe mode. I have also tried running the script without going to safe mode, and also another method where I install the XFTI_PCDRV_L11_2_40_0018 driver through device manager. I've tried everything, I don't know what else to do! The methods will work for a few minutes, I'll have audio working and everything, but then the meters fill to the top in yellow and my audio stops and the computer freezes (picture of Patchmix DSP attached). Has anyone else in here had this script work on their computer with the same setup as mine? If so, how exactly did you get it to work on your computer? I am really desperate for a solution! I haven't been able to record audio for months, I need to get back to work!

PLEASE, SOMEONE, HELP ME!
Below is my computer information for anyone who may need a little bit more info.

System Information
------------------
Time of this report: 11/26/2019, 10:03:06
Machine name: DESKTOP-SUQFKG9
Machine Id: {8F8630E9-74D5-46C3-8E86-F9A1D323D33F}
Operating System: Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: B450 AORUS ELITE
BIOS: F5 (type: UEFI)
Processor: AMD Ryzen 7 2700X Eight-Core Processor (16 CPUs), ~3.7GHz
Memory: 32768MB RAM
Available OS Memory: 32716MB RAM
Page File: 6394MB used, 31185MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode
You do not have the required permissions to view the files attached to this post.

User avatar
toonertik
KVRAF
2267 posts since 15 Feb, 2017 from a worn out vinyl groove

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Tue Nov 26, 2019 3:41 pm

Lexx1 wrote:
Tue Nov 26, 2019 12:53 pm
Hello all. I have reached out to ClubHouseKey,

PLEASE, SOMEONE, HELP ME!
Hi Lexx1.
I feel your pain.. I'm still on win7 so have not had experience of this, however.. I will have a look through the scripts and see what others are doing.

My initial thoughts would be to uninstall the drivers through "driver manager" and then remove the card and reboot... then re-install the card and start from scratch...
BUT... this might not be the way on win10...

I will do what I can... give me a couple of days or so.

Lexx1
KVRer
14 posts since 7 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Tue Nov 26, 2019 4:16 pm

toonertik wrote:
Tue Nov 26, 2019 3:41 pm
Lexx1 wrote:
Tue Nov 26, 2019 12:53 pm
Hello all. I have reached out to ClubHouseKey,

PLEASE, SOMEONE, HELP ME!
Hi Lexx1.
I feel your pain.. I'm still on win7 so have not had experience of this, however.. I will have a look through the scripts and see what others are doing.

My initial thoughts would be to uninstall the drivers through "driver manager" and then remove the card and reboot... then re-install the card and start from scratch...
BUT... this might not be the way on win10...

I will do what I can... give me a couple of days or so.
Hello. I've tried uninstalling and reinstalling the hardware, but that didn't change anything.
Thank you so much for taking the time to read my message! And thank you in advance for any effort towards helping me fix this issue. Have a wonderful day!
Last edited by Lexx1 on Wed Nov 27, 2019 10:09 am, edited 1 time in total.

vovi
KVRer
9 posts since 17 Jun, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Wed Nov 27, 2019 12:46 am

huge thanks to ClubHouseKey!
You do not have the required permissions to view the files attached to this post.

Lexx1
KVRer
14 posts since 7 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Wed Nov 27, 2019 10:05 am

Lexx1 wrote:
Tue Nov 26, 2019 4:16 pm
toonertik wrote:
Tue Nov 26, 2019 3:41 pm
Lexx1 wrote:
Tue Nov 26, 2019 12:53 pm
Hello all. I have reached out to ClubHouseKey,

PLEASE, SOMEONE, HELP ME!
Hi Lexx1.
I feel your pain.. I'm still on win7 so have not had experience of this, however.. I will have a look through the scripts and see what others are doing.

My initial thoughts would be to uninstall the drivers through "driver manager" and then remove the card and reboot... then re-install the card and start from scratch...
BUT... this might not be the way on win10...

I will do what I can... give me a couple of days or so.
Hello. I've tried uninstalling and reinstalling the hardware, but that didn't change anything.
Thank you so much for taking the time to read my message! And thank you in advance for any effort towards helping me fix this issue. Have a wonderful day!

Lexx1
KVRer
14 posts since 7 Nov, 2019

Re: EMU 1212m/1616m on Windows 7 - The Thread to End All Other EMU Threads!

Post Wed Nov 27, 2019 10:22 am

How do you delete a post?

Return to “Computer Setup and System Configuration”