Bug reports

Official support for: musicdevelopments.com
BluGenes
KVRist
346 posts since 15 May, 2017

Post Sat Feb 03, 2018 5:30 pm

Another quick suggestions bug.. this one draws the suggestion box, but, it stays visible when it shouldn't (after clicking next chord). I didn't show my settings in the video, but the top 3 choices in the hamburger menu are off.. the bottom 3 are on.. but, I don't think that really matters..

Also, not related, but a bug.. if you build a progression with the chord selector and drag it everything is fine. If you choose to create a new composition, the chord selector progression is not initialized, it still has the old progression data. (I was expecting a new composition to initialize everything..)

https://www.youtube.com/watch?v=l8B42GX ... e=youtu.be

nexussynth
KVRian
529 posts since 1 Jan, 2004

Re: Bug reports

Post Sat Feb 03, 2018 6:45 pm

I've noticed this behavior too.
"..What is simple, is simply seen.."

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Sun Feb 04, 2018 9:38 am

I have another bug video ready, just let me know when I should post it..

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Feb 05, 2018 1:10 am

Yes, indeed, I managed to reproduce this ugly window redraw bug!
Fix is under way.
Thanks for the video!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Mon Feb 05, 2018 6:03 am

awesome .. glad to help.. what about the second issue in that post, (not mentioned in the video)??

also.. I had a video ready with more bugs, but, found an error in my presentation, so, I have to re-do it.. shouldn't be long.

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Feb 05, 2018 8:18 am

This was fixed today, thanks, BluGenes!
The second issue: the Chord Selector does not belong to the composition context, it can be considered as a global tool, so that is why a new composition does not initialize it. Just like the MIDI Import page will not change for a new composition or when you load another composition.

Thanks!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Mon Feb 05, 2018 10:32 am

musicdevelopments wrote:This was fixed today, thanks, BluGenes!
The second issue: the Chord Selector does not belong to the composition context, it can be considered as a global tool, so that is why a new composition does not initialize it. Just like the MIDI Import page will not change for a new composition or when you load another composition.

Thanks!
Attila

Ok, understood.. would it be hard to initialize it anyways? restarting the program every time may become standard practice for me then..

I can crash the program via the chord selector, with consistency too.. still working on a video to show that and another bug.. I keep messing up the presentation and trying to keep the video under 10 minutes.. a lot more difficult than it appears when it comes to narrating. lol

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Mon Feb 05, 2018 10:58 am

Please don't make a long documentary :hihi:

Crashing? That sounds frightening. I'll fix that in the shortest possible time.
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Mon Feb 05, 2018 7:37 pm

musicdevelopments wrote:Please don't make a long documentary :hihi:

Crashing? That sounds frightening. I'll fix that in the shortest possible time.
haha yea, I tried to keep it short.. I think the bigger issue I am having is the voicing editor/builder behavior.

anyways..
edit: preview issue was a setting I missed..
Last edited by BluGenes on Wed Feb 07, 2018 7:40 pm, edited 1 time in total.

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Tue Feb 06, 2018 5:17 am

OK, fixed the preview problem with the VST. In Settings, you can change the octave preview.

edit:
The crash is easy to replicate.. build a new progression, then create a new composition after that, delete the progression from the chord progression builder, switch tabs to related chords and click one.. it crashes every time..

mannymang
KVRer
15 posts since 11 Mar, 2014

Re: Bug reports

Post Wed Feb 07, 2018 10:53 pm

musicdevelopments wrote:Sorry to bother you, but can you try if it does NOT work with v3.31?
It would be a big help if I knew where to look for this bug.
For some time I have been thinking about fully reworking note rendering and using a method that guarantees no hanging notes.
This will be necessary sooner or later.

Thanks,
Attila
In Reaper I also get hanging notes in Kontakt when using RapidComposer as a VST, haven't tried it in standalone to see if there's a difference.

Turning off Multi processors in Kontakt makes no difference.

The problem is not bad when syncing with Reaper as the hanging note(s) are turned off when playback is initiated.

Where it causes problems for me is when I'm using RapidComposer in "Local SEQ" mode. The note never turns off until I either hit the Kontakt "!" (panic button) or hit play momentarily in Reaper to reset.

mannymang
KVRer
15 posts since 11 Mar, 2014

Re: Bug reports

Post Thu Feb 08, 2018 1:18 am

I finally figured out why I couldn't drag from the Phrase Browser, and others I'm sure, it's because I'm left handed and I have my mouse buttons switched. I switched to "normal" :wink: buttons on my mouse and it works. Is there a way to help out us lefties? Thanks!

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Thu Feb 08, 2018 1:24 am

Oh no, "This video is unavailable" :bang:
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

musicdevelopments
KVRAF
2889 posts since 9 Jan, 2010

Re: Bug reports

Post Thu Feb 08, 2018 2:18 am

mannymang wrote:I finally figured out why I couldn't drag from the Phrase Browser, and others I'm sure, it's because I'm left handed and I have my mouse buttons switched. I switched to "normal" :wink: buttons on my mouse and it works. Is there a way to help out us lefties? Thanks!
Very good observation! :clap:
I have fixed this today. If you download the next beta version in about 2-3 days you'll be able to drag with the mouse buttons switched.
Thanks!
Attila
http://www.musicdevelopments.com
Music Prototyping And Automated Composition Solutions

BluGenes
KVRist
346 posts since 15 May, 2017

Re: Bug reports

Post Thu Feb 08, 2018 7:07 am

musicdevelopments wrote:Oh no, "This video is unavailable" :bang:

accidentally re-posted the edit version in beta bug thread.. :dog:

Return to “MusicDevelopments”