Tracktion 7- Selecting MIDI In as input not an option

Discussion about: tracktion.com
GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Post Tue Dec 24, 2019 11:27 am

Hi all, new here, and a bit of a noob at DAWs.

I have T7. My midi controller is the M-Audio 61 es keyboard.

I've setup audio and midi devices (I've had Tracktion since T5) per youtube tutorial/written instructions.

The m-audio is recognized as a midi input device in the Settings tab. I've enabled Live Input Monitoring, and Enable Input Monitoring.

When I go to a new project (or any project), and left click a new track, "usb es 61" doesn't show as an input device option, as it did in T5.

My controller works with other DAWs/hosts.

I can trigger midi sounds only with my mouse on T7.

I've looked for new drivers/firmware for the keyboard, but none exist. In Device Manager, the usb powered M-Audio says "this device is working properly," and the drivers are exactly the same on my new laptop with T7, as on my old laptop with T5.

I've reinstalled T7, but nothing. I've installed the demo version of Waveform, and same thing.

My controller works with Logic, Magix, Kontact, and and every program I have. Could it be that Tracktion simply doesn't recognize M-Audio? I'd find that hard to believe.

I'm thinking my noobieness is a possibility, but I've looked at a million tutorials, and read the manual.

Just as in this tutorial, at 1:22, I simply don't have the option to select my controller, aand it doesn't show: https://www.youtube.com/watch?v=XPA-vcYo-yo&t=73s

If it makes a difference, I output to a Helix LT processor, linked to a powered monitor.

I have the m-audio connected directly to a usb input, instead of a hub.

I've been at this for 2 weeks, and losing my mind, so would REALLY appreciate any input. Thanks in advance.

Oh, I've attached screenshots reflecting my Audio setup.
You do not have the required permissions to view the files attached to this post.

hueynym
KVRist
289 posts since 29 May, 2012

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Tue Dec 24, 2019 2:16 pm

Just curious, have you tried Disabling "USB Keystation 61es" from the Output section of the Midi Devices AND also "Line 6 Helix" from the Input section?

Not sure my question helps...

terrynoakes
KVRist
393 posts since 7 May, 2007 from Angus,Scotland

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Tue Dec 24, 2019 3:13 pm

Just a thought, is the midi keyboard enabled in the control surfaces tab?
My M audio keyboard works W10 Windows 8.1

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Fri Jan 03, 2020 5:07 pm

hueynym wrote:
Tue Dec 24, 2019 2:16 pm
Just curious, have you tried Disabling "USB Keystation 61es" from the Output section of the Midi Devices AND also "Line 6 Helix" from the Input section?

Not sure my question helps...
Sorry for delay in response. I have to look for notifications settings in this forum.

Yes, I have, and probably every possible combination. When I disable USB Keystation from Output, And Line 6 from Input, neither shows up as an option, in a track. Thanks.

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Fri Jan 03, 2020 5:14 pm

terrynoakes wrote:
Tue Dec 24, 2019 3:13 pm
Just a thought, is the midi keyboard enabled in the control surfaces tab?
My M audio keyboard works W10 Windows 8.1
Edit: no, I didn't have my controller enabled in surfaces. Sorry for the vague reply

Sorry for delay in response. I have to look for notifications settings in this forum.

Yes. I closed T7, reopened, and still same problem: no option to select the USB keyboard.

Everything worked on T5. Now, nothing works in T7 OR Waveform. I'm losing my mind.

I use Win 10, 64 bit, same as my old computer. Thanks for your response.
Last edited by GuitarPlayerinNYC on Sun Jan 05, 2020 4:05 pm, edited 1 time in total.

Peter Widdicombe
KVRist
426 posts since 29 Aug, 2014

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sat Jan 04, 2020 6:26 am

Did you verify the 61 isn't selected under control surfaces? If it is, then it may be "hijacked" and not available as a conventional MIDI input device.

dellboy
KVRian
1118 posts since 28 Mar, 2007

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sat Jan 04, 2020 7:20 am

What operating system are you using ?

Is you M-audio Keystation the Mk 3 ?

Apart from getting the latest M-Audio drivers for your keyboard its hard to see why its not working.

Have you tried uninstalling Tracktion and deleting all preference files etc and then reinstalling ?

If the Keystaion has a real 5 pin midi output have you tried plugging a midi cable out of that and and into the Line 6 Helix after unplugging the USB midi and seeing if that produces a midi input ?

Have you tried different USB inputs on your computer ?

Deleting the USB devices in control panel in devices if its a Windows OS ?

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 5:07 am

Peter Widdicombe wrote:
Sat Jan 04, 2020 6:26 am
Did you verify the 61 isn't selected under control surfaces? If it is, then it may be "hijacked" and not available as a conventional MIDI input device.
I just did, and no, nothing is selected in control surfaces. Thanks.

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 6:07 am

dellboy wrote:
Sat Jan 04, 2020 7:20 am
What operating system are you using ?

Is you M-audio Keystation the Mk 3 ?

Apart from getting the latest M-Audio drivers for your keyboard its hard to see why its not working.

Have you tried uninstalling Tracktion and deleting all preference files etc and then reinstalling ?

If the Keystaion has a real 5 pin midi output have you tried plugging a midi cable out of that and and into the Line 6 Helix after unplugging the USB midi and seeing if that produces a midi input ?

Have you tried different USB inputs on your computer ?

Deleting the USB devices in control panel in devices if its a Windows OS ?
I'm on 64 bit Win 10; i7 16 gigs ram, SSD.

My M-Audio is the 61 es- it's so old, it's called a legacy device on their web page, but there's no updated drivers when I checked. In any case, the drivers match the drivers on my old laptop, where the keyboard works on T5. I found and installation file for T4, installed it, but T4 doesn't recognize it on my new computer.

I uninstalled T7, then used CC Cleaner to clean up any registry entries. I'm not sure what you mean by preference files, but I deleted any saved projects that were in my Documents folder.

The Keystation doesn't have a midi port, but the keyboard works on every other program/DAW that uses a midi controller. I've loaded demo DAWs to see if it would be recognized, and it was- Reaper, Pro Tools, Ableton, Magix- they all pick up the keyboard, and it works.

I've tried both usb ports, and I deleted the device from Device Manager. I've tried a powered usb hub, as I read that could be an issue.

Since, I've downloaded the demo of Waveform 10. No go there either. I uninstalled WF10, used CC Cleaner to flush out the registry, and I'm back to T7. I'm back to square one. The keyboard shows up in Midi/Audio settings, but not as a choice as an Input device on a track in the project tab. I can trigger midi with my mouse (EZ Drummer), and single notes on a virtual keyboard plugin.

I've been through every Tracktion tutorial on midi I could find, and read hundreds of articles. I've kinda come to this conclusion after spending hundreds of hours on this: it's a tracktion thing. Despite the Keystation showing up in Settings, if it doesn't show up as an option when I arm a track, I'm SOL.

I'm heading to a guitar center today and getting an Arturia Keylab keyboard controller. It's already mapped to work with included software, and other DAWs like Ableton. I to mostly play guitar over backing tracks, or in collabs with others, and decided I want to create my own tracks from scratch. Anyway, if you've gotten this far, thanks.

Peter Widdicombe
KVRist
426 posts since 29 Aug, 2014

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 6:50 am

There is a Tracktion settings file. On my machine it's in "C:\Users\PWidd\AppData\Roaming\Tracktion 4\Tracktion.settings". Uninstall and a registry cleaner might not actually clean that up.

Yes, it's Tracktion 4. Good and bad - I believe the same file keeps settings for all versions of Tracktion you have installed, so when you upgrade things are preserved (again, good and bad). If something isn't compatible between versions, it may cause issues. It also means some things for older 32-bit versions (like VST directories to scan) get brought forward.

Try SAVING and then deleting this file - it'll be recreated back to defaults, but that might "unset" something causing you grief.

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 3:43 pm

Peter Widdicombe wrote:
Sun Jan 05, 2020 6:50 am
There is a Tracktion settings file. On my machine it's in "C:\Users\PWidd\AppData\Roaming\Tracktion 4\Tracktion.settings".
DUDE!!!! I woke up at 4 pm because I was up for 20 straight hours on this. I checked my notifications, and saw your post. I was dreading going to Guitar Center to pick up the Arturia KeyLab KB/Controller (the AnalogLab software is worth $200; there's a demo you can try, and they sound great https://www.arturia.com/products/analog ... /analoglab - I wasn't prompted to register).

Anyway, my attached pic speaks for itself. I can't thank you enough. Seriously, if you have a pet charity, tell me, and I'll make a donation. I've spent HUNDREDS OF HOURS AND SLEEPLESS NIGHTS ON THIS. Logically, I felt there had to be an answer, but after reading through a million posts on midi, and DAWs not recognizing them, I was thinking of not even trying your suggestion, but I'm glad I did.

I couldn't find the path navigating through File Explorer, so I just typed "Traction" in the search window. Here's the weird thing: I could only find a folder for Tracktion 4. No T7 or Waveform. T4 was on my old computer, and I installed it on my new one after first having installed T7, and I just uninstalled it. So, thankyou, thankyou, thankyou.

There's a folder simply named "Traction" but that's for the Tracktion Download Manager.

Waveform doesn't give me the option to select a midi input, but I'm not going to worry about that now. I barely know how to use t7, and d/l the demo of Waveform.

Another oddity: I did another search for Settings (AFTER THE FIX), and came up with a T4 Settings again, but within that folder, there's a file called settings. I'm guessing it's stuck in the registry. Yeah, I just checked, and there's loads of Tracktion entries. I'll use CC cleaner and hopefully flush things out, but I'm not concerned with that now.

I've been a member of music forums for over 10 years (I'm a guitar player), and I've had maybe 3 posted problems solved when it came to gear issues, and most definitely with DAW questions. I only found this forum because Traction directed me here. Unless they own this forum, they should have a dedicated forum at the Traction site.
Peter Widdicombe wrote:
Sun Jan 05, 2020 6:50 am
Try SAVING and then deleting this file - it'll be recreated back to defaults, but that might "unset" something causing you grief.
I decided to set a restore point, and simply deleted the folder. Then I got the message I didn't have enough room on my external drive for a restore point. I lucked out, but yeah, saving that folder is a smart idea.

ANYWAY, after deleting that folder, I fired up T7, and it was like a fresh installation (unlike my reinstallations). I had to reauthorize, set my Audio/Midi devices, scanned for VST plug-ins, etc.

Happy New Year, man. I can't thank you enough.
You do not have the required permissions to view the files attached to this post.

Peter Widdicombe
KVRist
426 posts since 29 Aug, 2014

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 5:48 pm

Yeah, seems that Traction 4 folder and settings is a carryover from that release.

I have wished there were separate settings files, say tracktion32.settings and tracktion64.settings; or per release, as I use both 32/64 bit and have to keep playing with the scan lists for .VSTs.

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Sun Jan 05, 2020 11:00 pm

It bugged me that Waveform didn't give me the option to select a midi input, and I can't leave well enough alone.

Through file explorer, I searched for "Waveform" and got a hit for Waveform.settings within a folder simply named Traction. I found two files: Waveform.settings and Traction.settings. I renamed both files with a .bak extension. I fired up Waveform, and bang, I now have the ability to select Midi as an input source.

In my tortured history with Windows, I opened up T7, and, of course, my midi input selection disappeared. I drilled back to the folder named T4, and deleted the Traction.settings file. I opened up T7, reauthrorized, and boom, I now have my midi input selection back, and in Waveform. This fix was a life saver for me.

There's a quirk in T7 when I arm a midi track. I must arm another track with an output device (unlike every tutorial I've looked at). Generally, not a big deal. I noticed in Waveform, I don't have to do this. This may be enough for me to spring for the $119 price (I doubt I'm eligible for the upgrade price, unless they consider the free T7).

I still intend on getting the Arturia Midi controller. It has pads, and transport controls, plus a massive library in their AnalogLab bundle they throw in. Whether I'll be able to map the pads to Traction is another story, but I know my options much better now.

Anyway, all is working. I'm really grateful for the assist. You have no idea.

Peter Widdicombe
KVRist
426 posts since 29 Aug, 2014

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Mon Jan 06, 2020 3:54 am

If you have the waveform.bak and waveform.settings files, it might be interesting to compare the two to see the settings. I would expect the dev's would find these useful... ? However, they're probably fairly occupied with NAMM at the moment.

Unfortunately that file doesn't work well with a normal text editor - looks like field separators are NUL bytes.

GuitarPlayerinNYC
KVRer
26 posts since 23 Dec, 2019

Re: Tracktion 7- Selecting MIDI In as input not an option

Post Mon Jan 06, 2020 12:09 pm

Peter Widdicombe wrote:
Mon Jan 06, 2020 3:54 am
If you have the waveform.bak and waveform.settings files, it might be interesting to compare the two to see the settings. I would expect the dev's would find these useful... ? However, they're probably fairly occupied with NAMM at the moment.

Unfortunately that file doesn't work well with a normal text editor - looks like field separators are NUL bytes.
I'm not an IT guy, but have 20 year's experience in screwing/fixing Win probs. The settings file can be opened with Notepad. It seems to contain all my- Settings...plus email address, name, etc (I thought file extensions were limited to 3 characters?). Anyway, this is what it looks like: "PROP5 lastPluginScanPath_VST C:\Program Files\Steinberg\VstPlugins;C:\Program Files\VstPlugins;C:\Users\GuitarGuy\AppData\Roaming\Tracktion 4\Tracktion Plugins lastPluginScanPath_VST3 C:\Program Files\Common Files\VST3;C:\Program Files\Toontrack\EZdrummer;C:\Users\GuitarGuy\AppData\Roaming\Tracktion 4\Tracktion Plugins applicationFile C:\Program Files\Tracktion 7\Tracktion64.exe applicationVersion 7.2.1 (Built: 1 August 2016) hasCheckedMackiePlugFolders 1 installedVersion 459265 cacheSizeSamples 288000 midiout_Microsoft GS Wavetable Synth <?xml version="1.0" encoding="UTF-8"?> <SETTINGS enabled="1" preDelay="0" sendTimecode="0" sendMidiClock="0" programNames="Custom"/> midiout_Line 6 Helix <?xml version="1.0" encoding="UTF-8"?> <SETTINGS enabled="1" preDelay="0" sendTimecode="0" sendMidiClock="0" programNames="Custom"/> midiout_USB Keystation 61es..." It goes on for hundreds of more lines. I didn't have my USB keyboard attached when I first installed T7. I wonder if the Settings file "locked" in my hardware somehow.

The mystery of the reappearing T4 folder has been solved. It wasn't truly uninstalled. I uninstalled it through the Win10 Control Panel, but I was mystified as to why a T4 folder even existed, after numerous uninstalls of T7 & Waveform. I opened up CC Cleaner, and went to its uninstall tab, and saw a program simply called "Traction"- no number designation, and I also saw T7 and Waveform. So I drilled down to that folder using Explorer, found an "unin.exe" file (what could go wrong? haha), but set a restore point, double-clicked it, and poof, The T4 program and folder is now gone.

One big thing I learned during this 3 week nightmare is, many controllers are made specifically to work with specific DAWS/Hosts, like Native Instruments Komplete Kontrol is most compatible with the Kontact line, or, the manufacturer has a partnership with a DAW maker, and "lite" versions are thrown in. If a manufacturer cares enough, they'll make a patch for incompatible hardware, and some will make patches to map specific input devices. Tracktion always make top 10 lists of DAWs, but maybe they're not big enough for midi manufacturers to cater to them.

Anyway, I'll still probably get the Arturia keyboard/controller. It's made for Ableton out of the box, and the AnalogLab software has over 6,000 instruments. There's plenty of free VSTs, and I'm tired of trying to make everything work smoothly together.

Return to “Tracktion”