Work in Garageband

Official support for: amplesound.net
Ample Sound
KVRAF
1693 posts since 28 Jun, 2012

Post Fri Mar 13, 2015 10:51 pm

Working with Garageband X needs a little and simple extra work. Many 3rd party plugin software suffer from this.

There is a workaround for this Garageband X specific issue. The reason is GarageBand is now sandboxed so it has a copy of our setting file inside its directory. Logic still works in a traditional way, so no worries on Logic.

In order to make things work, please do the manual work as the following.

Open Terminal app, you can find it in Applications/Utilities folder.

Please open a Terminal and type 4 commands as below:
1. cd ~/Library/Containers/com.apple.garageband10/Data/Library/Application\ Support/
2. mkdir Ample\ Sound
3. sudo chmod -R 777 Ample\ Sound
4. cp ~/Library/Application\ Support/Ample\ Sound/* Ample\ Sound/.

Please be aware of the output after you input the commands, and make screenshots for the error&warning messages if there is any.

Jie Chen[Ample Sound]
KVRian
657 posts since 14 Sep, 2013 from Ample Sound

Post Wed Jul 06, 2016 6:51 am

The script is here for download. You need to unzip it first.
You do not have the required permissions to view the files attached to this post.
Last edited by Jie Chen[Ample Sound] on Sun Feb 19, 2017 11:11 pm, edited 2 times in total.

marksmusicaustralia
KVRer
21 posts since 15 Jul, 2013 from Perth, Australia

Post Sun Jan 29, 2017 3:07 am

No success. Still getting the missing samples error in GarageBand 10.1.5 after using Terminal.
You do not have the required permissions to view the files attached to this post.

Jie Chen[Ample Sound]
KVRian
657 posts since 14 Sep, 2013 from Ample Sound

Post Mon Jan 30, 2017 12:37 am

Please contact service@amplesound.net and we can help you remotely.

jondl_2000
KVRist
188 posts since 5 May, 2006

Post Mon Jan 01, 2018 4:25 pm

I'd experienced the identical issue here, but your fix worked for me. APC now works in GB, but it does not allow for the selection of presets as it does in other hosts (Live, Logic 9.)
"All persons living or dead are purely coincidental." - Vonnegut

studentojazzkeys
KVRer
1 posts since 17 Jan, 2018

Post Tue Jan 16, 2018 5:08 pm

Slightly different issue...
GarageBand unexpectedly quit while trying to use the Audio Unit “Ample Bass Upright II” by “Ample Sound”.
This plug-in may require an update.


I ran the script but it thew a path error until I created an Ample Sound folder in the application support folder, then the script adds a ? folder with plist and xml files.

Any Ideas?

Ample Sound
KVRAF

Topic Starter

1693 posts since 28 Jun, 2012

Post Wed Jan 17, 2018 7:06 am

Please follow these 3 steps:

1. Make sure you have three ".plist" files in "~/Library/Application Support/Ample Sound" for each product.
2. Create a folder called "Ample Sound" in "~/Library/Containers/com.apple.garageband10/Data/Library/Application Support/" (if it is not already existing), then copy the ".plist" files from step 1 to this "Ample Sound" folder.
3. Enter the command "sudo chmod -R 777 ~/Library/Containers/com.apple.garageband10/Data/Library/Application\ Support/Ample\ Sound" (just copy the whole line without quote mark) in Terminal.
(To quickly go into the folders above, just click "Go - Go to Folder" from top of the screen when in Finder, then type the folder address without the quote mark)

Then restart GarageBand and set the correct Instrument Path.

Please let us know how it goes.

geniedumal
KVRer
1 posts since 15 Apr, 2018

Post Wed Apr 18, 2018 8:01 pm

Thank you for the instructions! I managed to get the AGTC II working with Garageband.

blackhuman
KVRer
1 posts since 23 Jul, 2018

Post Sun Jul 22, 2018 7:05 pm

AUTO-ADMIN: Non-MP3, WAV, OGG, SoundCloud, YouTube, Vimeo, Twitter and Facebook links in this post have been protected automatically. Once the member reaches 5 posts the links will function as normal.
As others App does, which could create a soft link to "Ample Sound" folder instead of copy all the files to Garageband Data folder.
Just do things like this:

Code: Select all (#)

cd "~/Library/Containers/com.apple.garageband10/Data/Library/Application Support"
ln -s "../../../../../Application Support/Ample Sound" "Ample Sound"
(Above command can be run on the "Terminal" App)
I use quote in the command line because there is a space in "Application Support" folder name, which will make command line confuse if I do not use quote to quote them, also as "Ample Sound".

 

pjonesdotca
KVRer
1 posts since 28 Oct, 2018

Post Sun Oct 28, 2018 5:49 pm

None of these options work for 10.3.1

Shadowlink
KVRer
1 posts since 23 Feb, 2019

Post Sat Feb 23, 2019 11:43 am

Hello,
I am working with Garageband Version 10.3.2. Unfortunatly when I start the Ample Guitar II Lite plugin, I get the error message that the samples couldn't be loaded and I have to set the correct Instrument Path to the Samples. I installed the Ample Sound Library under /users/shared (The default location). The plugin is still not working and not playing any sound. When I run the script which is provided in the second post of this topic I get the error message that there is no such file or directory.
The strange thing is that AS-Host works just fine. Is there anything I have to setup in order to make this plugin work with Garageband?

When I open the settings in the plugin window I see Instrument Path: FileNotFound. I click on it and change it to /Users/Shared/AMple Sound/

If i leave the settings now and reenter them the path I just set is gone.
Thank you for your help in advance!

Best Regards!

jimhenleymusic
KVRer
2 posts since 1 Apr, 2019

Post Mon Apr 01, 2019 5:31 pm

I have a different GarageBand issue. I can add a software instrument track to an existing project and load AGM III, no problem. No error messages. I can hear sounds from the plug-in. BUT - I click record in GB, then the Play button in the Strummer. I can hear sounds from the plug-in. However, when I stop the recording and turn off the strumming engine, nothing has actually been recorded. I tried the main menu just for comparison purposes: no luck.

I also started a new project just to cover all the bases. I added a software instrument track and loaded AGM III; again no problem. Here, GB showed its little software keyboard (the one tied to the laptop keyboard. If I "played" the software keyboard with the mouse, it recorded as a MIDI track. But once again, the Strummer produced no recorded output.

The Strummer and the Riffer are why I bought my AmpleSound plugins (AGM III, AGF, AGTF, AGP). How do I make them record?

Michael AD
KVRer
13 posts since 10 Sep, 2017

Post Tue Apr 02, 2019 4:58 am

Do you have MIDI OUT turned on in AGM III's preferences?

jimhenleymusic
KVRer
2 posts since 1 Apr, 2019

Post Sun Apr 21, 2019 5:40 pm

Michael AD wrote:
Tue Apr 02, 2019 4:58 am
Do you have MIDI OUT turned on in AGM III's preferences?
Thanks. I did figure this one out with some help from the Facebook support folks. I've been able to both drag strum patterns to the grid and play them through my MIDI keyboard.


Jim

Macklehat
KVRer
1 posts since 10 May, 2019

Post Fri May 10, 2019 12:49 pm

What to do when the Terminal app ignores the keystrokes when I type my password...? Never mind. I've recently learned that despite the TERMINAL not displaying your keystrokes, they are in fact being registered. So just type slowly and carefully and hit enter. Then I saw a notice within TERMINAL that a directory of some sort didn't exist. It looked familiar. I saw a post about it above. The post mentioned a need to add a folder in a certain directory. (your apple computer name)/Library/com.apple.garageband10/Data/Application Support/Ample Sound. So I traced this out and sure enough, there was no Ample Sound folder in this folder. There was, however, a folder with no name, and it had Ample Sound related files in it. So I renamed this no-name folder, opened Garageband, and viola'. All fixed!

Return to “Ample Sound”