Bitwig Studio 2.1 has been released!

Official support for: bitwig.com
User avatar
dom@bitwig
KVRian
Topic Starter
912 posts since 1 Nov, 2012 from Berlin

Post Mon May 15, 2017 7:51 am

Hi everybody!

Bitwig Studio 2.1 has been released and can be downloaded from our website:
https://www.bitwig.com/en/download.html


Changes in Bitwig Studio 2.1

NEW Add quantize to Math modulator.
NEW Java API for development of custom control surface drivers.
NEW MIDI slave support for transport sync.
NEW AMP Device.
NEW APC40 MKII script (rewritten in Java).
NEW New controller scripts for Nektar Technology products: LX25+, LX49+ and LX61+ .
FIXED MIDI Song Select sends improperly formatted messages.
FIXED Crash sometimes when closing the popup browser with a control surface connected.
FIXED In drum edit mode, the pen tool deletes the wrong notes.
FIXED Keylab 49 controller crashes when switching parameter pages.
FIXED Crash when dropping device in device chain.
FIXED Differences in Transient Detection between 44,1 and 96khz files.
FIXED Bad performance when scrolling through file browser for files that are on a network.
FIXED Unsupported format for WASAPI on Windows 7/8.1 if no sample-rate was selected.
FIXED Behavior / Bounce bit depth setting has no effect.
FIXED "Open containing folder" shown as "action.open_containing_folder.name".
FIXED MIDI Program Change might loose the note if it happens at the same time as the program change.
FIXED Halion 6 VST2 version does not work in Bitwig Studio 2 on windows.
FIXED Drag and drop does not work with Spectrasonics Stylus RMX on windows.
FIXED Akai MPK49 script crashes when pressing Shift and Play.
FIXED Many notes playing polysynth voices with long release time crash audio engine.
FIXED ASIO: Turning off the HW FX power button causes odd feedback behavior/noise.
FIXED Bouncing files causes a "Missing Files" notification.
FIXED Halion VST3 plugin does not remember its window size on macOS.
FIXED Crash when using scroll wheel in Zynaptic plugins on macOS.
FIXED Content of 32-bit VST plugin window may loose relation to parent window when switching to another application on macOS.
FIXED Incorrect vst2 channel interpretation for plugins which do not implement effGetOutputProperties.
FIXED Range of indexed controls was too big.
FIXED Fix some devices crash on old Windows systems.
FIXED Control Surface API: ClipLauncherSlot.isStopQueued().get() reports true event if this slot is not playing.
FIXED Play stop marker on raw audio events not draggable when being zoomed in.
FIXED Not possible to create a smart collection in the multi samples tab.
FIXED Memory leaks when painting automation points.
FIXED Crash when nudging selected automation events after changing selection.
FIXED Crash when deleting beat marker by double-clicking on it in some cases.
FIXED Hiding and showing the layered editor sometimes results in the window being resized to an enormous size and showing distorted graphics.
FIXED Drag-copying notes using time selection tool in clip launcher note editor does not repaint the drop area correctly.
FIXED Crash when opening old projects in some cases.
FIXED Sometimes automation points jump to different value when adjusting value via arrow keys.
FIXED Different MTC framrates don't have any effect.
FIXED In drum editor, dragging in the background always erases notes independent of the selected tool.
FIXED On some windows machines the icons never show up due to trying to load Java assistive technologies.
FIXED Note end might incorrectly show the masked-by-clip indicator when entering notes on triplet grid.
FIXED Transport.isAutomationOverrideActive() does not notify callbacks when it changes.
FIXED Controller API: Cursor.selectFirst/Last not working in some situations.
FIXED Crash when copying integer value automation to clipboard and clicking in another integer value automation lane.
FIXED Midi messages could be received before a controller has loaded its preferences.
FIXED MIDI Program Change: fix PDC in the chain.
FIXED Potential engine crash on macOS when changing sample rate or buffer size on slow hardware devices.
FIXED Crash when adjusting value of two equal-timed automation events via inspector.
FIXED Dragging the DSP performance graph window to another display makes it disappear.
FIXED Potential crash when copying data to the clipboard on macOS.
FIXED Crash when pinning device cursor for a control surface in the IO panel.
FIXED iZotope Iris VST2 plugin window content looks shifted after resizing and then re-opening window.
FIXED Launcher audio clip plays silence if previously played clip ended with a fade out on a contained event while then next clip starts inside the events and both events have identical settings and refer to the same sample.
FIXED Possible to get the automation editor to lose the panel with the free-run settings & co.
FIXED Adding devices with plugin latency to the FB FX of delay 4 breaks PDC graph.
FIXED Controller API: not possible to receive notes on multiple inputs with different masks.
FIXED Eraser skips over notes when moving fast.
FIXED Cakewalk Z3Ta2 instant crash with VST3.
FIXED MIDI Clock slave was too slow to catch up.
FIXED Potential crash when opening old projects.
FIXED When using clock slave and the tempo goes jitters around 100 BPM the size of the toolbar also jitters.
FIXED Raw audio events might not get played for the expected duration when loading old projects.
FIXED MIDI Clock Offset now use the same direction as Audio Recording Offset: positive values means earlier.
FIXED MTC framerate is not initialized properly on document load.
FIXED Midi CC device sends unwanted messages when scrolling through the CCs.
FIXED Transposing multiple selected notes using keyboard shortcuts cuts existing notes when "passing through".
FIXED ASIO: audio device is not properly restarted when the buffer size is changed via the ASIO configuration panel.
FIXED VST3 plugin states were saved with fxb extension instead of vstpreset.
FIXED Note Latch: toggle and velocity mode do not work properly.
FIXED Crash when erasing notes in drum editor.
FIXED Changing play offset for unlooped clips in inspector creates additional overlapping clips.
FIXED Step modulated DC offset does go to sleep when not being in focus.
FIXED Crash when trying to adjust fades on mixed selection of clips and meta clips.
FIXED Editing MIDI CC device knobs, requires to remove the CC prefix.
FIXED Polysynth: there is no beating with unison = 2, and in this case unison act as a DC Offset.
FIXED Selecting effect tracks from right to left using shift modifier and dragging to main track area can crash Bitwig Studio.
FIXED Deleting time range in raw audio event does not work correctly.
FIXED Under certain circumstances an extra note will be played outside clip boundaries.
FIXED Controller API: Parameter.name() not updated for parameters that are not remote controls.
FIXED ASIO didn't work with Realtek driver when using automatic sample-rate.
FIXED When drawing automation with pencil tool while being zoomed-in very far into the timeline, the resulting events get thinned too much on mouse up.
FIXED Too much smoothing on note expressions.
FIXED Scrollbar in midi learn section block the delete button for mappings.
FIXED Value of automation point still shown when switching to another application.
FIXED VST3 window resizable flag is interpreted incorrectly on macOS.
FIXED Show presets for legacy devices by default.
FIXED Spectrum Analyzer takes a lot of time to initialize on Windows.
FIXED Popup notification for a remote control shows the name of the target not the renamed remote control when adjusting from a controller.
FIXED Engine crash when scanning audio devices that don?t report manufacturer metadata on macOS.
FIXED Regression on macOS in alpha-2: some VST-2 plugins with resizable window have incorrect size after opening the second time.
FIXED Regression: VST3 state wasn't stored correctly.
FIXED MTC sends invalid messages.
IMPROVED Add a velocity knob to the note sidechain.
IMPROVED Added Select All action to edit menu.
IMPROVED Better erase tool in note editor.
IMPROVED When trying to adjust the value of automation events further than the limits of the value range via arrow keys, it takes the same amount of steps to move it back.
IMPROVED Chain device can now output notes.
IMPROVED Improved workflow for tracks which are routed to a note/MIDI destination (mute/solo/meters).
IMPROVED Note Latch Device not working properly in several modes after preset reload or engine restart.
IMPROVED Primary device for a controller will automatically select first instrument if there is one otherwise the first device.
IMPROVED PDC: Monitoring latency less influenced by other tracks.
IMPROVED Allow to paste events from the clipboard over selected events.
IMPROVED Show a notification if we get an unbalanced PDC graph with a submit action that sends the PDC file in the bug report.
IMPROVED Configure the MIDI Clock offset in milliseconds.
IMPROVED MIDI Clock Slave: stabilize the tempo variations.
IMPROVED Show playback follow button in each timeline editor panel (bottom right).

ejgallego
KVRist
300 posts since 9 Mar, 2017

Post Mon May 15, 2017 8:13 am

Fantastic, thanks folks! Running smoothly on my Ubuntu 16.10 so far.

User avatar
turbo_kev
KVRian
582 posts since 18 Dec, 2014

Post Mon May 15, 2017 8:15 am

Hi

I have installed this update in DEMO mode
and the audio engine will not activate

it all worked ok in V2

if I load up v 1.3.16 everything works as normal
cheers
Kev
Last edited by turbo_kev on Mon May 15, 2017 8:22 am, edited 1 time in total.
BWS 4.2.3,Spark LE, V Collection 8. BS1 & BS PRO, KS & KS pro keylab 25, Axiom pro 49,Behringer UMC1820,LPP ProFx8 v2 Icon m+, KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 1TB NVMe.M2 msi x99a sli + NV GF Gt710, Matrix Brute Roland TR8S

abique
KVRian
800 posts since 26 May, 2013 from France, Sisteron

Post Mon May 15, 2017 8:19 am

turbo_kev wrote:I have installed this update in DEMO mode
and the audio engine will not activate

it all worked ok in V2
Even with an empty project?

User avatar
turbo_kev
KVRian
582 posts since 18 Dec, 2014

Post Mon May 15, 2017 8:23 am

yes even with a new empty project
BWS 4.2.3,Spark LE, V Collection 8. BS1 & BS PRO, KS & KS pro keylab 25, Axiom pro 49,Behringer UMC1820,LPP ProFx8 v2 Icon m+, KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 1TB NVMe.M2 msi x99a sli + NV GF Gt710, Matrix Brute Roland TR8S

User avatar
dom@bitwig
KVRian
Topic Starter
912 posts since 1 Nov, 2012 from Berlin

Post Mon May 15, 2017 8:29 am

The Focusrites often don't like the "auto" settings for sample rate and buffer size.
Be sure to set them up manually in Bitwig Studio. If this does not help, please get in touch with the support team!

Cheers,
Dom

sovietpop
KVRist
227 posts since 16 Apr, 2004

Post Mon May 15, 2017 8:35 am

Thanks for the update.
Thats quite a long list of bugfix nice :) :tu:

User avatar
turbo_kev
KVRian
582 posts since 18 Dec, 2014

Post Mon May 15, 2017 8:53 am

Cheers Dom

that cured the audio engine problem

but if I load in any of my old projects
I get a load of plug in is not installed errors

but if I create a new project and load the missing vst´s they all load in
so they must be installed
its mostly arturia plugins like spark mini v etc etc

can you sugest anything I can try
BWS 4.2.3,Spark LE, V Collection 8. BS1 & BS PRO, KS & KS pro keylab 25, Axiom pro 49,Behringer UMC1820,LPP ProFx8 v2 Icon m+, KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 1TB NVMe.M2 msi x99a sli + NV GF Gt710, Matrix Brute Roland TR8S

User avatar
pdxindy
KVRAF
21266 posts since 3 Feb, 2005 from in the wilds

Post Mon May 15, 2017 9:27 am

Thanks for the 2.1 update!! I'm sure lots of hours of work went into it...

maschinelf
KVRian
880 posts since 3 Sep, 2011

Post Mon May 15, 2017 9:31 am

Awesome!

User avatar
llze
KVRAF
4463 posts since 21 Jan, 2008 from oO

Post Mon May 15, 2017 10:25 am

turbo_kev wrote:Cheers Dom

that cured the audio engine problem

but if I load in any of my old projects
I get a load of plug in is not installed errors

but if I create a new project and load the missing vst´s they all load in
so they must be installed
its mostly arturia plugins like spark mini v etc etc

can you sugest anything I can try
maybe just force the rescan of the plugins in the preferences? Or reselect the plugin path?
lucid.network | former user Suloo

craigtumps
KVRist
250 posts since 16 Jul, 2014

Post Mon May 15, 2017 10:46 am

**Update** This is ok now, problem was with KarmaFX EQ plugin. If anyone is having trouble try and disable it.


Im having real big trouble after installing 2.1. All projects glitching out like crazy, cant play them even with latency up to over 1000 samples. Totally unplayable.

Used to run like butter before. Is there any way to rollback without uninstalling and losing all my settings?

Im using ASIO on Steinberg UR44 interface :?
Last edited by craigtumps on Mon May 15, 2017 12:15 pm, edited 2 times in total.
http://Freshby6.com
Bitwig since 1.0

User avatar
pdxindy
KVRAF
21266 posts since 3 Feb, 2005 from in the wilds

Post Mon May 15, 2017 10:49 am

craigtumps wrote:Im having real big trouble after installing 2.1. All projects glitching out like crazy, cant play them even with latency up to over 1000 samples. Used to run like butter before. Is there any way to rollback without uninstalling and losing all my settings?

Ah man really dont need this right now, trying to get some stuff ready for Friday.
You can keep both versions side by side... I always do that with new releases and betas...

craigtumps
KVRist
250 posts since 16 Jul, 2014

Post Mon May 15, 2017 10:56 am

I thought 2.1 wouldn't be such a major update to cause this much chaos. I should have waited a while. Literally dead in the water here :(
http://Freshby6.com
Bitwig since 1.0

abique
KVRian
800 posts since 26 May, 2013 from France, Sisteron

Post Mon May 15, 2017 11:03 am

craigtumps wrote:I thought 2.1 wouldn't be such a major update to cause this much chaos. I should have waited a while. Literally dead in the water here :(
Is it slower on every projects or just one?
Can you try to isolate elements which are introducing issues?

Return to “Bitwig”