Wusik EVE V5 Beta Testing

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
fmr
KVRAF
7835 posts since 16 Mar, 2003 from Porto - Portugal

Post Tue Oct 23, 2018 1:02 am

Ok, I just tested with 5 instances, and everything is working as expected. Each instance plays in its own channel. The loading is still too crude, IMO. Each time we click in the "Add New Instance", the GUI blinks, takes maybe one second, and then the list comes back - a little confusing and even frightening. I still think that a new panel on the left (as it was in WS7 and is also in Falcon and HALion, for example) is the way to go for this. I can accept the current solution as a temporary workaround, but you should definitely think in a better solution for the Multis.

MOREOVER: The CPU consumption is way too high. The indicator in VST Host shows 60% CPU for just 6 instances of Wusik EVE. It seems like the code could use some optimization. This is too much for what is, basically, a sample player. I get much less in Kontakt with a Multi of 16 channels fully loaded.
Fernando (FMR)

User avatar
fmr
KVRAF
7835 posts since 16 Mar, 2003 from Porto - Portugal

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 1:03 am

I will test the Multis in WS9 to see what kind of CPU consumption I get in it.

EDIT: The problem I reported for EVE Multis is also present in WS9. Only the first two instances play. Consumption is reported as 10% (which, considering that it's just for two instances, is too high). I will wait for the fix, to check with six instances.

I found no way to save Multis. Changing between instances within a Multi is painfully slow.
Fernando (FMR)

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 4:00 am

To save a multi just save the preset, it will contain the multi data. I will update the Manuals soon with the informations.

And sorry if the current solution is not what you wanted, this is why I can offer right now. :oops:

Cheers

User avatar
fmr
KVRAF
7835 posts since 16 Mar, 2003 from Porto - Portugal

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 4:22 am

WilliamK wrote:
Tue Oct 23, 2018 4:00 am
And sorry if the current solution is not what you wanted, this is why I can offer right now. :oops:
IT IS what I wanted. :) I just think it's not the best way to do it :shrug:
Fernando (FMR)

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 4:50 am

Fair enough. :hug:

goldglob
KVRian
617 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 5:01 am

Great work William, the slots now always show instances, 'Add New Instance' is clear, 'Rename instance' is clear, and if a multi is loaded, saving it opens your 'Multi' folder...excellent.
Just to tidy things up, it would be good if the MIDI channels popup showed the names of all the instances (as fmr suggested), and if the heading was 'Edit Instance MIDI channels'. The word 'layers' here invites confusion with the four layers we already have within each instance.
Actually, if the heading just said 'Edit Instance MIDI channels' you wouldn't need the names, just have the boxes labelled 1, 2, 3...etc (if that's easier), but not Multi Preset 2, 3....etc (because they're instances, not Multis).
Now you did say 'keep pushing me' so just a reminder that the 'Add Older Wusik Station Data' thing doesn't work. As discussed previously there probably needs to be a re-structuring of the whole soundsets thing, and I can see the complexity of it....different users have different combinations of products, a user might just have say Wusik One with a core library but another user with say Wusik One AND WusikStation doesn't want duplicates taking up hard drive space...arhhugg!? How to do it elegantly?

User avatar
fmr
KVRAF
7835 posts since 16 Mar, 2003 from Porto - Portugal

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 5:25 am

goldglob wrote:
Tue Oct 23, 2018 5:01 am
Now you did say 'keep pushing me' so just a reminder that the 'Add Older Wusik Station Data' thing doesn't work. As discussed previously there probably needs to be a re-structuring of the whole soundsets thing, and I can see the complexity of it....different users have different combinations of products, a user might just have say Wusik One with a core library but another user with say Wusik One AND WusikStation doesn't want duplicates taking up hard drive space...arhhugg!? How to do it elegantly?
I think William mentioned he is thinking about a Shared Resources folder that would host all the Soundsets. IMO that's the best solution. All products would point to the same folder and would pick the content that's relevant to them.
Fernando (FMR)

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 6:16 am

Guys, a question. Is "Edit All Instance's MIDI Channels" or "Edit All Instances MIDI Channels" ?

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 6:17 am

As for the new Shared SoundSets folder, I will work on this ASAP. I just need to orchestrate this very carefully as I need to do on all products at once. :cool: I will also need to create a guide on how to merge the stuff you already own, for those who are not familiar with file systems and stuff like that. ;-)

Cheers, WilliamK

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 6:24 am

Oct 23 2018 - V5.0.0 BETA 38

- Improved the Multi-Preset code.
- Optimized the code by removing stuff from the engine that are not used by EVE. This should reduce a bit CPU usage compared to the other products.

goldglob
KVRian
617 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 6:34 am

WilliamK wrote:
Tue Oct 23, 2018 6:16 am
Guys, a question. Is "Edit All Instance's MIDI Channels" or "Edit All Instances MIDI Channels" ?
Ha Ha, I was wondering the same thing when I suggested it.
Strictly speaking I'd say "Edit All Instances' MIDI Channels" (the apostrophe after the s).
Or you could say "Edit MIDI Channels of all instances" or "Assign MIDI Channels to instances".

User avatar
WilliamK
KVRAF
4000 posts since 12 Jun, 2001 from Wusik Dot Com

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 6:41 am

:hihi: Ok, I will use "Edit MIDI Channels of all instances", easier to write. :hug:

I will change the code in a minute.

Cheers, WilliamK

Cakreshvara
KVRist
81 posts since 4 Sep, 2006

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 3:43 pm

The preset vs multi issues, what will load and what will not load are way beyond my vegetable understanding. Still got to get a hold on the concept. Glad that greater minds than mine are on top of the reporting. Think that a preset should load all associated sound files. The AOS collection does this, but the Mellotronix as an example comes up with only missing files. Sorta understand that the fix for this is easy but the time involved to correct the presets is way intensive.

CPU drain is a concern. Noticed this several betas ago. Simple loading of files should not take the program down to crackles. Something happening here not quite right yet as far as the resource requirements.

John K

goldglob
KVRian
617 posts since 10 Jan, 2007 from London

Re: Wusik EVE V5 Beta Testing

Post Tue Oct 23, 2018 5:19 pm

Cakreshvara wrote:
Tue Oct 23, 2018 3:43 pm
The preset vs multi issues, what will load and what will not load are way beyond my vegetable understanding. Still got to get a hold on the concept. Glad that greater minds than mine are on top of the reporting. Think that a preset should load all associated sound files. The AOS collection does this, but the Mellotronix as an example comes up with only missing files. Sorta understand that the fix for this is easy but the time involved to correct the presets is way intensive.

CPU drain is a concern. Noticed this several betas ago. Simple loading of files should not take the program down to crackles. Something happening here not quite right yet as far as the resource requirements.

John K
Re presets vs multi.
Consider EVE V5 before all this multi stuff. A preset loaded a bunch of settings and sounds, and the GUI with all it's knobs and waveform boxes reflected that preset. Now imagine that you set up another instance of EVE on another track and dialed up another preset on it and had both instances playing simultaneously. This really is what multi presets do, except that now the two instances (presets) are combined into the one (multi). You can hear both but to edit and see the GUI of either you have to toggle between them by clicking on the respective instance slots.

Yes, presets should load associated sound files. The AOS sounds came with the EVE V5 download, they were already in EVE's soundset folder and the EVE engine already knew where to find them. But the presets made available later for testing ( Mellotronix etc) depend on the associated sounds being in place and EVE knowing where to find them...alas, this is not yet the case....all you can do for now to test the Mellotronix presets is to point EVE to the sounds required one by one...yes, tedious for now.

I haven't really tested the CPU thing properly but I'm not getting crackles etc.
I just compared EVE 5 and Kontakt in REAPER, each loaded with a single piano and no FX.
EVE uses slightly more CPU.
But if I record arm (thus disabling REAPER's anticipative FX processing) EVE uses perhaps twice the CPU of Kontakt.
Not scientific tests...just an impression.

User avatar
fmr
KVRAF
7835 posts since 16 Mar, 2003 from Porto - Portugal

Re: Wusik EVE V5 Beta Testing

Post Wed Oct 24, 2018 1:14 am

goldglob wrote:
Tue Oct 23, 2018 5:19 pm
.../... But the presets made available later for testing ( Mellotronix etc) depend on the associated sounds being in place and EVE knowing where to find them...alas, this is not yet the case....all you can do for now to test the Mellotronix presets is to point EVE to the sounds required one by one...yes, tedious for now.
You really don't need to do that. You just need to copy the folder Mellotronix from e.g. the WusikStation Data/Soundets into the EVE Data/Soundsets folder. From then on, all the Mellotronix presets will load as supposed. Same applies to ElektroWusik and HQ Piano Sets.

When William manages to create the mentioned Shared Soundsets folder, all Wusik instruments will point to the same folder, so, thill not be needed anymore (hopefully).
Fernando (FMR)

Return to “Instruments”