Vengeance Producer Suite - AVENGER - free 1.4.9 update with new features

VST, AU, AAX, etc. plug-in Virtual Instruments discussion
User avatar
msvs
KVRian
1397 posts since 18 Apr, 2011

Post Mon Apr 22, 2019 10:30 am

cant imagine this has something to do with Avenger... :(

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:00 pm

msvs wrote:
Mon Apr 22, 2019 10:30 am
cant imagine this has something to do with Avenger... :(
That's a start... Confirmation that this is not normal behaviour. Thank you. The image I shared a few post back is Avenger shown in Volume Shaper, it's a Psy Trance preset with drums. Avenger is being triggered by midi exactly on beat but it's output is considerably delayed. This isn't the same as untended swing on Nexus (sample accuracy issue), the delay stays at a fixed amount, unique to each preset. It can't be Volume Shaper, my other synths and audio show in the same instance of it as on beat, in time. I can't think why VS, would make only the Avenger synth delayed.

Something related to Cubase and Avenger is causing this delay... It seems to be bigger for Heavier presets. I've been through all the Cubase setting and nothing is fixing it. I really am stuck as to why I have this issue or how I can fix it.

Can people try this for themselves? Please. I was really loving the Hands up lives pack but I can't progress until I've resolved this.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

User avatar
msvs
KVRian
1397 posts since 18 Apr, 2011

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:07 pm

you should check if in Avenger a preset uses a limiter or compressor, because they need a lookahead they have few ms latency. Turn them off to test. On the other hand, your daw should compensate.

User avatar
DJErmac
KVRian
816 posts since 25 Apr, 2009 from France

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:13 pm

mitchiemasha wrote:
Mon Apr 22, 2019 1:00 pm
Can people try this for themselves? Please. I was really loving the Hands up lives pack but I can't progress until I've resolved this.
I use Cubase 10 (Windows 8.1 64), and Avenger is absolutely not delayed...

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:14 pm

msvs wrote:
Mon Apr 22, 2019 1:07 pm
you should check if in Avenger a preset uses a limiter or compressor, because they need a lookahead they have few ms latency. Turn them off to test. On the other hand, your daw should compensate.
Yes... That sounds about right. I remember that preset had a limiter on it. I'll check now.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:18 pm

DJErmac wrote:
Mon Apr 22, 2019 1:13 pm
I use Cubase 10 (Windows 8.1 64), and Avenger is absolutely not delayed...
Thank you for you acknowledgement, I really appreciate it. Have you checked? It wasn't until I was deep into a session that I realised the issue. Under normal light usage I wouldn't of noticed.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:20 pm

Turning off the limiter does indeed reduce the delay, considerably but not all of it. Something is definitely wrong with auto delay compensation in my Cubase.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

User avatar
DJErmac
KVRian
816 posts since 25 Apr, 2009 from France

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:33 pm

mitchiemasha wrote:
Mon Apr 22, 2019 1:18 pm
DJErmac wrote:
Mon Apr 22, 2019 1:13 pm
I use Cubase 10 (Windows 8.1 64), and Avenger is absolutely not delayed...
Thank you for you acknowledgement, I really appreciate it. Have you checked? It wasn't until I was deep into a session that I realised the issue. Under normal light usage I wouldn't of noticed.
Well, I always use Avenger in all my sessions and never noticed any delay... if I encounter this bug, I will report it here.

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Mon Apr 22, 2019 1:54 pm

DJErmac wrote:
Mon Apr 22, 2019 1:33 pm
Well, I always use Avenger in all my sessions and never noticed any delay... if I encounter this bug, I will report it here.
I'd check it, it's not something that would stick out lots. Only if you were using a heavy preset with the limiter and separate lighter presets would it be an issue, things wouldn't be lined up tightly. If Cubase isn't calculating delay correctly, I'd say that's a serious issue.

I've activated the new Cubase feature, "Channel Latency" in "set up window layout" in the mixer and Avenger isn't showing any compensation at all. If I load something heavy like Ozone, Cubase will display the compensation.

I've also noticed an issue with Izotope Neutron Dynamic EQ when Sidechained, this too isn't reporting any correction and isn't pumping correctly, in time... But i'll take that up with them.

Thank you again. I really appreciate your communication.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

sircuit
KVRian
641 posts since 15 Jul, 2016

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 3:03 am

msvs wrote:
Mon Apr 22, 2019 1:07 pm
you should check if in Avenger a preset uses a limiter or compressor, because they need a lookahead they have few ms latency. Turn them off to test. On the other hand, your daw should compensate.
In macOS neither Logic (AU) neither Ableton Live (VST) compensate when using compressor/limiter/mb limiter.

Thavma
KVRist
236 posts since 29 Apr, 2014

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 3:19 am

Cubase is the master of PDC , should be working fine, maybe investigate on that?

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 4:37 am

sircuit wrote:
Tue Apr 23, 2019 3:03 am
In macOS neither Logic (AU) neither Ableton Live (VST) compensate when using compressor/limiter/mb limiter.
Interesting.
Thavma wrote:
Tue Apr 23, 2019 3:19 am
Cubase is the master of PDC , should be working fine, maybe investigate on that?
PDC, that's new term to me, I'll check that out. Thank you.

Edit: Ok... the P stands for Plugin. I guessed the DC was Delay Compensation, just not the P. I just didn't know it was referred to as PDC. Thank you.

PDC isn't working properly. Now i need to find out if it's CUBASE or AVENGER or both. Sidechain PDC isn't working properly in some cases either. No one on Steinbergs forum seems to notice or care. I guess they don't get that technical.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

jbraner
KVRian
918 posts since 8 Jan, 2003

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 5:49 am

It's definitely a PDC issue.
Either Cubase isn't doing it (delay compensation) or Avenger isn't reporting it correctly.

PDC means the DAW delays everything by the amount that the plugins report - so that all your audio plays together (or in your case, lines up). If your audio doesn't line up - that means Cubase didn't compensate for the delay (latency) which has to exist when you record through a plugin (Avenger).

Does that make sense? It doesn't help you - but maybe it helps show you where to look (?)

mitchiemasha
KVRist
202 posts since 15 Aug, 2011 from teesside

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 6:28 am

jbraner wrote:
Tue Apr 23, 2019 5:49 am
It's definitely a PDC issue.
Either Cubase isn't doing it (delay compensation) or Avenger isn't reporting it correctly.

PDC means the DAW delays everything by the amount that the plugins report - so that all your audio plays together (or in your case, lines up). If your audio doesn't line up - that means Cubase didn't compensate for the delay (latency) which has to exist when you record through a plugin (Avenger).

Does that make sense? It doesn't help you - but maybe it helps show you where to look (?)
Yes totally... I come from hardware origins, timing was a constant nightmare, syncing everything was a challenge. I was aware of Delay Compensation, but not that it was referred to as PDC. When we open the new latency display feature in Cubase 10 mixer, Avenger isn't shown to be reporting any delay to be compensated.
MSI z390, i7 9700k, Noctua NH-U9S, NVME 970 Pro, 16GB 3000C15, BeQuiet S11, W10, Cubase 10.
Virus TI (INTERGRATED), Yamaha CS2x (Custom Mapped), JV1080 (Dance Card), Nord 2, Novation KS & Stations.

djmce
KVRer
8 posts since 12 Oct, 2018

Re: Vengeance Producer Suite - AVENGER - free 1.4.0 update with new features

Post Tue Apr 23, 2019 12:19 pm

I can confirm this behavior. Windows 10 1803, Cubase 10.0.20, I9-9900K 32GB.
I took my most cpu consuming session and added another Avenger with the preset SQ BE Alive from Melodic EDM. Cubase Audio Utilization is at around 80%. I triggered the preset with drums and melody midi events in beat. Avenger shows around 15% CPU.
I soloed the Kick of the preset and it is constantly around 4ms behind the beat. The delay is visible at the VPS MiniChain V3 plugin as well.
I made similar tests with Maschine and GrooveAgent (midi triggered drum loops). No delay.

The Cubase Mixer shows accumulated latency of insert plugins only.
Hope this helps....

additional info. The other Avenger playing the piano chords (CPU up to 25%) is not delayed.
Cubase Pro 10.0.20 @ 64bit Windows 10 Home v1803 @ i9-9900K 32GB
https://www.youtube.com/channel/UCcLk3l ... gPCNegk5gw
https://soundcloud.com/dj-mce-1

Return to “Instruments”