Studio One... in my eyes it´s a bug, but...???

Plug-in hosts and other software applications discussion
Trancit
KVRAF
2285 posts since 27 Jul, 2004

Post Thu Jul 18, 2019 3:33 am

I am not sure if this was present before V4.5 but I don´t get really what´s up with this auto numbering of certain FX:

I happens with all Fabfilter plugs but not with DMG Audio ones...
It happens with all Melda plugs but not with Toneboosters ones...
It happens with Voxengo plugs but not with Image Line ones...

https://youtu.be/eEeRd4syb6g

I had a ticket on Presonus support, but I was told this wouldn´t be a bug and should be made as feature request... where I don´t agree with...

What I didn´t showed in the vid (was out of my head at this point in time):

If you do not insert new instances of i.e. Pro-Q3 and Melda plugs but copy an existing instance by drag n drop to a new track, it doesn´t auto number at all... only if you insert them via the browser or "+"

Does this bother you???
Would you call this a bug or a (unwished) feature???

daw.one
KVRist
85 posts since 16 Nov, 2016

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 5:38 am

Since the behavior is not consistent and the outcome depends on the method of operation, I would also classify this as a bug.

For instance when copying a troublesome insert (like the melda one) with CTRL+drag, the numbering is subsequent.
Even when copying an insert which was numbered wrong due to a previous duplicate, like e.g. MEqualizer 2 2, will be numbered correctly again when copied e.g. MEqualizer 3.

That being said. I think the behavior is correct that normally added inserts, so non duplicated or copied inserts remain their original plugin name. Basically the numbering tells us: "This instance is a duplicate/copy of that instance".

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 5:55 am

daw.one wrote:
Thu Jul 18, 2019 5:38 am
Since the behavior is not consistent and the outcome depends on the method of operation, I would also classify this as a bug.
Thx...
For instance when copying a troublesome insert (like the melda one) with CTRL+drag, the numbering is subsequent.
Even when copying an insert which was numbered wrong due to a previous duplicate, like e.g. MEqualizer 2 2, will be numbered correctly again when copied e.g. MEqualizer 3.

That being said. I think the behavior is correct that normally added inserts, so non duplicated or copied inserts remain their original plugin name. Basically the numbering tells us: "This instance is a duplicate/copy of that instance".
Tbh, I don´t see any need for numbering here as these instances are on different tracks...
If they would be on the same track... ok... but on seperate tracks???

I think the complete auto numbering for duplicated/inserted instances is simply wrong...
Presonus basically has thought the same as none of their own plugins get numbered as many 3rd party ones...
... Basically the numbering tells us: "This instance is a duplicate/copy of that instance".
No, it doesn´t as copied instances from track to track by drag n drop doesn´t auto number...

daw.one
KVRist
85 posts since 16 Nov, 2016

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 6:01 am

Trancit wrote:
Thu Jul 18, 2019 5:55 am
daw.one wrote:
Thu Jul 18, 2019 5:38 am
... Basically the numbering tells us: "This instance is a duplicate/copy of that instance".
No, it doesn´t as copied instances from track to track by drag n drop doesn´t auto number...
You are right.
Maybe the correct question to ask support is what the purpose of the numbering is. :wink:

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 6:24 am

What me wonders, is that from that many views it doesn´t seem interesting for them all... :(

Blaster
KVRist
370 posts since 22 Apr, 2004 from Ireland

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 6:45 am

Is this a vst2 / vst3 thing?

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 6:52 am

Blaster wrote:
Thu Jul 18, 2019 6:45 am
Is this a vst2 / vst3 thing?
No, it happens with either...

User avatar
gentleclockdivider
KVRAF
2153 posts since 22 Mar, 2009 from gent

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 7:33 am

Just post it on the presonus studio one forum , with the you tube video >
It will probably be noticed by a studio one beta tester who will report it as a bug
Or you could create a ticket yourself
Eyeball exchanging
Soul calibrating ..frequencies

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 7:47 am

gentleclockdivider wrote:
Thu Jul 18, 2019 7:33 am
Just post it on the presonus studio one forum , with the you tube video >
It will probably be noticed by a studio one beta tester who will report it as a bug
Yes, perhaps a good idea...
Or you could create a ticket yourself
I wrote in the opening post:
...I had a ticket on Presonus support, but I was told this wouldn´t be a bug and should be made as feature request... where I don´t agree with...

DaveClark
KVRist
169 posts since 8 May, 2007

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 9:42 am

Hi Trancit,

Many, if not most, software companies define a "bug" as something that was unintended behavior on the part of the programmer(s). They do this despite the fact that some behaviors are seriously objectionable in the eyes of users. What Presonus appears to be telling you is that they never intended for that behavior to be anything specific, so your complaint is not technically a "bug" but a feature request, as far as they are concerned.

Presonus will probably not reclassify this, regardless of what you say, unless you can document that the intended behavior was something different than what is actually happening. You would have to look in the manual, talk to others in support, contact the developers (Good Luck on that one), etc.

Regards,
Dave Clark

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 10:20 am

DaveClark wrote:
Thu Jul 18, 2019 9:42 am
... What Presonus appears to be telling you is that they never intended for that behavior to be anything specific, so your complaint is not technically a "bug" but a feature request, as far as they are concerned.

...
Hmm, had to think a minute about this...
Don´t you think, this is a bit splitting hairs??

Their own plugins do not auto number regardless of what you do... this is in my eyes the desired behaviour... otherwise they would behave different imho...

If now a few 3rd party plugins behave different (only in S1, so a fault of S1) is for me definetely a aberration from the desired behaviour... this is for me a bug then... just because it´s not all 3rd party plugins... just these from a few developers...

If the plugins from a handful developers stop making noise in S1 (and only in S1) while the plugins from other developers do, would this be a bug for you??

User avatar
Benedict
KVRAF
3007 posts since 5 Mar, 2004 from Gold Coast Australia

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 1:41 pm

Bug/Feature request is a fairly narrow line here methinks. Perhaps you are falling on the Bug side simply because you don't like it.

If this was audio rendering with a random DC offset so it all clipped, that would be a serious Bug. Adjusting the logic behind printed numbers is not quite at the same level seeing it doesn't damage core behavior - no matter how much happier 51% of users may be with the change.

They didn't tell you to go away. Re-present as a feature request as suggested.

:-)

Trancit
KVRAF
2285 posts since 27 Jul, 2004

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 1:49 pm

Benedict wrote:
Thu Jul 18, 2019 1:41 pm
... Re-present as a feature request as suggested.

:-)
A bugfix would be more likely to happen than a feature request...
But at the very end you´re right... it´s not the end of the world 8)

User avatar
Benedict
KVRAF
3007 posts since 5 Mar, 2004 from Gold Coast Australia

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 2:02 pm

Trancit wrote:
Thu Jul 18, 2019 1:49 pm
A bugfix would be more likely to happen than a feature request...
I understand, hence the tendency to go all hyper-nuclear-emotive

:-)

(my kids do this too in the hope they get their way in the thing they know isn't likely to happen - they don't like it when I train it out of them but in time they will understand)

THE INTRANCER
KVRian
1115 posts since 30 Dec, 2014

Re: Studio One... in my eyes it´s a bug, but...???

Post Thu Jul 18, 2019 2:26 pm

Tested this with Voxengo's GEQ effect plugin and yes it does as shown in the above video, initiates number duplication. The behaviour is the same from 4.5.2 down to version 2.6 of Studio One.

My guess is that the issue resides within the code of that of VST plugins themselves. Each VST has an ID reference which is recalled and what I suspect is that the plugin doesn't have an incremented instance reference code. So rather than keeping track of the number of existing instances created, they add an additional value. In other words, the code is missing the variable to be able to increment properly. I've not tested in other DAWs to confirm if the results are the same though... In any case, you're best to use the plugs that do behave because it's not an issue that's sitting on Presonus's doorstep to be able to do anything about. Contact the plugin developers instead.
THE INTRANCER-Digital 2D & 3D GUI / Music Artist - Orchestral Trance - Ambient - Film Scores | Soundcloud 27 | Soundclick 16 | Producing Music For 25+Years & Sound Monitoring FOH at UK Stadium/Festivals for Carl Cox, FatBoy Slim ect

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”