E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Configure and optimize you computer for Audio.
auron
KVRist
74 posts since 4 Nov, 2013 from Germany

Post Fri Mar 27, 2020 12:11 am

lestra wrote:
Wed Mar 25, 2020 2:02 am
Thank you so much for this solution. I have EMU 1820M soundcard and this works for me on Windows 10 64bit but there is one problem so far. When Windows started and soundcard loaded everything works but I get audio with some cracking noise and little bit of distortion. I listen on BayerDynamic DT 770 Pro headphones and I am sure there is noise and distortion. My workaround is like this: Go to PatcMix app/Sample rate settings and temporary switch from 48khz to 44,1khz. Result is there is no sound at all but when I switch back to 48khz and load preset of the patchmix again, audio become nice and clear, without any cracking noise or distortion.

Is this a known problem and is there better fix than mine?
I dont know if it is a known problem , besides that cracking noise (your mic preamp setting very high btw?), but that switching problem 48<->44.1 khz i had since windows 10 . Maybe this is related to 1820m and some mainboards and affects only the audiodock, where f.e. the 1010pci always shows a red dot in the patchmix left upper corner, the audiodock sometimes shows no red dot, seems the audiodock has a lost connection. But this happens only when i try to switch under windows to 44.1 khz. For me there is no need to switch to 44.1 khz under windows because every program works with 48 khz, even games are working with that . And for that reason i said, try to load a new 48khz patchmix session from the patchmix load menu, not a saved or personally created, if you get an error saying "Patchmix error - you do appear to have insufficient ...bla bla bla". A weird behavior sometimes occurs , i have to load a new 48 khz patchmix session twice (!), the first load sometimes gets ignored from the patchmix but the second does it, so it is very tricky to judge if it is working or not.

Another interesting thing i found out, you can extract the content of the Emu driver or Emu patchmix .exe files with 7zip file archiver and you can now look for certain dll's and additionally there is a driver uninstaller from creative, see that attached picture. Maybe this is of help to somebody.
You do not have the required permissions to view the files attached to this post.

lestra
KVRer
2 posts since 25 Mar, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Fri Mar 27, 2020 8:40 am

Last two days I am on 48khz factory session and there is no cracking noise problem at all. I love this soundcard from the first day I get it and now I love it even more. So happy now, Auron thanks for response nice infos you post.

Music1966
KVRer
2 posts since 28 Mar, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Sat Mar 28, 2020 3:28 am

Hey Guys,

I hope you're all keeping well and safe.

Wondering if anyone can help... I'm trying to install my 1820m with the BETA software that you provided on my Asus, Windows 10 Desktop. I removed any previous emu/creative drivers, to my knowledge and also removed the cards and restarted the computer. But when I go to do the first step and install the BETA file I get this message below:

"You have previously installed drivers without rebooting, please reboot".

Does anyone know how I can get past this so I can install the BETA? Would greatly appreciate it, its driving me mad and would love to get this box working!

Many Thanks,

Lin

greenalien
KVRer
3 posts since 2 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Thu Apr 02, 2020 6:05 am

I've just tried to install 1616 + Cardbus card on a laptop with Win10 v1909 32bit, but it doesn't work. Is the fix for 64bit only?

greenalien
KVRer
3 posts since 2 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Thu Apr 02, 2020 10:39 am

Update - updated Win10 to 64bit, completely new install. Followed all steps, script completed with no errors, all lines yellow, but still get code 12 error on E-mu wdm driver.

Music1966
KVRer
2 posts since 28 Mar, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Sat Apr 04, 2020 8:04 am

I managed to get mine to work following all the instructions but it took a few attempts..Possibly try going to a restore point and trying again?

andlil
KVRer
12 posts since 27 Mar, 2012 from Sweden

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Thu Apr 09, 2020 6:34 am

Sherwoodsound, thank you SOOOOOO MUCH for this post. It really saved my day. I know I was late installing Win10 update 1909, but when I finally did, I was icecold for fifteen minutes before I found this post, and successfully did the reinstall. I have 1820 with old-school PCI-card. have used it since about 2006. :hyper: :hihi: :clap: :clap:
Lil Borg

salvucce
KVRer
1 posts since 10 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Fri Apr 10, 2020 5:37 am

Hello sherwoodsound,

thank you sooo much too !!!
I can use my 1820m now again. After powershell EMU_Fix_Driver
Ihave to change the ctasio.dll to ctasio64.dll in the registry.

After that i got Emu Patchmix FX Effect error, but i changed my Inputs and created new channelstrips with Input Dock In 1L1R for the mic Input.... and it works....with Asio driver Yep!!!

Thank you Great man :tu: :hug:

Greeting from Cologne

vibesnrh
KVRer
4 posts since 12 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Sat Apr 11, 2020 6:35 pm

I just upgraded to Windows 10 from 7 and have followed these steps for my 1616 PCI. During the powershell commands, I keep getting this error:

Get-PnpDevice : No Win32_PnPEntity objects found with property 'Name' equal to 'E-MU E-DSP Audio Processor (WDM)'.
Verify the value of the property and retry.
At C:\temp\EMU_Driver_Fix.ps1:8 char:1
+ Get-PnpDevice -FriendlyName "E-MU E-DSP Audio Processor (WDM)" | Enab ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (E-MU E-DSP Audio Processor (WDM):String) [Get-PnpDevice], CimJobExcepti
on
+ FullyQualifiedErrorId : CmdletizationQuery_NotFound_Name,Get-PnpDevice

Then upon running PatchMix, it tells me "You don't appear to have EMU PCI or Cardbus Hardware in your system, or the drivers are incorrectly installed. Check your hardware or re-install drivers".

Does anyone have any advice? I'd love to continue with my 1616.

andlil
KVRer
12 posts since 27 Mar, 2012 from Sweden

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Sun Apr 12, 2020 8:52 am

Hello vibesnrh,
I had the same error during my upgrade, but luckily my interface worked anyhow. I think the commands at the beginning and end of the script are to disable the device during the copy of all the files, and then enable it again at the end of the script. Can you check that all the files were copied ok? Maybe your device is still disabled, check the Device Manager.
Lil Borg

vibesnrh
KVRer
4 posts since 12 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Sun Apr 12, 2020 4:50 pm

Hi andlil, I think all the files were copied over. But in Device Manager, Device status says "The drivers for this device are not installed (code 28). There are no compatible drivers." Pointing Device Manager to the temp folder holding all of these files does no good. What am I missing?

mocheez
KVRer
1 posts since 17 Jan, 2018

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Mon Apr 13, 2020 6:31 am

PC newbie here… How do I "Remove all current E-MU Drivers and PatchMix software", please?

andlil
KVRer
12 posts since 27 Mar, 2012 from Sweden

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Mon Apr 13, 2020 6:50 am

Hi vibesnrh, in the description there is a line about editing the script to fit the device name of the soundcard.
I uninstalled all the old EMU software first and then realised that I could not see the name anymore.

But as soon as I hade installed the driver, "EmuPMX_PCDrv_US_2_30_00_BETA", I could see the device name by using the device manager. My device name (as seen in Device Manager - E-MU E-DSP - Properties - Details - Device Description) is the same as in the script. I still got the error when running the script, but all files were correctly copied and the EMU device is working, also ASIO.
You probably should change the device name in the script, but I am not sure that will help you.
I think the most important thing is that you can see the device in the Device Manager already after installing the "EmuPMX_PCDrv_US_2_30_00_BETA" driver. If you do not, maybe you can try installing the drive in Safe mode.
Lil Borg

andlil
KVRer
12 posts since 27 Mar, 2012 from Sweden

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Mon Apr 13, 2020 6:54 am

Hi Mocheez, to remove apps and driver:
rightclick Win10-logo in lower left corner, select Settings, click Apps, there should be two entries: E-MU Audio Drivers and E-muPatchMix DSP, click once and select Uninstall.

Good luck.
Lil Borg

vibesnrh
KVRer
4 posts since 12 Apr, 2020

Re: E-MU 1616m, 1212m, 1820m, 0404 Audio Interface - Complete Windows 10 (1903 & Above) Installation Guide

Post Mon Apr 13, 2020 9:41 am

In Device Manager my card is just listed as "multimedia audio controller" under a tab called "other devices", with a problem sign on it. I changed the name in the script to "multimedia audio controller" and it ran without any errors. But the status in Device Manager hasn't changed and still when I try to fire up PatchMix, it tells me that I don't have a PCI or Cardbus installed.

Return to “Computer Setup and System Configuration”