Toneboosters Barricade v4

VST, AU, etc. plug-in Virtual Effects discussion
NeonNightflyer
KVRist
53 posts since 1 Sep, 2016

Post Wed Jun 03, 2020 4:25 am

trackbout wrote:
Tue Jun 02, 2020 9:40 pm
To everyone that's pointing out how annoying the gain reduction animation is with the pausing and shifting left, I pointed out the same thing to Mr. Breebaart last week via email and he said it's already been addressed. In the next update you'll have an option to choose either the current janky animation or a continuously scrolling animation.
Good to know. I've actually held off on the newest update because I can't stand the UI changes. It's one of my favourite plugins otherwise. The soft clipper is so good.

GRUMP
KVRist
443 posts since 11 Jun, 2019

Re: Toneboosters Barricade v4

Post Wed Jun 03, 2020 6:33 am

B3 CM is usually sufficient for me, B4 a Candidate.

I recommend to check out D16 Frontier (free!) anyway, it works different and has a whole little Bit more Pressure imO. D16 :tu:
Always on the Run ... :wheee:

jens
KVRAF
20066 posts since 12 Jul, 2003 from West Caprazumia

Re: Toneboosters Barricade v4

Post Wed Jun 03, 2020 7:11 am

mcnelson wrote:
Wed Jun 03, 2020 1:27 am
The Noodlist wrote:
Wed Jun 03, 2020 12:02 am
mcnelson wrote:
Tue Jun 02, 2020 10:47 pm
Was there ever a v3 > v4 upgrade path for Barricade?
I think it was €15 upgrade from v3 for a limited time, half price.
There might have also been a introductory offer.
jens wrote:
Wed Jun 03, 2020 12:20 am
I don't think the upgrades are time-limited. They send out e-mails. Search your inbox (and perhsps youe spam-folder) for the e-mail you used when purchasing V3. It might still be valid, but perhaps it isn't anymore because Toneboosters moved over to another shop in the meantime. But you can of course send them an e-mail.

Edit: I just checked and the Avangate links are indeed still valid.
I have receipts going back to 2009 when I bought Isone, and can't see anything. I suspect I didn't get an upgrade offer because I upgraded to v3 BusTools from owning Isone and FIX, so didn't have a dedicated Barricade licence?

I got upgrade offers (and used them) for V4 Reverb, EQ and Reelbus from owning TrackEssentials I guess - but nothing for Barricade.
Ah, yes, I was talking about direct V3 to V4 upgrades - and tbh I am not absolutely sure about Barricade at all since I (as I just realized) first purchased it as V4 apparently. I was assuming it was the same for Barricade as for the other V4 plugins that already existed as V3

User avatar
trackbout
KVRist
131 posts since 29 Apr, 2019

Re: Toneboosters Barricade v4

Post Wed Jun 03, 2020 7:28 am

NeonNightflyer wrote:
Wed Jun 03, 2020 4:25 am
Good to know. I've actually held off on the newest update because I can't stand the UI changes. It's one of my favourite plugins otherwise. The soft clipper is so good.
Ya a lot of the input models are gold, I use the "analog tape" and "mix console" models a bunch.

BerryLaCroix
KVRist
60 posts since 9 Apr, 2018

Re: Toneboosters Barricade v4

Post Wed Jun 03, 2020 1:45 pm

Mr. Spock wrote:
Tue Jun 02, 2020 8:02 am
Does anybody know why the gain reduction meter shows 2 different meters once you limit a bit more (first two independend L/R, then a wide one next to it)? I've also noticed that the GR meter of the compressor doesn't display a numeric readout.
It seems that this is only happening for AU in Ableton Live 10. I asked the dev and it's confirmed to be an Ableton Live 10 bug, instantiating multi-channel capable plugins with 9 channels even when running on a stereo track or bus. Hopefully the Ableton devs will resolve this asap.

User avatar
dangayle
KVRian
1185 posts since 30 Mar, 2014

Re: Toneboosters Barricade v4

Post Thu Jun 04, 2020 2:12 pm

BerryLaCroix wrote:
Wed Jun 03, 2020 1:45 pm
It seems that this is only happening for AU in Ableton Live 10. I asked the dev and it's confirmed to be an Ableton Live 10 bug, instantiating multi-channel capable plugins with 9 channels even when running on a stereo track or bus. Hopefully the Ableton devs will resolve this asap.
You can't even use the Reverb 4 AU plugin in Ableton 10 due to that bug. I blame both parties. Jeroen says to contact Ableton, which I have, but that's little comfort to me when trying to open older projects and it simply won't work.

BerryLaCroix
KVRist
60 posts since 9 Apr, 2018

Re: Toneboosters Barricade v4

Post Thu Jun 04, 2020 5:50 pm

dangayle wrote:
Thu Jun 04, 2020 2:12 pm
BerryLaCroix wrote:
Wed Jun 03, 2020 1:45 pm
It seems that this is only happening for AU in Ableton Live 10. I asked the dev and it's confirmed to be an Ableton Live 10 bug, instantiating multi-channel capable plugins with 9 channels even when running on a stereo track or bus. Hopefully the Ableton devs will resolve this asap.
You can't even use the Reverb 4 AU plugin in Ableton 10 due to that bug. I blame both parties. Jeroen says to contact Ableton, which I have, but that's little comfort to me when trying to open older projects and it simply won't work.
Hmm well if a host configures a plugin the wrong way as Ableton 10 does, I can't see how a plugin can resolve this, as the plugin is just doing what it is told to do by the host?

If it tells me anything, it is that the Ableton QA department never tested multi-channel capable plugins :o :scared:

User avatar
dangayle
KVRian
1185 posts since 30 Mar, 2014

Re: Toneboosters Barricade v4

Post Thu Jun 04, 2020 10:16 pm

BerryLaCroix wrote:
Thu Jun 04, 2020 5:50 pm
Hmm well if a host configures a plugin the wrong way as Ableton 10 does, I can't see how a plugin can resolve this, as the plugin is just doing what it is told to do by the host?

If it tells me anything, it is that the Ableton QA department never tested multi-channel capable plugins :o :scared:
I don't disagree, it's just that I would rather than functionality be disabled rather than the entire plugin not working at all. I'm not even using the multi-channel capabilities.

BerryLaCroix
KVRist
60 posts since 9 Apr, 2018

Re: Toneboosters Barricade v4

Post Sat Jun 06, 2020 1:33 am

dangayle wrote:
Thu Jun 04, 2020 10:16 pm
BerryLaCroix wrote:
Thu Jun 04, 2020 5:50 pm
Hmm well if a host configures a plugin the wrong way as Ableton 10 does, I can't see how a plugin can resolve this, as the plugin is just doing what it is told to do by the host?

If it tells me anything, it is that the Ableton QA department never tested multi-channel capable plugins :o :scared:
I don't disagree, it's just that I would rather than functionality be disabled rather than the entire plugin not working at all. I'm not even using the multi-channel capabilities.
Hmm well as TB Reverb 4 is one of the very few great sounding reverb plugins that can handle multi-channel and immersive audio, I'm very dependent on it and would hate it if that functionality would be disabled :o

Let's hope Ableton devs are working on this bug and release a fix soon....! I've filed a bug report with Ableton and perhaps you should do too to get this raised in importance.

Return to “Effects”